Anybody interested in BARRIER_OPERATOR Zwave Command Class?

Has anyone gotten this to work with the Linear GD00Z Garage Opener ? I have the device paired with OpenHab2 using security, but I only see the BARRIER_POSITION channel.

I don’t see the BARRIER_OPERATOR channel. Does anyone have any idea on how to add code for the BARRIER_OPERATOR channel under OpenHAB2 ?

This probably means that the device is not securely included. If the device did not complete secure inclusion, then it won’t even tell you that it supports these classes.

If I remember correctly, people are using this with OH2 if you use the development binding, but I’m not 100% sure without checking.

@chris The device is securely included. I am using the OH2 Development Binding. See pic below:

Please refer to my post: (OpenHab2 and Linear NGD00Z-4 Garage Door Controller)

on details of how I uninstalled the SNAPSHOT binding, installed the development binding, included the device securely, but still don’t see the BARRIER_OPERATOR channel. I only see the BARRIER_POSITION channel.

Are you sure that the BARRIER_OPERATOR command classes are included in the latest OH2 snapshot ?

Any help on this is appreciated.

Well, I’ve not checked recently, but I don’t think it will have been removed - so pretty sure. We implemented it a long time ago now (even for OH1).

@chris could you please take a look at this thread and help me diagnose why I dont see the BARRIER_OPERATOR channel even though the device is included securely.

@ashgupta - this works as intended. What you are likely missing is what I missed originally. I was thinking there would be an open/close “switch” that I could use. It seems there isn’t. What you need is to first ensure the device is securely included, validate by using HABmin to see if Using Security is a green checkmark in attributes. Once that is confirmed, then you need to create a virtual item to use as a switch, or use a Site Map to create a “switch” on the sitemap that will operate the door. The sitemap will use a mapping of 0 and 255 for the two states.

Reference this post in the OH2 Security testing thread: OH2 Z-Wave refactoring and testing... and SECURITY

If you would like to “validate” this before creating the map or virtual item - use the API (REST Documentation under MISC in Addons in PaperUI). You can test sending a 0 and 255 to the controller to validate.

@shawnmix yes it works by sending 0 to close the door and 255 to open the door. It is confusing to new OpenHab users since we are used to a switch to open/close on/off an item.

I am currently working with chris to define channels for the various alarms the device reports.

Hi AshGupta,

I just bought GoControl Garage Door opener and I am trying to configure it. I have installed z-wave binding and through PaperUI I was able to discover the GoControl opener which showed up as Z-Wave Node 3 but had only 1 channel: “Barrier Position”. I added “Barrier Position” in my sitemap but I am not seeing its value changing on tilting of the sensor. Even if it had changed, how would I send command to the opener to open/close? I am not sure how to proceed from here. I would appreciate any feedback you can provide.
I just wanted to add that in the previous post it says “What you need is to first ensure the device is securely included, validate by using HABmin to see if Using Security is a green checkmark in attributes.” I am seeing a “?” for “Using Security” attribute in HABmin. How do I change that to green checkmark?


  1. Make sure you are using the secure binding from
    The default z-Wave binding in OH2 doesn’t have security

  2. Then exclude and include the device in your network and in Habmin make sure that the device is showing up as Secure. Paper-UI doesnt display the security status of the device.

  3. Once you have the device securely included you will see that the Barrier_Position number is 0 when closed and 255 when opened. If you have got this then your garage door opener is working with OpenHab2.

  4. You send number “0” to Close the Door and number “255” to open the door. Below is my item and sitemap definition for this.

Number Garage_Gate_Position     "Garage Gate [MAP(]"   <lineargarage>
0="0 - CLOSED"
252="252 - CLOSING"
253="253 - STOPPED"
254="254 - OPENING"
255="255 - OPEN"
Switch item=Garage_Gate_Position mappings=[0="CLOSE", 255="OPEN"]

Just to clarify, shall I uninstall the current z-wave binding that I installed through PaperUI? I have never manually installed a biding before so not sure about how to add the jar file that you sent the link for. Shall I copy it in /srv/openhab2-sys/addons as-is, and then try to find items again?

Yes uninstall the current binding.

Go to the link and download the latest secure binding. Put it into openhab2/addon folder

Read the first 20 posts in that link. Somewhere you will find directions on how to install the serial binding and then how to restart the z-Wave binding.

Also install Habmin

Then follow my directions above.

Here is what I did:
Removed all the Items / Things related to z-wave and uninstalled z-wave binding from PaperUI.
Copied the jar file to /usr/share/openhab2/addons
Rebooted my Raspberry Pi
Using HABmin, added Z Wave Serial Controller, configured the port, which discovered the Garage Door Controller. Added the garage door controller and then the “Barrier Position Channel”. I still don’t see the green checkmark for “Using Security”. Did I miss any step? Here is the screenshot from HABmin:

And here is my log:

2017-04-17 18:41:58.881 [ERROR] [ing.zwave.handler.ZWaveSerialHandler] - ZWave port is not set.
2017-04-17 18:42:31.090 [INFO ] [ing.zwave.handler.ZWaveSerialHandler] - Stopped ZWave serial handler
2017-04-17 18:42:31.685 [INFO ] [ing.zwave.handler.ZWaveSerialHandler] - Connecting to serial port '/dev/ttyACM0'
2017-04-17 18:42:31.717 [INFO ] [ing.zwave.handler.ZWaveSerialHandler] - Serial port is initialized
2017-04-17 18:42:31.732 [INFO ] [ve.internal.protocol.ZWaveController] - Starting ZWave controller
2017-04-17 18:42:31.737 [INFO ] [ve.internal.protocol.ZWaveController] - ZWave timeout is set to 5000ms. Soft reset is false.
2017-04-17 18:42:35.128 [INFO ] [age.SerialApiGetInitDataMessageClass] - NODE 1: Node found
2017-04-17 18:42:35.130 [INFO ] [age.SerialApiGetInitDataMessageClass] - NODE 2: Node found
2017-04-17 18:42:35.134 [INFO ] [age.SerialApiGetInitDataMessageClass] - ZWave Controller using Controller API
2017-04-17 18:42:35.136 [INFO ] [age.SerialApiGetInitDataMessageClass] - ZWave Controller is Primary Controller
2017-04-17 18:42:35.138 [INFO ] [age.SerialApiGetInitDataMessageClass] - ------------Number of Nodes Found Registered to ZWave Controller------------
2017-04-17 18:42:35.141 [INFO ] [age.SerialApiGetInitDataMessageClass] - # Nodes = 2
2017-04-17 18:42:35.143 [INFO ] [age.SerialApiGetInitDataMessageClass] - ----------------------------------------------------------------------------
2017-04-17 18:42:35.802 [INFO ] [g.discovery.internal.PersistentInbox] - Added new thing 'zwave:device:15b7e4b4fb7:node2' to inbox.

@ashish use Habmin to exclude, PaperUI to include and then Habmin to check status.

I have found that PaperUI doesn’t exclude properly and Habmin doesn’t include properly.

HABmin will include properly - it sends EXACTLY the same thing to the binding as PaperUI. However, PaperUI is not good for configuration, and even worse at sending actions (such as Exclude) - I’ve been trying to improve it over the past couple of weeks but it still needs some work before I would suggest to use it.

I did a fresh openhab2 (openhabian) install on Raspberry Pi. Added the following bindings:
Yamaha Receiver
openHAB cloud connector
Then I copied z-wave binding from OH2 Z-Wave refactoring and testing... and SECURITY.
I launched HABmin and added the z-wave controller and configured the port. I then turned discovery on and unplugged the z-wave controller to include GoControl Garage Door opener. After including the garage opener, I plugged the z-wave stick back in Pi but after the garage opener didn’t get discovered, I rebooted the Pi. Now the garage opener showed up in discovery and I added it.

“Using Security” was still not showing green. Here is the log:

2017-04-30 14:40:23.375 [INFO ] [ui.habmin.internal.servlet.HABminApp] - Started HABmin servlet at /habmin
2017-04-30 14:40:31.648 [INFO ] [ing.zwave.handler.ZWaveSerialHandler] - Connecting to serial port '/dev/ttyACM0'
2017-04-30 14:40:31.796 [INFO ] [ing.zwave.handler.ZWaveSerialHandler] - Serial port is initialized
2017-04-30 14:40:31.910 [INFO ] [ve.internal.protocol.ZWaveController] - Starting ZWave controller
2017-04-30 14:40:31.914 [INFO ] [ve.internal.protocol.ZWaveController] - ZWave timeout is set to 5000ms. Soft reset is false.
2017-04-30 14:40:35.483 [INFO ] [age.SerialApiGetInitDataMessageClass] - NODE 1: Node found
2017-04-30 14:40:35.486 [INFO ] [age.SerialApiGetInitDataMessageClass] - NODE 5: Node found
2017-04-30 14:40:35.489 [INFO ] [age.SerialApiGetInitDataMessageClass] - ZWave Controller using Controller API
2017-04-30 14:40:35.491 [INFO ] [age.SerialApiGetInitDataMessageClass] - ZWave Controller is Primary Controller
2017-04-30 14:40:35.492 [INFO ] [age.SerialApiGetInitDataMessageClass] - ------------Number of Nodes Found Registered to ZWave Controller------------
2017-04-30 14:40:35.495 [INFO ] [age.SerialApiGetInitDataMessageClass] - # Nodes = 2
2017-04-30 14:40:35.497 [INFO ] [age.SerialApiGetInitDataMessageClass] - ----------------------------------------------------------------------------
2017-04-30 14:40:54.547 [ERROR] [alization.ZWaveNodeInitStageAdvancer] - NODE 5: SECURITY_INC State=FAILED
2017-04-30 14:40:57.992 [INFO ] [g.discovery.internal.PersistentInbox] - Added new thing 'zwave:device:15bbf4f4afb:node5' to inbox.

A couple of weeks ago when I was trying to add this device, I saw only one channel but now I am seeing 17, so not sure if I am doing something wrong. Here are the channels that I am seeing:

Barrier State
System Alarm (7 channels)
Access Control Alarm (5 channels)
Low battery alarm
Tamper Alarm
General Alarm (2 channels)

The 17 channels were added only a couple of weeks back. Ignore all of the alarm channels. You need to get only the BARRIER_STATE channel working.

Exclude the device from the network. In PaperUI change config to include ALL Devices securely. Include the GDC securely. Verify that it is securely included in HABMIN. Then everything will work.

I excluded the GDC and then using PaperUI set the Z-wave controller config to include All Devices securely.

I then included GDC through HABmin (click on discovery + z-wave binding --> unplug z-wave stick --> include GDC by pressing button on stick and GDC --> plug z-stick back in Pi --> reboot pi --> Add GDC to Things). After rebooting Pi, my z-wave controller binding stopped showing any properties and displayed a Delete icon. Even the added GDC displayed the same behavior.

Now if click on discovery, I don’t see Z-wave binding in the drop down. The logs still show that security failed:

2017-05-01 17:46:42.384 [INFO ] [age.SerialApiGetInitDataMessageClass] - ZWave Controller using Controller API
2017-05-01 17:46:42.388 [INFO ] [age.SerialApiGetInitDataMessageClass] - ZWave Controller is Primary Controller
2017-05-01 17:46:42.393 [INFO ] [age.SerialApiGetInitDataMessageClass] - ------------Number of Nodes Found Registered to ZWave Controller------------
2017-05-01 17:46:42.398 [INFO ] [age.SerialApiGetInitDataMessageClass] - # Nodes = 2
2017-05-01 17:46:42.402 [INFO ] [age.SerialApiGetInitDataMessageClass] - ----------------------------------------------------------------------------
2017-05-01 17:47:03.813 [ERROR] [alization.ZWaveNodeInitStageAdvancer] - NODE 6: SECURITY_INC State=FAILED
2017-05-01 17:47:07.292 [INFO ] [g.discovery.internal.PersistentInbox] - Added new thing 'zwave:device:15bbf4f4afb:node6' to inbox.

I don’t see any property/channel to add. Any suggestions please?

Maybe start from a new install of Openhab

I tried reinstalling several times from scratch but couldn’t add the garage door securely. “Using security” always showed up as red x. I must be missing something obvious.

I have a Raspberry Pi 2, Aeotec by Aeon Labs ZW090 Z Stick, and GoControl/Linear GD00Z-4 Z-Wave Garage Door Opener. I am installing openhabian image, and then openhab2. I used the z-wave binding from here (not adding it through PaperUI --> Addons): OH2 Z-Wave refactoring and testing... and SECURITY. In PaperUI, I changed z-wave controller config to include ALL Devices securely. I then used HABmin to discover z-wave binding things, and within 30 seconds I included garage door opener. I then added the newly discovered garage door opener as a Thing. When I check the attributes of this Garage door opener, the security shows up as red x.

Any thoughts before I give up on z-wave :confused:

I’m following this same thread, I have the same issue.