Aoetec z-stick gen5 (Z-wave Node 003) appears as OFFLINE - COMMUNICATION_ERROR Please help

Platform information:

  • Hardware: Raspberry Pi 3 Model B Rev 1.2
  • OS: OpenHAB
  • openHAB version: openHAB 2.5.5-1 (Release Build)

Hi everyone, I bought a Aeotec Z-Stick Gen5 and I was trying to connect it to the RPI I followed the steps:

  1. I downloaded the Z-wave binding
  2. Placed the stick into the RPI
    3.In Paper UI, in inbox I clicked on the + and selected the Z-wave binding
    4.Configured the port, which is /dev/ttyACM0 , I checked this in Putty, where the ACM0 port disappeared when I plugged the stick out of the RPI.
  3. Then I when to inbox again and searched for thing through Z-Wave Binding, found Z-Wave Node 003 and added it.
  4. I went to things however it displayed this messages OFFLINE - COMMUNICATION_ERROR
  5. I went on and looked around and found this topic [SOLVED]Connecting Aeotec Z-Stick Gen5 to OpenHAB, running on Synology and I though I found a solution.
  6. I followed the steps by @robjkamp tried it in multiple ways however it did not work.

And i do not know what else to do anymore. I am a beginner who started few days ago and any help regarding that problem would be highly appreciated.

This is the picture of the things folder

This is the thing when I open it

These are my logs

This is the code I wrote following @robjkamp

Check if zstick shows up under same port after plugging in. At least in my case those devices often got different port for some reason after reconnecting (sometimes ttyACM0, other times ttyACM1)

It’s true that if you unplug the stick the port is often not released and that will lead to the assignment of a different port the next time you plug it in. In that case, however, it is the stick that is reported as offline.

If OH found your Node 003 and your serial controller reports as online then your stick is likely not the problem here.

It will help if you tell us a little more about the node you’re trying to activate. What device and manufacturer is it? If battery powered, have you read the section of the user manual about how to wake up the device during inclusion? If the device is plugged in, have you tried to exclude the device from the network and then include it again (sometimes the inclusion fails to complete properly)? Try including the device by using OH to set the controller into include mode instead of removing from the computer (this is easier in HABmin than in PaperUI).

Follow the binding instructions and submit debug level logs. The default level of logging is not very useful for troubleshooting.

the Z-Wave Node 003 is the Z-wave stick (Aoetec Z-stick Gen5) I was watching a tutorial on youtube and thats what the guy did

The USB stick is the device that controls the entire network. It is assigned to Node 1 by default. That has been properly connected to OH when you added the serial device (just another name for your USB stick) and configured the computer port it was assigned to.

The way this binding works, when your controller is correctly connected it will detect all the other z-waves devices that have been included in that controller’s network (the controller assigns node numbers to each device when you perform the network inlcusion) and it will put those nodes with their assigned number in your inbox allowing you to create things for each of those individual devices in your network.

Node 003 is some other z-wave device, a sensor or a switch or something: perhaps one that you tried connecting to the stick prior to plugging it into the computer. If you previously tried to connect some other device and now are not using that device, then Node 3 is in fact offline and OH is properly reporting this. If it is a device that you are still expecting to be able to use then you need try and figure out why it isn’t connecting properly.

1 Like

Ok so the Z-stick is working normaly however for some reason I still have that weird z wave device that i have no idea what it is but also I get even more devices that are not recognized which do not connect to anything that I simply have to ignore.

thank you everyone that helped

If a device shows up in your inbox with a human readable label (e.g., your node 6 - FGD212 Dimmer 2) then that device is properly included in the network, communicating its identifying information to OH, and using that identifying information OH can find that device the z-wave database in the binding. In this case that device can be added as a thing and is fully available for control through OH.

If a device shows up in your inbox with the node number followed by a series of alphanumeric codes in parentheses (e.g., (0371:0104:00BD:1.1)) then the device is properly included in your network and sending its identifying information, but is not yet in the database in the binding and you will not be able to control it with OH until it is added to the database.

If a device only shows up as a node and number (e.g., your nodes 3, 4, 5, & 7) then that device is not sending any identifying information to OH. It is possible that this is a battery operated device that hasn’t been woken up enough times for the controller to finish inclusion and collect the identifying information. It is also possible that the device is simply not properly included in the network due to some failure in the inclusion process, or that device has been previously included in the network and subsequently excluded (but not properly) and is now an orphaned node with no device associated with it.

The device (node 6 - FGD212 Dimmer 2) is a ghost device because it used to work but then it stopped and I had to exclude it. Then when I would pair the same device node 6 would show up together with a new device (e.g., your node 8 - FGD212 Dimmer 2) which is esentially the same device only that now node 8 would oparate the lights that node 6 used to operate and node 6 would now be unresponsive to any given inputs like turning thoes lights off. If you maybe know how to get rid of thoes ghost nodes that would be really helpful but thank you very much for your help anyways.

Here’s another post which describes this problem with ghost nodes along with a fix to remove them.


As you are using the Aeotec stick you may also wish to utilize their backup software before trying any network management so that you can restore your stick in case of problems.

1 Like

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.