App broken after upgrade

Hi, I’m using Openhab 2.5 and after ios app upgrade I can’t see sitemaps anymore and app crash. Any help please?

Similar issue here. Since upgrade, I get a warning “Openhab sent back an empty sitemap list”. OH 2.5 and IOS 16.0.2

With openhab 2.2.0 the new ios app works
With openhab 2.3.0 the app crash and when not crash I can’t see any sitemap.

Please tell me how to help to solve this issue!

Same here. Using OpenHAB 2.4.0, the App is on iOS 16 and today got updated to Version 2.4.54. Now it is not working anymore, showing “Openhab sent back an empty sitemap list” error. Please help :slight_smile:

Using http(s)://<youropenhab>/rest/? I can see


* version: "1",

* links:[]


Version 1 was the issue in older ios app version already fixed. Could that be the problem?

Same issue here on iOS 16.1 and OpenHAB 2.4.0. Just updated to ver. 2.4.54.

App ver 2.4.53 is OK, ver 2.4.54 bug as described above.

Hi, any news?

Hi is it possible to restore 2.4.53 version?

I have submitted a bug report trough Test Flight, before this iOS version was released. Describing the problem on older 2.5 version. But still it was released.

Is there no tracking of Test Flight’s reports before signing it off?

@Kai What is the proper way of reporting bugs in test version of iOS app, please?

Same here. OpenHAB liefert eine leere Sitemap-Liste. Hope there will be an app Update soon….

Same issue here

I figured out that the internal URL (IP is not working anymore. With the external URL ( the Sitmap still gets loaded!

The new version 2.4.54 claims to have an “Advanced reachability logic” but unfortunately it is not working! I just erased the port no. from the internal IP to force to load the external URL.

But this is not really fixing the problem…

I got it back to work - somehow.

Have you included the protocol for your internal URL, like this: ?

Ignore SSL: OFF
Send credentials always: OFF

Et voila! The sitmap was loading again via the internal URL.

Let me know if that helped you as well!?

1 Like

Tried OpenHab on an iPhone 11 Pro and also on an iPad (7th generation), both devices with current iOS 16.1 (20B82).
OpenHab app version iPhone: 2.4.54 (1580410525),
OpenHab app version iPad: 2.4.53 (1580410519).

Unfortunately your solution didn’t work for me.
The error message says: “Fehler. URLSessionTask failed with Error: Zeitüberschreitung bei der Anforderung”.

Two screenshots of my settings / error message:

Same problem here: After a restart of the phone I can open the app and get an empty sitemap error. If I change something in the settings (tried SSL as suggested above and different type of icon rendering png/svg) the app crashes and keeps crashing on every start.

Exaclty, any tip or solution?
Is it possible to have old version?


From “Sven via openHAB Community” <>
Date 11-Nov-22 5:46:04 PM
Subject [openHAB] [Apps & Services/iOS App] App broken after upgrade

Please wait, there is a new version on the way, solving the issues.


@hmerk Thanks!

Just for information:
My iPad updated the app to version 2.4.56 (1580410531) but still can not connect to the server.

Thanks for your engagement and the investigation!

Have a nice weekend!