App crashes on start since yesterdays update - iOS 15.2.1

Hey everyone.

Looks like since iOS App Store Update of openhab app from yesterday (2.4.39) app crashes on every start (iPhone with 15.2.1).

We start the app, can see out sitemap and than app crashes and we are back to main menu. Happens on two different devices (iPhone 8 Plus and iPhone 12) in the exact same way.

Openhab itself is running fine. I can access the ui via brother, all rules are running fine. Looks like it’s the app itself. Anyone have the same issue or experience with this.

Problem is I’m at work and my wife is at home and can’t change the temperature for the heating… she is bringing my stresslevel up a lot …

1 Like

Hello!
Same crashes on iPhone with iOS 15.3 and app 2.4.39 (openHAB 3.2).

I can open the app and the sitemap is loaded. It is possible to use all elements that are visible initially. It is also possible to call groups. However, the app crashes continuously when scrolling, so elements at the bottom of the sitemap are not accessible.

IOS app gives error emtpe site map
Openhab 2.3
anyone else ?

Same issue here: I am using OpenHAB 2.3.0 and everything works fine (webpage, App on Android devices, webpage on Iphone) except the Iphone App (Version 2.4.39). With the App I only get an error message stating, that the site map is empty. This happens regardles if I try to connect locally or via the openhab cloud.

I’ve got also problems since the update to 2.4.39. Before it was working fine. I can surpress the crash if I rename the icons folder on my raspberry (classic to classic_bak) for example. Doing so, I don’t see any icons but the IOS Application doesn’t crash anymore. I use SVG icons.
The Web Version is running fine.

I was able to prevent the crashes by removing the “pantry” icon from the sitemap. Since then everything runs stable.
The icon is available in the directory and has been included for a long time. Why it causes the crashes in the current version I can not understand.

1 Like

yes in fact that helped. i switched to a different icon instead of pantry and no it is working

Yes, same for me. This pantry icon was also the root cause for my problems. I’ve deleted it and now the application is running stable.

Hi, I have the same error on my iphone with iOS 15.3 and my updated ipad. With an Android phone it still works well.

i removed all icons from my site map - no change. issue persists.
Id say there is issues with the App release - 2.4.39

would be good if the app developer responded here or even acknowledged the issue

May be related to this:

No, as it is working with BasiUI sitemaps as it should. No crash over here.

Same here. App crashes since a couple of days - but only, if I scroll down to a certain position (children’s room). This is the same on two different sitemaps with similar entries. On a smaller sitemap I don’t have issues.

Pantry SVG is buggy (can‘t be processed by SVGKit) It was corrected a year ago on server side

Surely the app shouldn’t crash due to that, but gracefully fall back to ‘no icon’ in such a case though?

I would love to have a proper graceful handling of SVG icons.

Unfortunately, on iOS there is no public access to the internal SVG parser. For the iOS openHAB app we therefore make use of SVGKit. We contributed to handle some bugs there, but pantry.svg was found to be non-compliant with the SVG standard: https://github.com/SVGKit/SVGKit/issues/708.

any help either on the graceful handling in SVGKit or on a safer integration into a Swift would be more than welcome.

yup, that was it …

The developers are aware of this issue and they already released version 2.4.41 of the iOS client on TestFlight. I tested that and the issue is solved. If you want to try it before the official release, install TestFlight from the App Store, then go here to get the latest beta version.

Thanks for the fast response. It is working again.

My app is still crashing using the TestFlight app :frowning: Did submit a crash log.