APT Repo Public Key Expiration & Update

The issue with the stable repo has been resolved now. I’d reccomend using the bintray server for the stable releases.

3 Likes

So you recommend me and others who changed the file openhab2.list according to @mstormi’s
solution should change it back to the original “https://dl.bintray.com/openhab/apt-repo2 stable main”?

Both repositories will continue to work fine, but the Bintray server is better suited to distribution-time releases than the jfrog (artifactory) server.

I could try whatever I want - I always got GPG errors for the OpenHAB repos, both jfrog and bintray. This is what worked for me in the end:

Delete apt status information:

sudo rm -rf /var/lib/apt/lists/*

Load bintray key again:

wget -qO - 'https://bintray.com/user/downloadSubjectPublicKey?username=openhab' | sudo apt-key add -

After that, apt-get update started working again.

4 Likes

Any idea why I am getting an error when running the command?

wget -qO - 'https://bintray.com/user/downloadSubjectPublicKey?username=openhab' | sudo apt-key add -

Gives me:

curl: option -: is unknown
curl: try 'curl --help' or 'curl --manual' for more information
gpg: no valid OpenPGP data found.

You probably have messed up your installation or are using some exotic OS, but ‘curl’ is not part of the apt-key script (at least not on Raspbian). Eventually you have created an misdirected alias, too.

And please follow community guidelines when posting from now on.

How to ask a good question / Help Us Help You - Tutorials & Examples - openHAB Community

Same problem here with a rpi4, raspbian (buster): stable release is not signed.

Tried removing all files under/var/lib/apt/lists, but did not work…

Anybody having the same problem?

Thanks so much.

1 Like

I might have accidentially destroyed the signature last night… Will see to get it working asap again, sorry!

1 Like

The repo should be working now!

3 Likes

Doesn’t work for me.
Just tried on Debian 9.9 for the stable release with the bintray server.

Hi @matzR

Could you send a copy of the error you’re getting? I’ve just checked and the repo is working for me.

Hei Guys,
can somebody tell me where i can find the Home UUID for the camera thing in the Paper UI

Please open a new thread. In that thread, please include:

  • version of OH you are running
  • what binding you are talking about (IP Camera binding?)
  • what you have done thus far to solve the problem.

This question is not related in any way to this thread.

Kai, it’s working fine now, thanks a lot!

Sorry, I have been out for a while, could not have tried earlier.

Cheers!

E: The repository ‘http://dl.bintray.com/openhab/apt-repo stable Release’ is no longer signed.
N: Updating from such a repository can’t be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Tried:

wget -qO - ‘https://bintray.com/user/downloadSubjectPublicKey?username=openhab’ | sudo apt-key add -

But same result.

Can I ask which instructions you’re following?

The sources file (e.g. /etc/apt/sources.list.d/openhab2.list) should contain:

deb https://dl.bintray.com/openhab/apt-repo2 stable main

Your file currently misses the ‘s’ in ‘https’ and the ‘2’ in ‘apt-repo2’ so is currenly pointing to an old repo.

Thanks!
My openhab2.list file was correct, but I had still the openhab.list file there as well.
Removed this now and the update worked.

Thanks a lost for your help!

Thanks to a clue from @matzR I figured out my problem. The openhab2 repo is signed but not the openhab (1.8) repository. Is this intentional?

I know you’re encouraging people to move to openhab2 but until there’s an insteon binding for openhab2 I’m stuck (but very happy with) with openhab 1.8. I want to upgrade my server to buster but I’m not keen to use the [trusted=yes] workaround.

Cheers from a long-time happy openhab user,
Chris

You are aware that OH 2 can and does run OH 1.x bindings right? You may choose to stay on OH 1.8, but the lack of a 2.x version of any binding doesn’t mean you are stuck on OH 1.8.

I am aware of that possibility but I didn’t want to distract this thread by getting into the big issue of OH2’s future and upheaval (from a relative outsider’s point of view).

Suffice to say that, for me personally, I’m looking at an OH2 Insteon binding being a milestone at which I’ll put in the effort to upgrade. Otherwise I may look at other options if there’s no way to keep on with OH. :frowning_face:

So, I take it that not signing the old repo is intentional?