APT Repo Public Key Expiration & Update

All,

Our public key for the APT repos (snapshot/milestones/releases) expires today. We have just extended its validity until 2023 (thanks @theo!), but you will have to make sure that your Linux installation is aware of the new key, otherwise your will have problems when updating openHAB through apt. All you need to do execute:

wget -qO - 'https://bintray.com/user/downloadSubjectPublicKey?username=openhab' | sudo apt-key add -

Best regards,
Kai

22 Likes

This will affect OpenHABian users too . won’t it?

It will yes, but updating from the openHABian menu will do this step for you.

EDIT: If you select option 3 (stable) or 40 (testing/unstable) in the menu.

3 Likes

Using Raspbian here. Already updated, gave me OK message. We’re good up until 2023 again. :slight_smile:

Thanks!

1 Like

Hello, I’m using Raspbian with Openhabian menu, didn’t update it for me, hence why I’m here in this thread now.

I can confirm chubber’s experience. The key did not update when I upgraded through openhabian-config. I had to update the key manually. I figured I had something non-standard in my config because I was having other apt issues at the same time.

1 Like

It did not update for me from openhabian-config either :frowning:
I updated manually though.

Apologies all, slight oversight from me!

For openHABian to update the key you’d need to select option 3 (for stable) or 40 (for the latest testing/snapshot). It’s probably easier to put in the command at the first post though and I’ll see if it’s worth putting the function in the general upgrade option.

2 Likes

Works like charm, thanks man.

  • Platform information:
    • Hardware: RPi 3B+, Intel 128 GB SSD, Aeon labs Z-Stick Gen 5
    • OS: Openhabian
    • Java Runtime Environment: Included in Openhabian
    • openHAB version: 2.4 SNAPSHOT build 14?

I have tried the manuel update of the key by doing the following command:
[17:02:45] openhabian@Guard:~$ wget -q0 - ‘https://bintray.com/user/downloadSubjectPublicKey?username=openhab’ | sudo apt-key add -

And got the following message:
[sudo] password for openhabian: wget: invalid option – ‘0’
Usage: wget [OPTION]… [URL]…

Try `wget --help’ for more options.

Sorry, try again.
[sudo] password for openhabian:XXXXXXX (entered password)
gpg: no valid OpenPGP data found.

In the command is -q0 = q and figure zero or q and capital letter O?
Have I done something wrong?

Looking at the man page, I think it is a capital O. I just copied from the first post here & it worked.

Thanks, it worked!

Thank you, My 2.5.0-M1-1 wasn’t updating either after “The following signatures were invalid: EXPKEYSIG…” messages.
Did the command manually - all good now.

I’m trying to do a fresh OpenHabian installation (openhabian-pi-raspbian-201908050414-gitca0976f-crc6a66b5a1.img.xz) and it’s failing.

2019-08-09_18:55:54_CDT [openHABian] Installing or upgrading to latest openHAB release (stable)... FAILED (apt)          
2019-08-09_18:56:10_CDT [openHABian] Initial setup exiting with an error!

I tried running apt and I’m seeing the key error:

[19:18:52] root@openhab:/etc/apt# wget -qO - 'https://bintray.com/user/downloadSubjectPublicKey?username=openhab' | sudo apt-key add -
OK
[19:23:34] root@openhab:/etc/apt# apt update
Hit:1 http://raspbian.raspberrypi.org/raspbian buster InRelease
Hit:2 http://archive.raspberrypi.org/debian buster InRelease          
Ign:3 https://dl.bintray.com/openhab/apt-repo2 stable InRelease       
Get:4 https://dl.bintray.com/openhab/apt-repo2 stable Release [6,051 B]
Ign:5 https://dl.bintray.com/openhab/apt-repo2 stable Release.gpg
Reading package lists... Done
E: The repository 'https://dl.bintray.com/openhab/apt-repo2 stable Release' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Is there something else going on with the repo tonight?

2 Likes

Is there something else going on with the repo tonight?

Unfortuantely there is… at the moment, Bintray can’t sign the repository, which is why you get this error. Hopefully this will be fixed when the right person can get to the problem, but if not I will get a workaround to you as soon as I can.

1 Like

Hi there,

Decide to install OpenHab today, but it seems there’s a problem with the repository. The boot script fails when trying to install openhab2… doind it through the configuration tool also fails:
$ apt-get -y install openhab2
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package openhab2
FAILED (apt)

Any help is welcome.

Thx
BJR

Thanks, @Benjy.

+1
same error

Can one see, if the key is updated ?

Same Error.