openHAB Milestone builds

Openhabian is just a script system to manage OpenHAB. If you select the testing version from openhab-an-config, it should install 2.5M3.

Hmmm… I tried that, but something is wrong.
It does not start and I get plenty of error messages:
After starting via
sudo /etc/init.d/openhab2 start
OH does not seem to start.
No access via karaf, nothing via
No PaperUI or eny log entry neither in events.log nor openhab.log

I found a log in /var/lib/openhab2/cache/ which contains:

!SESSION 2019-09-12 18:11:02.486 -----------------------------------------------
java.vendor=Azul Systems, Inc.
BootLoader constants: OS=linux, ARCH=arm, WS=gtk, NL=de_DE
!ENTRY org.openhab.ui.iconset.climacons 4 0 2019-09-12 18:11:02.488
!MESSAGE FrameworkEvent ERROR
org.osgi.framework.BundleException: Could not resolve module: org.openhab.ui.iconset.climacons [107]
  Unresolved requirement: Import-Package: org.eclipse.smarthome.core.i18n

        at org.eclipse.osgi.container.Module.start(
        at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(
        at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(
        at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(
        at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(
        at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(
        at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(
        at org.eclipse.osgi.framework.eventmgr.EventManager$

I ran openhabian config again including update / upgrade and test (M 2.5 3).
Now it looks better…

I might come back with one or the other error :wink:

Yes, M3 is available via openhabian system update (assuming you are on testing branch).

On a raspi 3, I just finished upgrading. I let it run for several minutes, did a sudo reboot then waited a few more minutes for it to settle down. Looks good.

Seems when I do an milestone update I have to do a sudo reboot twice. Let it settle out and works great.
Thank you to all that make OH possible!
We are OH Strong :muscle:

1 Like

Hello Kay

Many thanks for the new version of the program.
I have a question, I always get an error message when updating from “”. do you have any idea why?



All questions related to this latest milestone build can be posted here:

@jpk8201 Did you see this page: APT Repo Public Key Expiration & Update It should show up on top of the forum (unless you click it away)


Oh, no, I missed that. Thank you very much!

Hmm… Untill a few minutes ago I was running openhab 2.5 M1.
I just ran openhabian-config #02 “Upgrade all installed software packages to their newest version”.
(I was NOT trying to upgrade to the latest Milestone)

After this, PaperUI tells me, that I´m using openhab 2.5 M2.
How is that possible?

You are the one with the log files. You tell us!. :smiley:


I´m not really sure where to find the logfile for this… But this is the total session from the promt:

[13:49:19] openhabian@openHABianPi:~$ sudo openhabian-config
2019-09-13_13:49:33_CEST [openHABian] Checking for root privileges... OK
Get:1 stretch InRelease [25.4 kB]
Get:2 stretch InRelease [15.0 kB]
Hit:3 stretch InRelease
Ign:4 testing InRelease
Get:5 testing Release [6,053 B]
Hit:5 testing Release
Get:6 stretch/main armhf Packages [11.7 MB]
Hit:7 stable InRelease
Fetched 11.7 MB in 10s (1,070 kB/s)
Reading package lists... Done
2019-09-13_13:49:50_CEST [openHABian] Loading configuration file '/etc/openhabian.conf'... OK
2019-09-13_13:49:50_CEST [openHABian] openHABian configuration tool version: [master]v1.5-519(9af5552)
2019-09-13_13:49:51_CEST [openHABian] Checking for changes in origin... Updates available...
2019-09-13_13:49:56_CEST [openHABian] Updating myself... OK - Commit history (oldest to newest):

e9eaa69 - Revert "Temporarily move stable repo (#663)" (#717) (2 days ago) <Ben Clark> N
 functions/openhab.bash | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

openHABian configuration tool successfully updated.
Visit the development repository for more details:
The tool will now restart to load the updates...

2019-09-13_13:49:58_CEST [openHABian] Checking for root privileges... OK
Hit:1 stretch InRelease
Get:2 stretch InRelease [25.4 kB]
Ign:3 testing InRelease
Hit:4 stretch InRelease
Get:5 testing Release [6,053 B]
Hit:5 testing Release
Hit:6 stable InRelease
Fetched 25.4 kB in 3s (8,242 B/s)
Reading package lists... Done
2019-09-13_13:50:08_CEST [openHABian] Loading configuration file '/etc/openhabian.conf'... OK
2019-09-13_13:50:08_CEST [openHABian] openHABian configuration tool version: [master]v1.5-520(e9eaa69)
2019-09-13_13:50:10_CEST [openHABian] Checking for changes in origin... OK
2019-09-13_13:50:26_CEST [openHABian] Updating repositories and upgrading installed packages...
$ wget -O openhab-key.asc
--2019-09-13 13:50:26--
Resolving (
Connecting to (||:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: unspecified [application/octet-stream]
Saving to: ‘openhab-key.asc’

openhab-key.asc                                             [ <=>                                                                                                                            ]   3.14K  --.-KB/s    in 0.001s

2019-09-13 13:50:26 (3.43 MB/s) - ‘openhab-key.asc’ saved [3219]

$ apt-key add openhab-key.asc

$ apt-get --yes upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages will be upgraded:
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 74.3 MB of archives.
After this operation, 2,751 kB of additional disk space will be used.
Get:1 testing/main armhf openhab2 all 2.5.0~M2-1 [74.3 MB]
Fetched 74.3 MB in 14s (5,167 kB/s)
apt-listchanges: Reading changelogs...
(Reading database ... 43871 files and directories currently installed.)
Preparing to unpack .../openhab2_2.5.0~M2-1_all.deb ...
Unpacking openhab2 (2.5.0~M2-1) over (2.5.0~M1-1) ...
Setting up openhab2 (2.5.0~M2-1) ...

Configuration file '/var/lib/openhab2/etc/org.ops4j.pax.logging.cfg'
 ==> Modified (by you or by a script) since installation.
 ==> Package distributor has shipped an updated version.
   What would you like to do about it ?  Your options are:
    Y or I  : install the package maintainer's version
    N or O  : keep your currently-installed version
      D     : show the differences between the versions
      Z     : start a shell to examine the situation
 The default action is to keep your current version.
*** org.ops4j.pax.logging.cfg (Y/I/N/O/D/Z) [default=N] ? N
Installing new version of config file /var/lib/openhab2/etc/ ...

[openHAB] Performing post-update tasks for version 2.5.0:

[openHAB] Listing important changes for version 2.5.0:
  Warning:  senseBox Binding: The senseBox binding is now using Units of Measurements, and the channel name for Illuminance has changed. The Items must be reconfigured.
  Warning:  Vitotronic Binding: The following channels have been renamed: 'outsite_temp' to 'outside_temp', 'pelletburner:power' to 'pelletburner:powerlevel', 'party_temp' to 'party_temp_setpoint' and 'save_temp' to 'save_temp_setpoint'
  Warning:  OneWire Binding: Some thing types have changed and need to be updated in textual configurations. See documentation for further information.
  Warning:  REST Docs: This add-on is now part of the UIs. When installing it using textual configuration, update 'services/addons.cfg' by removing 'restdocs' from 'misc' and add it to 'ui' instead.
  Warning:  EnOcean Binding: Channel 'receivingState' has been removed, because this was a string containing many information. For this, there are three new channels: 'rssi', 'repeatCount' and 'lastReceived'.
  Warning:  Mail Action: The mail action has been replaced by a new mail binding.
  Warning:  Homekit: Some tags have been renamed. Old names will not be supported in future versions. Please check documentation.
  Warning:  Pushbullet Action: The pushbullet action has been replaced by a new pushbullet binding.
  Warning:  DarkSky Binding: The item type of `rain` and `snow` channels have been changed to `Number:Speed`.

Processing triggers for systemd (232-25+deb9u12) ...
Updating FireMotD available updates count ... 2019-09-13 13:51:50,771: FireMotD: Error: Template folder doesn't exist. Upgrading from an older version? Please run make again or run the install function "FireMotD -I -v".

$ java_install_or_update
openjdk version "1.8.0_222"
OpenJDK Runtime Environment (Zulu8.40.0.178-CA-linux_aarch32hf) (build 1.8.0_222-b178)
OpenJDK Client VM (Zulu8.40.0.178-CA-linux_aarch32hf) (build 25.222-b178, mixed mode, Evaluation)

$ systemctl stop openhab2.service
openjdk version "1.8.0_222"
OpenJDK Runtime Environment (Zulu8.40.0.178-CA-linux_aarch32hf) (build 1.8.0_222-b178)
OpenJDK Client VM (Zulu8.40.0.178-CA-linux_aarch32hf) (build 25.222-b178, mixed mode, Evaluation)
2019-09-13_13:51:55_CEST [openHABian] Installing Java Zulu 32-Bit OpenJDK...
$ wget -nv -O /tmp/openhabian.TWW0P/zulu8.tar.gz
2019-09-13 13:52:17 URL: [175560479/175560479] -> "/tmp/openhabian.TWW0P/zulu8.tar.gz" [1]

$ update-alternatives --remove-all java

$ update-alternatives --remove-all javac

$ update-alternatives --install /usr/bin/java java /opt/jdk/zulu8.40.0.178-ca-jdk1.8.0_222-linux_aarch32hf/bin/java 1083000
update-alternatives: using /opt/jdk/zulu8.40.0.178-ca-jdk1.8.0_222-linux_aarch32hf/bin/java to provide /usr/bin/java (java) in auto mode

$ update-alternatives --install /usr/bin/javac javac /opt/jdk/zulu8.40.0.178-ca-jdk1.8.0_222-linux_aarch32hf/bin/javac 1083000
update-alternatives: using /opt/jdk/zulu8.40.0.178-ca-jdk1.8.0_222-linux_aarch32hf/bin/javac to provide /usr/bin/javac (javac) in auto mode

$ wget -nv -O /tmp/openhabian.HDH1a/
2019-09-13 13:52:33 URL: [12181/12181] -> "/tmp/openhabian.HDH1a/" [1]

$ unzip /tmp/openhabian.HDH1a/ -d /tmp/openhabian.HDH1a
Archive:  /tmp/openhabian.HDH1a/
   creating: /tmp/openhabian.HDH1a/ZuluJCEPolicies/
  inflating: /tmp/openhabian.HDH1a/ZuluJCEPolicies/LICENSE
  inflating: /tmp/openhabian.HDH1a/ZuluJCEPolicies/README.txt
  inflating: /tmp/openhabian.HDH1a/ZuluJCEPolicies/DISCLAIMER
  inflating: /tmp/openhabian.HDH1a/ZuluJCEPolicies/local_policy.jar
  inflating: /tmp/openhabian.HDH1a/ZuluJCEPolicies/US_export_policy.jar

$ systemctl start openhab2.service
2019-09-13_14:03:55_CEST [openHABian] Checking for default openHABian username:password combination... FAILED
2019-09-13_14:03:57_CEST [openHABian] We hope you got what you came for! See you again soon ;)
[14:03:57] openhabian@openHABianPi:~$ sudo systemctl restart openhab2.service
[14:04:51] openhabian@openHABianPi:~$ sudo openhabian-config
2019-09-13_14:14:41_CEST [openHABian] Checking for root privileges... OK
Get:1 stretch InRelease [25.4 kB]
Hit:2 stretch InRelease
Hit:3 stretch InRelease
Ign:4 testing InRelease
Get:5 testing Release [6,053 B]
Hit:5 testing Release
Hit:6 stable InRelease
Fetched 25.4 kB in 2s (8,557 B/s)
Reading package lists... Done
2019-09-13_14:14:50_CEST [openHABian] Loading configuration file '/etc/openhabian.conf'... OK
2019-09-13_14:14:50_CEST [openHABian] openHABian configuration tool version: [master]v1.5-520(e9eaa69)
2019-09-13_14:14:51_CEST [openHABian] Checking for changes in origin... OK

Try to check & upgrade again. Perhaps it needed to move from M1 to M2 before you could get M3?
Just a guess.

I wasn´t trying to upgrade to later Mileston at all… Thats why its very odd. #02 should NOT upgrade to newer milestone, as far as I know.

I found this logfile in \var\log\apt\history.log

Start-Date: 2019-09-13  13:50:49
Commandline: apt-get --yes upgrade
Requested-By: openhabian (1000)
Upgrade: openhab2:armhf (2.5.0~M1-1, 2.5.0~M2-1)
End-Date: 2019-09-13  13:51:49

Very odd… I dont understand it…

If you had it upgrade all the OS packages I would expect it to have upgraded to M3 because Openhabian just installs & upgrades using the apt program from the OS, which also upgrades the OS packages.

It has to be a change in openhabian-config then, cause I have run this option before, and it didn´t upgrade openhab, only the system files.

openHAB also is installed in form of OS packages called openhab2 , openhab2-addons, openhab2-addons-legacy. These you had installed (at least the first one) when you selected ‘Upgrade’.
So openhabian did exactly what you told it to: it upgraded ALL packages to their latest versions.
(I know that was not your intention. But that’s what the description told you it would do and is what it did).

No. It has ever been working like that. You probably have been on release or on latest milestone then so there was no newer one to upgrade to.

1 Like

Except M3? :wink:

No, latest version then, i.e. whatever was latest by the time he selected that.

I did this a few hours ago… The M1 has been running for a few months…
I really dont get it… Whats the latest version then?

My experience with my “stable” 2.4.0-1 deployment is that issuing a system update does not upgrade openHAB. Perhaps if you are on a SNAPSHOT or Milestone, it will upgrade you to a newer SNAPSHOT or Milestone, respectively?

Agree, it havn´t done that before. Even when I have been running 2.5 M1 and executed the system update.

But then I would have thought it would have chosen M3 insted… M2 makes absolutly no sense, when M3 is released.

1 Like