AVM Fritz Binding cant connect new decives anymore. But working with existing

Recently i updated my openhab installation (on my RPi) to OH3.0 and as there were several errors i decided to reset everything and start from the scratch.
So far i did the initial setup and installed just 3 bindings: OH cloud, AVM Fritz and Deconz.
As OH found severalthings automaticly, i added them al with names, locations etc.
Kinda random i restartet some tme later my FritzBox 7590 and not all things came back alive in OH.
Suprised i saw them all in the FritzBox config and can controll them, i did again a restart on my RPi and the FritzBox.
Still, 2 devices (Fritz DECT 301 heater thermostates) did not come back. The remain in status “unknown”.
So i tried different things, like reconnecting the thermostat with the FritzBox, removing and reinstalling it etc.
Actually my current status is:

  • all the thermostates work with the FritzBox
  • all, except of 2, also work with OH
  • OH cant find any new devices by Scan from FritzBox binding
  • adding manually the missing device will result in status “unknown”
  • adding an existing device manually (choosing another ID, name but same AIN) will result in the new device being “unknown” while the original device is working and “online”

The log file is pretty unclear about this problem:

17:12:53.902 [INFO ] [hab.event.ThingStatusInfoChangedEvent] - Thing 'avmfritz:FRITZ_DECT_301:192_168_1_1:test' changed from UNINITIALIZED to INITIALIZING
17:12:53.932 [INFO ] [hab.event.ThingStatusInfoChangedEvent] - Thing 'avmfritz:FRITZ_DECT_301:192_168_1_1:test' changed from INITIALIZING to UNKNOWN

I would be thankful for help.

PS: I just deleted a working thing, which was bound over AVM Fritz binding before.
Then did a scan on my FritzBox and the thing is not discovered anymore …
Seems like the binding indeed does only work with things, which were binded several days before, but not with new ones …

PPS: ok, i was just very confused and decided to delete everything of this binding …
So i removed first all items, then all things, then den bridge and then the binding itself.
Afterwards i re-installed the binding and did a scan … my FritzBox was found.
Installed the FritzBox as the bridge and did the config (exactly the same way, as before). And after this all my DECT devices were discovered automaticly …
But again … after adding all devices as things, the devices i deleted before were “unknown” again, even tho they were discovered automaticly.

Just an idea, but could it be, that somehow the deleted items were not deleted completely, but like be therre in the background now allowing to create new items with same AIN?