BE469ZP zwave listed as unknown

Tags: #<Tag:0x00007fc8efd45a48>

I have a BE469ZP and its being listed as unknown,
Z-Wave Node 004 (003B:0001:0469:3.3)

I opened a ticket with CD-jackson and he informed me that the database is up to date. Any suggestions? im running on openhab stable version

Welcome to the forum! There’s one other post about this lock…

The device database entry was added in February, so you will need a 2.5 snapshot version of the binding. I’m going to assume you are an experienced OH user and know how to upgrade OH or the binding, but if you need help just ask!

Thank you very much, got it working!

openhab> bundle:list|grep -i zwave
206 │ Active │ 80 │ 2.4.0 │ ZWave Binding
openhab> bundle:update org.openhab.binding.zwave https://openhab.jfrog.io/openhab/online-repo-snapshot/2.5/org/openhab/binding/org.openhab.binding.zwave/2.5.0-SNAPSHOT/org.openhab.binding.zwave-2.5.0-SNAPSHOT.jar
openhab> bundle:list|grep -i zwave
206 │ Active │ 80 │ 2.5.0.201904190356 │ ZWave Binding

1 Like

Im still having an issue, after a while it automatically downgrades to 2.4, is there a check somewhere that doengrades the zwave binding ?

I have to redo the commands to get it back to 2.5 everytime

There’s nothing that would downgrade it, but if you have two versions, the older one might be showing up. What exactly is happening?

Then how do i delete the older version?

I do the upgrade commands in CLI and after a while , maybe a day or so, my zwave BE469zp stops working, i then go into the CLI and check the zwave binding version and i find that its 2.4 instead of 2.5

I do the upgrade, and after a few days same thing happens.

I’m not very familiar with repository installations. Are there more than one version of the binding installed? Does this happen after a restart of OH or the binding? After an Items file is saved? Did you manually configure the bindings in the addons.cfg?

There are lots of possibilities. I use a manual install of OH, and a manual install of the zwave binding, and have never experienced (or heard of) the issue you are describing.

I installed the openhab via apt

sudo apt-get install openhab2
sudo apt-get install openhab2-addons

Via paperui i installed the zwave binding, and i upgraded the zwave binding via CLI, what is the command to verify is there are more zwave bindings installed?

Does upgrade not overwrite the binding?

When thje issue occures i still havent pinpointed, randomly i experience this.

Just use list -s |grep -i zwave to check if more than one are installed. If you find more than one, use bundle:uninstall X, where X is the ID shown when you ran list. Maybe pointing to a milestone or snapshot package repo would help (assuming you are currently pointed at stable).

Are you on a Pi, and would it restart if it crashed?

@mhillbush and @sihui, have you ever heard of a binding rolling back?

Yeah im pointing to the stable 2.4 release.

Look what i found

openhab> list -s |grep -i zwave
220 │ Active │ 80 │ 2.5.0.201904202118 │ org.openhab.binding.zwave
230 │ Installed │ 80 │ 2.4.0 │ org.openhab.binding.zwave
openhab> bundle:uninstall 230
openhab> list -s |grep -i zwave
220 │ Active │ 80 │ 2.5.0.201904202118 │ org.openhab.binding.zwave
openhab>

for some reason 2.4 becomes randomly active instead of 2.5

I removed the older version, hopefully now its fixed.
And yes im on the PI 3, the PI does not restart , and openhab just keeps working after the zwave automatic bind downgrade

I think this is not possible.
To upgrade the zwave binding, you need to uninstall it through PaperUI and then drop the 2.5 zwave snapshot jar file into your addons folder.

Mark had provided some instruction for upgrading from Karaf, without dropping a jar…

I have thought about adding this as an option in my install script, but I’m reconsidering as the issues reported here. However, the issue may have just been that the older version was also installed.

Ah, missed that one.

I think that was the case.

I got this error
2019-05-02 20:21:31.006 [INFO ] [ui.habmin.internal.servlet.HABminApp] - Started HABmin servlet at /habmin
2019-05-02 20:21:31.101 [ERROR] [org.openhab.binding.zwave ] - FrameworkEvent ERROR - org.openhab.binding.zwave
org.osgi.framework.BundleException: Could not resolve module: org.openhab.binding.zwave [236]
Another singleton bundle selected: osgi.identity; type=“osgi.bundle”; version:Version=“2.5.0.201904202118”; osgi.identity=“org.openhab.binding.zwave”; singleton:=“true”

    at org.eclipse.osgi.container.Module.start(Module.java:444) ~[?:?]
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1634) ~[?:?]
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1614) ~[?:?]
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1585) ~[?:?]
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1528) ~[?:?]
    at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1) ~[?:?]
    at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230) [?:?]
    at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340) [?:?]

For some reason the 2.4 zwave version would again appear after a restart of the openhab, but not on active.

I cleared the cache as per instructions here

but had to use this “sudo openhab-cli reset-ownership” , before starting up again
2.5 is the only version i see now after stop/starting the openhab and the error above is also gone.

2019-05-02 20:21:31.101 [ERROR] [org.openhab.binding.zwave ] - FrameworkEvent ERROR - org.openhab.binding.zwave
org.osgi.framework.BundleException: Could not resolve module: org.openhab.binding.zwave [236]
Another singleton bundle selected: osgi.identity; type=“osgi.bundle”; version:Version=“2.5.0.201904202118”; osgi.identity=“org.openhab.binding.zwave”; singleton:=“true”

This message usually means there are two versions of the binding installed. What do you see if you run this in the console?

list -s | grep zwave

2 versions, even after deleting 1

Hmm. Odd.

All I can say is

  • make sure Paper UI is not showing it as installed
  • make sure it’s not referenced in conf/services/addons.cfg
  • make sure there are not multiple copies in addons (use ls -la to make sure there’s nothing that starts with a dot)

If after verifying all the above, try removing the contents of cache and tmp

Did you drop a jar into addons? If you’re using 2.4 with a 2.5 snapshot binding jar to get your lock working, uninstall the binding in Paper UI. The jar will install the newer binding and it will not show in the UI.