Binding Xiaomi Mi home getway

Tags: #<Tag:0x00007f616d9de880>

I am stuck at the same problem, did you find a solution yet?

Hi Daniel
Have you found a solution for this - i have exactly the same problem.
Torben

Hi TBM.
Welcome to the forum and this topic.
I stopped looking at the issue late last year, and did not progress anyfurther than is mantioned in this thread. However I will be looking at in depth in this subject again in the next week or so. So your timing could not be much better.
My initial thoughts with regards to my plan to getting my Xiaomi gear working is to:

  1. Try the binding method of integration again, with a fresh mind, and (if lucky) some changes to the firmware that allows me to obtain the developers key.
  2. try the Zigbee2mqtt solution as mentioned in this (Xiaomi Mi Home Gateway) thread. Note: this thread goes into further detail of the issues I had with the gateway and others who gave suggestions… take a look.

Let me know how you get on.
Cheers,
Dan

Hey there

Today I bought the Conbee II Stick (39,95€) from Amazon which should enable me to discover the sensors with ease. Furthermore the bridge does not get used --> no calling back home to China.

I talked to Xiaomi support via chat, mail and the feedback hub in the app and did not get a useful response of any of them.

The stick should come on Monday, I am looking forward =). It’s not the prettiest solution as it costs an extra 40 bucks but I really want those sensors.

Hello Daniel
Thanks for your quick reply.
I have also considered to look into the Zigbee solution.
I have also been thinking if it possible to reset the Xiaomi Brigde/Hub to factorysettings and/or find an old version of the app - i am not used to work with apps on phone/tablet (I rather do it on my pc) so i dont know if it possible.
If i have a breakthrough I will sure let you know.
/Torben

Hi again
It look likes it is possible to find old versions:


I am not at home right now, so i can not test - i will try tomorrow.
/Torben

I had this idea too and tried one or two apks. One of them was v3.9 I think. However I had no luck with them either =(

Hi Felix
Exciting - hope you let us know if it is useable.
/Torben

Hi Felix
Is the problem in v3.9 that you can not find “About”?
/Torben

Yes!

I will. YouTube videos concerning this topic made me optimistic.

This app works:

The 2.5.5 snapshot version of the binding is able to extract the token directly from the cloud, no need for apps anymore:

What exactly is the token ? I have my token as well. I found it via an older version of the Xiaomi Mi Home App.
However what’s the purpose of the token? It’s 32 signs long and consists of lower case letters and numbers. I tried putting in this token as the developer key in the gateway configuration in paper UI. However this didn’t do anything, the thing went from initialisation to offline and stayed there.

I also read that you have to decrypt the token first. Tried this as well with no luck either.

Is there a way to use the token or get the developer key out of it?

If anyone want the manual on how to extract the token tell me. It’s pretty easy

I got it to work with extra hardware. See my post here