Blink Binding

Hi Wouter, i tried your reviewed jar, but still have the same problem I was experiencing with previous versions. When I enable the binding, I immediately get the following error:
COMMUNICATION_ERROR
java.util.concurrent.ExecutionException: org.eclipse.jetty.client.HttpResponseException: HTTP protocol violation: Authentication challenge without WWW-Authenticate header

I don’t receive any authentication code, and therefore the binding won’t work.

Can you help me to understand what’s happening? Am I doing something wrong?

thanks and regards
Marco

Since last night I cannot login to my blink account. Error message is “Blink API Call unsuccessful <Status 403>”.
I tried to delete the account and add it again. But I don’t receive the 2fa PIN code.

1 Like

Same error for me also since this night

Using “curl” with the api works.

Same here.
Could anyone help, please?

1 Like

Same error😒

Also, getting the same error. Tried the newer jar and still getting it.

Unfortunately, the same here:

Blink API Call unsuccessful <Status 403>

I guess Blink have changed something their end as they want our money!! The Mobile App has recently changed also and now defaults to Cloud storage all the time so states ‘no clips’ and have to manually change back to internal storage.

Hope someone here with more knowledge than me can figure it out and amend the binding.

1 Like

Odd my app still defaults to Local Storage, did have a few updates so maybe they are having issues with the app too.

Where can i found the api spec? maybe this will help to found the Problem in source code - openhab-addons/bundles/org.openhab.binding.blink at blinkbinding · moesterheld/openhab-addons · GitHub

1 Like

The information can be found here

The difference in login is that with “curl” I don’t use a “unique_id”. Maybe this should not be sent during login?

Same issue here

Hi folks,
I will take a look into this this week. If it is doable without too big of a workload I will address the changes necessary.
I have moved on from OpenHab, so I need to set up a development environment once again to test it. Please bear with me while I do that.
This will then be my last contribution to the binding. If anyone versed in Java development wants to take over, please go ahead and fork the branch.
Matthias

3 Likes

From what @Jogobo said up here, maybe removing this line can be the first thing to try (I’m just trying to help, not saying what you should do, I’m only a grateful user willing to help to the best of my knowledge):

1 Like

As far as I digged into the login process via curl and bash I can say that it depends on the time since last “rauth”. If it is too long “reauth” fails and a login with ‘{ “reauth”:false }’ results in a new PIN sent via SMS.

So if there is an auth token and login with “reauth=true” fails, I send a login request with “reauth=no”, verify the PIN and everything I moved to bash scripts works as expected. Set the time between two logins with “reauth=true” to 12 hours and up to now, I had no problems.

That’s great ! Thank very much. If you need help testing you can count on me again.

How can I set up?
I tried to delete the blink-thing an add a new blink-account, but there are no options to set “reauth”.
For a new think, no pin is generated :frowning: and the error “Blink API Call unsuccessful <Status 403>” is shown immediately after activating the blink account.