BMW ConnectedDrive Binding

I assume you’re using the official binding from OH3 release. Would be nice to know if somebody has the same problem too in order to check if BMW changed something on Authentication again.

In the meanwhile it’s worth to check if the update for soc_max value is working on your side: BMW ConnectedDrive Binding - #94 by weymann. THis one is currently running on my machine without problems so far.

I’ve been using the OH2 version this past week in preparation for a migration to OH03. It started to fail with authentication errors yesterday morning. So it would appear to be an issue with BMW as I can’t renew my ConnectedDrive subscription either. When I called them yesterday the person I spoke to seemed to be reading a scripted statement to tell me it’s being worked on and will be resolved with 24hours of my call. I called them around 9am yesterday, still not able to renew my subscription.

BMW appears to have launched a new app.

It‘s the binding that comes with oH 3.1

I‘ll try the updated binding and get back to you.

This update is working.
I made a test with the regular binding and it´s still running into Bad Request

I cannot connect using the official app. Other integrations to BMW has failed as well. So, I guess there are some issues at BMW:s side.

Same here (MY2021 i3). Also, when you try to retrieve your vehicle details or “car data” report on the myBMW website, you will run into a “400/bad request” situation (“Size of a request header field exceeds server limit.”) and they refer you to customer support. Seems to be a broader issue with their backend.

Isn’t it possible that BMW has stopped service of the connected app. I’m not able to connect to binding nor to the connected app (iphone version). But the iphone App “My BMW” works well.

same here…

…seems others have similar issues (e.g. home assistant). Here’s a link to some more infos and further links to what they changed to make the login successful again (at least for row): click

It´s the same backend and that didn´t changed with the new App.
As already mentioned, my binding is online with the version from this post.

I can acknowledge. This binding seems to use a different login/authentication method to the BMW backend and this is the only one working currently.

Just tried the binding from this post. Doesn’t work either. Same error as official BMW binding:

Total timeout 10000 ms elapsed

EDIT: Just cleaned the cache and updated OH and now its working again!

1 Like

Came here for the obvious same problem. I have to note that on Friday morning, I had to re-authenticate to ConnectedDrive in my car and my “My BMW” Android app. And at that point the OpenHAB binding also broke - but I only noticed it just now.

I can also confirm replacing the binding with the one linked in the previous posts brings things back online!

The binding does not connect using the latest nightly build.
After changing to the above linked binding, everything works as usual.

Hello Everybody,

I had the same Problem:
At 10.08.2021 I restartet my OpenHAB 3.1.0.M4. Since this moment the Connected Drive Binding had Communitications Errors (mostly: COMMUNICATION_ERROR Total timeout 10000 ms elapsed)


  1. Delete Connected Drive Things (Bridge and Vehicels)
  2. Deinstall Connected Drive Binding wich comes with the 3.1.0.M4 Release
  3. Stop openhab
  4. Clear cache and tmp folders (see Clear the Cache)
  5. Copy org.openhab.binding.bmwconnecteddrive-3.1.0-SNAPSHOT.jar (from BMW ConnectedDrive Binding - #94 by weymann) to “addons” Folder
  6. Start openhab
  7. Create new Connected Drive Bridge and Vehicels Things (in Things configuration page in the UI simply click “+”. There you will see the manual added Binding)

Now everything works again for me.


Hi Bernd,

does oauth is still working with the 2.5.9. version of this binding? I do not dare to switch to OH3.

2021-08-21 21:36:05.359 [INFO ] [el.core.internal.ModelRepositoryImpl] - Refreshing model ‘bmw.items’
2021-08-21 21:36:36.785 [WARN ] [rive.internal.handler.VehicleHandler] - ConnectedDrive Proxy isn’t present
2021-08-21 21:36:41.783 [INFO ] [internal.handler.ConnectedDriveProxy] - Auth
2021-08-21 21:36:41.936 [WARN ] [internal.handler.ConnectedDriveProxy] - Server returned HTTP response code: 400 for URL:

BMW changed server access for authentication and all versions OH2.x and 3 are affected. I applied the changes also in the OH2 binding which accessible in the top post. Simply exchange the jar and it should work again.

1 Like

I can see that there was a commit for the 2.5.9 binding 2 days ago, but the 3.1.0 is still 5 months old.

Is the fix available in the 3.2.0-snapshot?

Just put org.openhab.binding.bmwconnecteddrive-3.1.0-SNAPSHOT.jar into my addons folder.
Before removed old one, stop oh, cleared cache temp, start oh.

The binding does not show up. No log entry also.

I use docker.
Did open a shell in the container, there is a /addon folder and the .jar file is in the folder. File owner is openhab, changed rights to 777 still no luck.

Any ideas?

I did get the addon via wget and the file size is smaller than the version downloaded on my windows machine. Copied it from the windows machine and the addon starts.

At least with an error :frowning:

org.osgi.framework.BundleException: Could not resolve module: org.openhab.binding.bmwconnecteddrive [278]
Unresolved requirement: Import-Package: javax.measure; version="[1.0.0,2.0.0)"