Broadlink binding for RMx, A1, SPx and MP. Any interest?

The themillinghousegroup broadlink binding allows learning commands (through “Remote Learning Control” channel, using MainUI), as well as the broadlinkthermostat does (“Learning Mode” channel).
I gave the 3.4.x-alpha0 release a try and … it seems to work, on oh4.0.1. My RM4mini is recognized online, items are linked to channels, values are read.

I’ve just double checked that. I’ve never recognized this learning channel?! Maybe, because I’ve started with a very early version of themillinghousegroup plugin 3 years ago, it’s possible that this remote learning channel was not available at the beginning or I’ve just missed this channel from the beginning?

Usually, I configure OH completely via config files and don’t use the config GUI after hat. Maybe I missed the appearance of this channel at a later time. When I first use a complete new binding, I usually use the OH GUI just for an initial test and copy the generated code for things and channels to transfer the config data to the config files and delete the GUI created things/items after it.

Now, I’ve learned that I should check from time to time to see, if new channels may be available with newer versions of OH and their bindings.

Thanks for the feedback and good to know that this binding does also work with your OH 4.0.1 with an RM4 mini. So I will do a test with the RMPro+ with my current OH 3.4.4 and also after updating to HO 4.0.1.

1 Like

RM4PRO does not get discovered on OH4, I have tried both with the “marketplace” binding (broadlinkthermostat) as well as with the Openhab addon binding 3.4.3.

  • broadlinkthermostat: After scan will not find the device. If device gets added manually through IP and MAC, it goes online but when activating learning mode, it will not authenticate against RM4PRO.
  • addon binding 3.4.3: after uninstalling the broadlinkthermostat and installing this one, the binding will not show on the “Add things” menu to be selected.
    Has anyone been able to get the binding to properly work on OH4 for a RM4PRO?

Hi guys,

not sure if I understand right but did someone so far test with Openhab 4 the RM Mini 3 and with the broadlink native binding?

When you look at the documentation it should work no?
My RM3 Mini gets recognized and is online in OH4. I still have the old map file with all commands from OH3 but I am not sure how to implement them? I saw someone used the habpanel interface to activate the learning mode and save with a name, I believe this is at least what the page says: Broadlink - Bindings | openHAB

Any thoughts on this or ways how this works are appreciated :slight_smile: So far I did not find something and the only idea I see is that the old broadlink custom binding from millhouse get ported?


The documentation shows three channels.

I haven’t done this, but I assume the steps are:

  1. Make an item for each channel
  2. Toggle the learningmode switch to ON to teach a code to the RM Mini
  3. Copy the IR code from the savelearned string item in your log
  4. Use the IR code to the sendlearned string item to trigger the command

Since you already have the IR codes, you should be able to skip steps 2 and 3. I’m just including them here to cover the whole process.

If this works, please confirm for the benefit of other users.

1 Like

Here is an update:

I have included the following in my items config:

Switch RMini_LearningMode "RMini_LearningMode" { channel="broadlinkthermostat:rmuniversaldevice:RMMINI-5a-c0-78:learningmode" , homekit="Switchable" } 
String RMini_Learned "RMini_Learned" { channel="broadlinkthermostat:rmuniversaldevice:RMMINI-5a-c0-78:savelearned" } 
String RMini_SendLearned "RMini_SendLearned" { channel="broadlinkthermostat:rmuniversaldevice:RMMINI-5a-c0-78:sendlearned" }

I also have the old in the transform folder with IR codes and names.

So the RM Mini goes to learningmode ON at least:

2023-09-09 19:51:31.100 [INFO ] [openhab.event.ItemCommandEvent      ] - Item 'RMini_LearningMode' received command ON
2023-09-09 19:51:31.101 [INFO ] [penhab.event.ItemStatePredictedEvent] - Item 'RMini_LearningMode' predicted to become ON
2023-09-09 19:51:31.103 [INFO ] [openhab.event.ItemStateUpdatedEvent ] - Item 'RMini_LearningMode' updated to ON
2023-09-09 19:51:31.104 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item 'RMini_LearningMode' changed from OFF to ON
2023-09-09 19:51:31.135 [INFO ] [openhab.event.ItemStateUpdatedEvent ] - Item 'RMini_LearningMode' updated to ON

But when I send a press a button on my remote it does not show the resulting filled string in the log which I would expect to be savelearned at least.

I don’t understand what they mean in the documentation with “saves the learned keys with the provided name” No idea what is meant here how to provide that name in the config before. Anyone has a best guess?


Here’s the answer. I’d forgotten about this conversation, but found it when I searched for “learningmode”.

Great thanks but does this imply that I actually click on the website in habpanel and create a site to press select the correct name? Is there no way to get around that? Or do I get it wrong?

Anyway I quickly created it, let me check if it works :smiley:

You’ve already learned the code, so as I understand it you would now send a command to the saveLearned item with the name you want to give the code, and the binding will store it.

Then you would send commands to sendLearned using the name.

Seems a little more complicated, but that could just be due to my lack of familiarity with it. At the very least, this method doesn’t require users to read the IR codes or use map transformations.

Okay indeed it is working as expected above. I have now tested it and is actually creating files for each command and supplied name in the sitemap. So thats great. Unfortunetely my TV works but my receiver IR does not work :confused: now.
Man it was so much easier with the millhouse OH3.X binding :frowning:
I guess I will have to wait for a port to properly use the RM mini. Before my receiver was working with the IR code but here it doesn’t work now.

I’m not so sure about that. It was very confusing figuring out how to get the IR codes in the first place, and I only managed it due to some instructions buried somewhere in this 1500+ thread.

Now that you’ve got it figured out, I’d suggest you write a tutorial for others. That’ll help you streamline the process and benefit others.

Hi friends,
I would like to upgrade my OpenHAB docker app to the latest stable version, but before I do, I wanted to make sure the Broadlink binding supports OpenHAB 4.0.3?
Can anyone please confirm? :pray:

I have now created an testsystem with an snapshot of OH4.1
Is there a small guidance, how to use the new broadlink binding for an RM4 mini?
I have in my other setups still the unoffical binding in use were it works to send the climasystem in the wintergarden on and off.
A small setup guide with step by step, how to use the binding with lean, save and send whould very helpfull.
Do we have someone who has done dis already?
Thanks in advanced.

Did you scroll up?

Upgraded OpenHAB to 4.0.3. Binding still works properly.
Thank you for all the developers maintaining it :pray:

I can confirm, that the “beta” binding, works, and works, and works… also under snapshot
Still I’m interested somehow to bring the offical binding to run…
Hope to get a step by step guidance.

Hello… I have played a little with the soultion now.
But so far I’m NOT able to bring the RM4 mini to the learning mode, when
switching “on” the switch in the Learningmode and sending to the RM4 mini via IR from the remote
a code. The LED on the RM4 mini in NOT go be “white”. no nothing happend on it.

The RM4 mini works perfect with the old unoffical binding in 2.5 - 3.4.4. and also in 4.0.x version.
So the HW is not broken and it working finde to switch my clima on and off.

Only the new binding will not run with it.

PS: The RM4 mini I can ping etc…

UID: broadlinkthermostat:rmuniversaldevice:08aa07e868
label: Broadlink RM4
thingTypeUID: broadlinkthermostat:rmuniversaldevice
  macAddress: 24:df:a7:e8:41:30
  - id: learningmode
    channelTypeUID: broadlinkthermostat:learningmode
    label: Learning Mode
    description: Put device in infrared learning mode when turned on
    configuration: {}
  - id: savelearned
    channelTypeUID: broadlinkthermostat:savelearned
    label: Save Learned
    description: Saves the learned keys using the provided name.
    configuration: {}
  - id: sendlearned
    channelTypeUID: broadlinkthermostat:sendlearned
    label: Send Learned
    description: Send previously learned keys by name.
    configuration: {}

What can I do more to bring the RM4 mini to work?

I found now a settings in the binding itself, were I can enable the logging . This is now the logfile when press the switch to the learing mode:

2023-09-19 07:57:10.639 [DEBUG] [nal.handler.RMUniversalRemoteHandler] - Command: ON
2023-09-19 07:57:10.641 [DEBUG] [nternal.handler.BroadlinkBaseHandler] - Authenticating with broadlink device Broadlink RM4...
2023-09-19 07:57:10.669 [WARN ] [com.github.mob41.blapi.BLDevice     ] - RM2 enter learning received error: fffffffb / -5
2023-09-19 07:57:10.671 [DEBUG] [nal.handler.RMUniversalRemoteHandler] - Thing broadlinkthermostat:rmuniversaldevice:08aa07e868 entered learning mode
2023-09-19 07:57:10.612 [INFO ] [openhab.event.ItemCommandEvent      ] - Item 'Broadlink_RM4_Learning_Mode' received command ON
2023-09-19 07:57:10.621 [INFO ] [penhab.event.ItemStatePredictedEvent] - Item 'Broadlink_RM4_Learning_Mode' predicted to become ON
2023-09-19 07:57:10.622 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item 'Broadlink_RM4_Learning_Mode' changed from OFF to ON

Under 4.0.3 it looks like this:

2023-09-19 20:10:39.890 [DEBUG] [nal.handler.RMUniversalRemoteHandler] - Command: ON

2023-09-19 20:10:39.891 [DEBUG] [nternal.handler.BroadlinkBaseHandler] - Authenticating with broadlink device Broadlink RM4...

2023-09-19 20:10:39.871 [INFO ] [openhab.event.ItemCommandEvent      ] - Item 'Broadlink_RM4_Learning_Mode' received command ON

2023-09-19 20:10:39.874 [INFO ] [penhab.event.ItemStatePredictedEvent] - Item 'Broadlink_RM4_Learning_Mode' predicted to become ON

2023-09-19 20:10:39.876 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item 'Broadlink_RM4_Learning_Mode' changed from OFF to ON

2023-09-19 20:10:39.921 [WARN ] [com.github.mob41.blapi.BLDevice     ] - RM2 enter learning received error: fffffffb / -5

2023-09-19 20:10:39.924 [DEBUG] [nal.handler.RMUniversalRemoteHandler] - Thing broadlinkthermostat:rmuniversaldevice:3b677c7077 entered learning mode

But still no possiblity to save a command, because the white LED ist not on and nothing happend, when I send a command to via the remote to the RM4 mini.

Hey @mjeshurun Which binding are you using? Trying to get back to the old binding as well as with the stock broadlink binding the IR commands not work the same as with the millhouse binding.