Broadlink for OH 3.0

Hi I’ve a quick question, I’ve tried to find the github for Broadlink for OH 3.0

This is the link .jar I need to move to my add on file?

and by the way, how do I move that to my add on file?
On OH 2.5/4, I used to connect via IP from ‘My Computer’ then \IP , that takes me to the main files there (config , OH add on ETC)

openHAB 2 addons will not work on openHAB 3. You can run an openHAB 2.5.x instance and use the remoteopenhab binding to get the Items into OH3 though.

I don’t really understand what should I do, Do I need to install OpenHAB 2.5.X binding? can you get me a link for that?
I’ve installed Remote openHAB Binding Version of the binding 3.0 I’ve installed it via the Main UI of the OH 3.0 Should I need to create a new remote with this binding? if yes where do I get the details for set it?

I might want to get back to OH 2.5, I’ve tried for house, can you link me the OH 2.5 file that I will install on my SD card on my RPI 4 ?


EDIT: I can’t find the img.xz for 2.5
Only the .rar file, I want to install it on SD, Can I do it with the winrar file?
Or where do I get the img.xz File for 2.5

When I go the github to find the right Version I can’t really sure what is for 2.5, does it the V1.5?

The broadlink binding is working in OH3 without issues, not only OH 2.5 hence no need for a remote 2.5 instance., Link.
Please read through the thread though for advice on how to use it, it’s long but has all the information you need.

I just can’t understand how do I move the file to the AddOn file, in 2.5 version I was able to connect with the the ip VIA ‘my computer’ , put there the IP and that’s it. Right now I can just connect via SSH with Putty.
I’ve read like 100 reply over there, I’ve saw your reply over there, but I just can’t find soultion to my problem.
Anyway - If you can help me with it, and help me with my last question as well here. thank you

I am not sure I understand your challenge, but yes, you need to connect via SSH/SFTP to your OH instance, then move the bindings file into the respective addon folder.
Afterwards do a restart and the binding should be activated. At least this is the process I followed and I guess will be the process as long as the binding is not official in the repo.
Another thing to note is that sometimes bindings you add this way will not appear in the bindings menu, but will appear when you add a new Thing (hence just because it does not show broadlink in the menu, does not mean its not installed).
If you could be a bit more specific on your challenge I am sure we can help you further.

So first of all thank you, the main challange is how to move the .jar to my add on file. I am not sure how to do it with SSH.

The easiest would be to use an SFTP/FTP program like FileZilla connecting to the same IP and then uploading the jar file. SSH programs also often come with the option to directly call an external FTP program (i.e. I am using mRemoteNG (instead of Putty) with FileZilla).
You might need to upload it into your home user directory first though (in case you do not use root) and then move it via SSH over.
edit: and make sure that you adjust user privileges of the .jar file to i.e. openhab:openhab

Hi, I’ve downloaded both FileZilla & RemoteNG , and I’d able to connect as well , I also downloaded the .jar file you sent (snapshot), It’s a winrar file that include a bunch of folders , where exactly I should move those file? After connect with FileZilla (I guss the port is 22), I saw there Home>Openhabian> ssh/vim/gnupg those the folders I’ve in my openhabian in FileZilla, about the Putty/RemoteNG, in kind like the smae thing , console that you need to enter files with linus (LS,CD…, etc) I know to work with this, I just need to know where should I move those file I said above.
Thank you very much for your help , I apprciat it.

Sorry for my late reply.
The addons folder is (for me) in: /usr/share/openhab
The transform folder is (for me) in: /etc/openhab
I did install though with apt and not openhabian if that matters.


I recently bought Broadlink RM4 Mini, downloaded and installed 3.2 Beta Add-on but could not discover my device. I am getting this error log…

Thank you in advance for your help @Cato_Sognen

2022-09-27 22:08:03.738 [WARN ] [.discovery.BroadlinkDiscoveryService] - Device identifying itself as ‘21014’ (0x5216) is not currently supported. Please report this to the developer!