Browser fails to reach openHAB after install

• Platform information: Raspberry 4
• Hardware: Raspberry 4
• OS: _openHABian from zip file openhabian-pi-raspbian-201908050414-gitca0976f-crc6a66b5a1.img.xz
• Java Runtime Environment: In the package. not sure I can choose?
• openHAB version: See OS above
• Issue of the topic:
My browser displays: “This site cannot be reached” when I enter DNS name, IP address, or the openHAB dashboard.

I used and old linksys router, disabled the wireless, and connected the pc and Ras to the router. I saw both devices in the router clients table found and one was named openhab. I used this IP and i was able to ping the ip address but cannot connect to it via browser.

• Please post configurations (if applicable):
• Items configuration related to the issue
• Sitemap configuration related to the issue
• Rules code related to the issue
• Services configuration related to the issue
• If logs where generated please post these here using code fences:

Let’s assume everything is installed correctly…did you try to reach it by IP and not DNS name ?
It’s not so automatic that the router can resolve the host name.
So try to put in the browser http://YOUR IP:8080

Can you ssh into the Pi or have a monitor, keyboard and mouse attached?
Browse to /var/log/openhab2 or userdata/log and check openhab.log for clues to if OpenHAB is starting or not. Also sometimes it takes my Pi a few minutes to open the dashboard in the browser and that is the message I get until then, first time might take a few minutes. As Alessio said, use the ip address of the Pi


I entered http:\
“Site cannnot be reached.”

I have putty

What is the port number please?
I can also attach a monitor and display.


If you really entered this it would not work…


If it doesn’t work ssh in or connect monitor.

1 Like

I entered into putty IP address and kept default port set at 22, tried same IP and set port to 8080 also and the result was failure to connect.

Connected my display and keyboard to the Raspberry and got a blank screen when I hit enter and cycled Rasp power.

Was successful at SSH into the pi using and default channel and this was the result:

login as: openhabian
openhabian@’s password:
Linux openhab 4.19.57-v7l+ #1244 SMP Thu Jul 4 18:48:07 BST 2019 armv7l

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
openhabian@openhab:~ $

Is this helpful?
What do I do from here?

Just to review my ethernet setup. Browser is Crome, connected to both ethernet and wifi. I tried dropping Wifi but made no difference.


Sorry I meant 192


Try using http://openhab:8080 or http://openhab.local:8080 and see if that works. Also this is a openHABian installation, please be sure to specify that in the thread title.

now that you were able to openssh you need to review the logs typically at ```
sudo sh -c “echo ‘deb
$(lsb_release -cs) main’ >
/var/log/openhab2. In that directory you should see a log file if openhab2 is running.

you can also execute the command sudo systemctl status openhab2.

Lastly, is what you type in the web browser what happens when you do that?

Seems like your installation hasn´t finished yet…
I´m just installing openhabian onto an Rpi4 myself, using SD card. Atm it has taken 20 minutes, and still not ready, (but its close now… I have a monitor connected to my Rpi4 so I can tell what happens).
I could ssh after aprox 5 minutes of the installing, and then I have the same result as you did get. Thats why I assume your installation isnt finished yet.

EDIT - Installation done. Took 40 minutes (yikes!!!)… openhab is available at http://IP:8080
(I never use the DNS name, as I´m used to IP adresse… they tend to work :slight_smile: ).

It may be caused by the fact the current release image for openHABian is not working perfectly as there have been a number of breaking changes since it was made. We are working on a new image now.

As a temporary solution you could try using the image provided at

1 Like

Ahmmm… Thats hopefully not true??? I have been struggling for quite a few days with my test setup… I just dumped my setup on my SSD drive and is installing yet a fresh image copy on a SD.
And now you tell me, this may be a known issue for the openhabian image :unamused:

If there are issues with the image, it should NOT be available, in my opinion.

We know, and have been trying to work to fix it ASAP.

@mstormi I think we may need to stop waiting for Holger and create a new image with what we have and then when offline and all related patches are ready make either a patch release or new release.

Which I truely appreaciate.
In the mean time… Which version would be suitable for Rpi4, the 32bit or 64bit?

32bit, 64bit is in beta and not well tested.

I could give it a shot, if you want me to?

It should be perfectly stable, go ahead and see if it works for you and see if it installs correctly.

Btw will the .elf and .dat files be updated to boot from USB which is required for the latest EEPROM which enable USB boot on Rpi4 or do I still need to copy those manually?

RPi 4 USB boot is not supported with openHABian right now, if you want to go down that road you are on your own. My recommendation is to use an SD card and use Balena Etcher to write the image to it.