[BTicino/OpenWebNet] New openHAB2 binding ready for testing

bticino
openhab2
openwebnet
Tags: #<Tag:0x00007f51e124f0d8> #<Tag:0x00007f51e124ef98> #<Tag:0x00007f51e124ee58>

(stefan) #517

thank you massimo!

sorry that i am not able to test all the new features because i don´t have zigbee and energy meter. but two questions i´d like to ask:

normally i don´t use autodiscover, i prefer manually managing my things, but now i startet it for testing purposes. the multimedia-touchscreen and the mh200n are being found automatically. but i see an entry in the inbox that i cannot understand:

GENERIC Device (WHO=AUX, WHERE=0)

can you tell me what this could be?

and i don´t understand what is meant with “added Switchable tag to shutter channel” - could you please shortly explain, thanks


(Mark) #518

Thanks Massimo,

I wondered why zyou had gone quiet. Now I know. Install went fine.

Didn’t need to do the bundle uninstall form console. Removing the jar was sufficient.

Two new gateways now show in my inBox after the install.

Ciao M


(Massimo) #519

Hi @m4rk if you have already configured your gateway using .things file, just ignore the discovered gateways. In later versions i will need to hide them if you have already a configured gateway via .things (I will recognize them by MAC address )


(Massimo) #520

Good! I need these confirmations to ensure that all gateways are found correctly!

This is an AUX device. Discovery is implemented for AUX, but handling of these devices is not yet included in the binding; it will probably be added in next release (M3).

This is about integrating rollershutter with Google Home/Alexa. Situation is still incomplete in these add-ons : is not a problem of the binding but of the assistants integrations. Since some of the found (temporary) solutions need rollershutter items to be tagged Switchable, so I added it to the already existing Blids tag

bye
M


(Patrick) #521

Hi,

i have updated the system from org.openhab.binding.openwebnet-2.4.0-b9-2 to org.openhab.binding.openwebnet-2.5.0-M2 and my gate (MH202 goes online that my devices stays at UNINITIALIZED - BRIDGE_UNINITIALIZED -> Bridge is online
bg Patrick


(Michele) #522

very strange,
have you tried doing a Reboot?
are the gateway parameters correct?
What does the log say?

Edit:
Version OH?


(Patrick) #523

is soved.
havent seen that i have to set the bridge per thing :sleepy:


(Patrick) #524

Find my error


(Massimo) #525

Maybe this is because in last binding version Things definition and links to bridge have changed a bit.
(That’s is why I suggest in the instructions to create things again - this is not needed for things defined in .things file)
But good that it worked to you by setting again the bridge in things properties. I will add this hint in the binding README.

Bye
Massi


(Patrick) #526

so my system is up to the new version. The rest works perfect in my system (Light/Shutter)


(Mark) #527

Hi

I not sure if its a binding issue or something else but now when I ask Alexa what is the office temperature she responds with ‘Office light doesn’t support that’. It used to work.

Number Office_Temperature "Office temperature [%.1f °C]" <temperature> (gGroundFloorTemperature) ["CurrentTemperature"] {channel="openwebnet:bus_thermostat:Screen10:6:temperature"}
Switch OfficeLight_Switch "Office light" <light> (gAllLights) ["Lighting"] {channel="openwebnet:bus_on_off_switch:Screen10:16:switch"}```

(Massimo) #528

If the two items work well in PaperUI is not a binding issue…
You can try to synch your devices again with Alexa and maybe before that change the label of the two items (to differentiate them a bit ) : locations (rooms) in my experience with GH should be defined in the Assitant app and not in the label of the item


(Mark) #529

Yes that did it. Working again now. Thanks.


(Enrico) #530

Hi Massi,
I am using a workaround for the rolleshutters, but with the tag “Lighting” (so I can fool Google making it belive it’s a dimmer).
Can you please link where did you found the solution using the “Switchable” tag?
I’m interested in understanding how they made it

Thanks!


(Mark) #531

Create a proxy item in openhab. Eg closeblind, openblind, stopblind, 50%blind. All proxy items should have the tag switchable. Create rules for each proxy item so that when the proxy item changes to ON the rule then executes the real blind item to move the blind.

After running Alexa device discovery In Alexa create a routine that switches the new proxy blind item to ON. The routine should listen for a spoken phrase like ‘close blind’.


(Enrico) #532

Thank you Mark for the explanation, but this way seems more time consuming (I have 20 rolleshutters to config :sweat_smile: ).
In my current setup all I had to to was adding the “Lighting” tag to each rolleshutter and give % commands in Google Assistant. To be able to say “open/close” I used Google assistant routines


(Enrico) #533

After installing the new version of the binding the % commands don’t work properly: the rollershutters go all the way up or down (depending on the relativr position compared to the % command sent) instead of going at the requested %.
Is anyone else experiencing this?
I mean using openhab through its own interface


(Michele) #534

Hi Enrico,
need more details.
Type of configuration?
How do you use the shutterRun value?
Did you see README the shutter position section?


(Enrico) #535

Hi Michele,

I just put the desired % in the paper UI.
I have manually configured the shutter run about one year ago and never changed it.
Until yesterday the % command worked as expected, I suppose something has been changed in the binding.
Do you have a rollershutter to do a test?


(Michele) #536

I’ll do tests