[BTicino/OpenWebNet] New openHAB2 binding ready for testing

bticino
openhab2
openwebnet
Tags: #<Tag:0x00007f1e5b9eff40> #<Tag:0x00007f1e5b9efc98> #<Tag:0x00007f1e5b9efa68>
(JP) #497

version 9b2
I know it’s just a warning, but i regurlarly check the log and try to eliminate errors and warnings

0 Likes

(Tom) #498

Thanks Jpcolin!
I use 9b2 with the Homeserver1 and BTicino binding 1 with LN4890. For this one I’m waiting the implementation of the central unit 3550 to pass as I need for temperature scenarios. But I would love to, also for the power management.

Homeserver1 is quite blocked. I can’t even access with the Openwebnet app, have still to check it. BTicino wants to control everything with their app, fortunately they haven’t blocked MyHomesuite.

But rules are working with 9b2 binding, the binding is also more stable compared to BTicino 1, but with that I have much more rules and things. I don’t know why Federico you can’t access with Google Home

0 Likes

(Massimo) #499

State of lights are updated as soon as lights change state (and a message on the BUS is sent).
I am not sure I understand your question… Please explain better what is not working for you and what you would expect to happen.

Massi

0 Likes

(Massimo) #500

@jpcolin, @Tommyshome, @gozilla01
Frames like this (command translation) should be supported for lights and automation since beta9-1.
This is a regression.
It will fixed again in 2.5.0-M2 (see #29)

0 Likes

(JP) #501

@gozilla01: version 9b2
@MoriFede: since you have a MHserver1, i have a question, did you have a firmware update to enable Alexa/goole home?
I was at ISE Amsterdam and they anounced Alexa and Google will be officialy supported via the MHserver1 natively.

0 Likes

(Patrick) #502

Hi,

i have update to the newest snapshot build
the command

feature:install esh-io-transport-upnp
Error executing command: No matching features for esh-io-transport-upnp/0

Anyone else has this symptom? So the binding isn’t working

bg Patrick

0 Likes

(Michele) #503

I tried to update OH 2.5.0.snapshot , I had problems. In the end I gave up and returned to the OH 2.4.0

I had no problems with this command

0 Likes

(Arnaud) #504

Hello Stefan,
Sorry for the late response.
After a reboot, the error is gone.
Regards
Arnaud

0 Likes

(stefan) #505

hi patrick,

i had similar problems with “openhab-transport-serial” and "esh-io-transport-upnp
"
they did not work, when tried to install or remove them i received an error.

tried with clear cache like this did not work:

sudo /bin/systemctl stop openhab2.service
sudo openhab-cli clean-cache
sudo /bin/systemctl start openhab2.service

don´t know why but for me at last worked to clear the cache with this command:

sudo service openhab2 stop && sudo rm -rf /var/lib/openhab2/cache/* && sudo rm -rf /var/lib/openhab2/tmp/* && sudo reboot

after the reboot i was able to install the two features again.

best, stefan

0 Likes

(Patrick) #506

Hi,
i have tested both way and it doesn’t works for me :frowning:
bg

0 Likes

(Michele) #507

With OH 2.5.0 there are too many changes in progress, it is better to wait

0 Likes

(Arnaud) #508

Hello,
For information, I contacted legrand’s professional relations department to inform them of the MyHome server1 problem.
They asked me to send them the screenshot with the error.
I hope the mistake will be corrected soon.
Regards
Arnaud

0 Likes

(Patrick) #509

So i have done a new installation :slight_smile: and a stay at stable openhabian 2.4 :slight_smile:

0 Likes

(Michele) #510

excellent

0 Likes

(Wouter Born) #511

Maybe you can tune the logging of the binding a bit?
In Discovery of unsupported devices filling up log @gozilla01 had some issues with this.
Bindings that are already part of openHAB follow these logging guidelines.

0 Likes

(Michele) #512

Perhaps, are you referring to this other discussion?

0 Likes

(Wouter Born) #513

Yes that’s why I linked to it in my second line :slight_smile:

0 Likes

(Michele) #514

Sorry, you’re right

0 Likes

(Massimo) #515

Hallo,
Here you are the new OpenWebNet binding release: 2.5.0-M2 which also includes the enhancements released in January (2.5.0-M1) (I did not advertise it to all).
The binding now follows the openHAB milestone release scheme and is attached to the openHAB 2.5.0 dev branch.

Improvements

This releases brings gateway automatic discovery and some bug-fixes:

  • [FIX #28] automatic discovery of BUS gateways is now supported
    • gateway model, firmwareVersion and serialNumber are read from UPnP discovery
  • [FIX #29] Fixed (again) Automation command translation (1000#)
  • [FIX #39] Energy Meter subscription (every 10min)
  • [FIX] corrected deviceWhere address management for ZigBee devices and discovery of ON_OFF_SWITCH_2UNITS
  • [FIX #54] CEN scenarios are now detected when activated from Touchscreens (added PRESSURE>RELEASE schedule)
  • [FIX #56] Thermostat Cannot set setpoint temperature (now WHERE=N is first used, then WHERE=#N if it fails)
  • [FIX #59] added discoverByActivation parameter (optional) to BUS gateway
  • [FIX #4] added support for BTicino movement sensors (like AM5658 Green Switch)
  • added Switchable tag to shutter channel
  • updated to openHAB 2.5.0 dev branch

I also added a new FAQ section to the README.

This is a demo of the gateway automatic discovery:

bridge_discovery480

IMPORTANT
If you have multiple gateways in your BUS systems that support UPnP discovery, they will all be discovered and put in Inbox, but only one gateway at a time should be selected/configured and used with openHAB to avoid duplicate items and confusion in things/item configuration.

Installation and Upgrade

This binding version is compatible with openHAB 2.3 and later.
To install/upgrade to the new version of the binding, as always CAREFULLY follow the instructions in the README.

JAR File: https://github.com/mvalla/openhab2-addons/releases/download/own-2.5.0.M2/org.openhab.binding.openwebnet-2.5.0-M2.jar

Ciao!
MASSI

0 Likes

(Michele) #516

Massimo, thank you

0 Likes