[BTicino/OpenWebNet] New openHAB2 binding ready for testing

bticino
openhab2
openwebnet
Tags: #<Tag:0x00007fe0634f9e30> #<Tag:0x00007fe0634f9cc8> #<Tag:0x00007fe0634f9b10>

(Michele) #477

I do not know much because I do not have myhomeserver1
From your browser (chrome or other) from the ip address (I think 192.168.1.35) and enter the configuration


(Arnaud) #478

Hello,
the problem comes from MyHomeServer1
On my test setup, I have an F454 (2.0.51) and a MyHomeServer1 (2.3.8)
I did a test of * # 2 * 0 ## on the 2 webserver
Here is the result on the photo.
The problem is on MyHomeServer1. It is therefore necessary to contact Bticino to make a correction on the next firmware

Regards
Arnaud


(Federico) #479

ok tx Arnaud. I still don’t know how to get my firmware version.
I’ll try tomorrow to remove the physical config on all 4 actuators for the shutters and try to access via home_up on mobile, maybe there i could get the version.


(Arnaud) #480

Fede,
To obtain the firmware number.
Open MyHome_Up
You add a user, after the search you click on your gateway then you click on “I do not have identifiers” and you connect with the “pin code” installer.
Once connected you will know “other” lower right then “system” on the 5th line.
You will have the firmware version and the version of the application.
For mine it is:
Firmware: 2.2.14
Application: 2.3.8

Regards
Arnaud


(Michele) #481

Do not you offer a firmware update?


(Michele) #482

If I’m not mistaken, it’s on the webserver’s label
image


(Marco) #483

Hi all and thanks Massimo for the great job done!
I’m an OH2 newbie but, testing with success the 9.2 binding.

Using an MH200N as server. Got following stuff working:

  • light switch, dimmer and light general (where 0)
  • thermostat
  • energy management (current energy consumption)

Not essential but, what is the best way to configure central heating thing (99 zones)?

Waiting for new release and new supported things! :+1::+1:

Regards,
Marco


(Massimo) #484

I suggest we close this discussion as this is an already known issue: some updated versions of the BTicino MyHomeServer1 gateways are answering invalid frames when requested for automation devices in the system.
Some users have already contacted BTicino support: apparently they answered that since MyHomeServer1 is not an official OpenWebNet gateway, support for the OpenWebNet language is not guaranteed (I have another opinion, but it does not matter :sweat_smile:)

Solution

Add your Automation things that cannot be found using manual config from PaperUI:
PaperUI > Inbox > search for things > openwebnet > ADD MANUALLY at the bottom > Automation
just configure your WHERE address, for example 93.
In fact the problem is only with auto-discover. Once you add the Thing manually it will work normally.

Links to Issue

See issue reported here:

and on the BTicino official forum (no answer from BTicino staff so far… they are not moderating the forum since many months now):


(Massimo) #485

Hi @marchino , happy to see that a lot of stuff in your system is supported correctly by the binding!

The central unit itself is not supported yet, sorry.

massi


(JP) #486

Massi,

Are you planning to support it? (central unit 3550)

Thanks


(JP) #487

Is this beter?

2019-02-05 09:11:52.432 [ERROR] [penwebnet.message.OpenMessageFactory] - ##openwebnet## INVALID FRAME: *13*26##

==> /var/log/openhab2/events.log <==

2019-02-05 09:11:52.503 [vent.ChannelTriggeredEvent] - logreader:reader:9e852bdb:newErrorEvent triggered 2019-02-05 09:11:52.432 [ERROR] [penwebnet.message.OpenMessageFactory] - ##openwebnet## INVALID FRAME: *13*26##

(JP) #488

the other one also in correct format

2019-02-05 17:42:35.023 [WARN ] [.handler.OpenWebNetAutomationHandler] - ==OWN:AutomationHandler== updateAutomationState() FRAME <*2*1000#0*76##> NOT SUPPORTED for thing openwebnet:bus_automation:MH200N:kitchen_rear_curtain, ignoring it.

==> /var/log/openhab2/events.log <==

2019-02-05 17:42:35.547 [vent.ChannelTriggeredEvent] - logreader:reader:9e852bdb:newWarningEvent triggered 2019-02-05 17:42:35.023 [WARN ] [.handler.OpenWebNetAutomationHandler] - ==OWN:AutomationHandler== updateAutomationState() FRAME <*2*1000#0*76##> NOT SUPPORTED for thing openwebnet:bus_automation:MH200N:kitchen_rear_curtain, ignoring it.

==> /var/log/openhab2/openhab.log <==

2019-02-05 17:42:35.576 [WARN ] [.handler.OpenWebNetAutomationHandler] - ==OWN:AutomationHandler== updateAutomationState() FRAME <*2*1000#2*76##> NOT SUPPORTED for thing openwebnet:bus_automation:MH200N:kitchen_rear_curtain, ignoring it.

==> /var/log/openhab2/events.log <==

2019-02-05 17:42:36.550 [vent.ChannelTriggeredEvent] - logreader:reader:9e852bdb:newWarningEvent triggered 2019-02-05 17:42:35.576 [WARN ] [.handler.OpenWebNetAutomationHandler] - ==OWN:AutomationHandler== updateAutomationState() FRAME <*2*1000#2*76##> NOT SUPPORTED for thing openwebnet:bus_automation:MH200N:kitchen_rear_curtain, ignoring it.

(Giampaolo Fabiani) #489

Hi Massimo,

I would like to congratulate you for the excellent work done!

i succesfully installed openhab2 on my raspberry, setup your openwebnet binding component and it’s work fine!. i have also activated the alexa binding and it’s work fine also!.

my web server model is F453AV.

bye.

giampaolo.


(Federico) #490

Ciao Massimo,
tks for all your information.
By the end I followed your suggestions inserting the shutters manually in PaperUI. Now I can see them online in things as Automation and I can control them as well from PaperUI->Controls. Unfortunately when I browse all the objects from google Home via the openhab account in cloud I just see the switches and not the shutters. Any idea?


(Federico) #491

Sorry guys if i bother you but it’s just now if i bought an object (Bticino MyHomeServer1) useless. Like I said in the last post I succeeded , as suggested by Massimo, adding shutters manually on paperUI and so I can control them from there. The issue is related to the comunication with google home where they aren’t showed during import from openhab.
I’ve enabled logs on rasp and seen still the same error related to wrong frame format.
Do you think is there another workaround or should i think to buy another gateway for example F454?


(stefan) #492

hi federico,

i don´t know the myhomeserver1 at all. i use an mh200n as gateway, what this is not an official gateway too, but as far as i could test it works for me.

if you really want to buy another gateway perhaps think about the f455. to be clear: i CANNOT tell you if everything works there, but it is much cheaper than the f454 and it is an official gateway. this surely depends what else you want to use the webserver. perhaps somebody else uses it and can confirm if everything works that you need.


(Tom) #493

Hi Federico,
I have a MyHomserver1 too, but don’t have Google Home. My log file reports the frame error too (FRAME <21000#0*… NOT SUPPORTED for thing…) when my rule is telling the shutters to open or close, but they work anyway.
I’ve put everything in the things, item, sitemap and rule files.
Ciao


(Federico) #494

Tks Tom . I didn’t edit the files by myself. I followed all the suggestions of Massimo and they worked if i use the shutter control from PaperUI but as I said I bought MHS1 just to pilot all devices remote and via Google Home. I hope BTicino will release a new version of the firmware 'cause this is really a silly bug.
ciao


(Federico) #495

Hi Stefan,
as soon as I have time I’ll try to get in touch with a BTicino consultant to understand which solution could be more efficient and matching my needs (no so many just control on remote and via bigG assistant on free cloud as openhab).
ciao


(Michele) #496
2019-02-05 17:42:35.023 [WARN ] [.handler.OpenWebNetAutomationHandler] - ==OWN:AutomationHandler== updateAutomationState() FRAME <*2*1000#0*76##> NOT SUPPORTED for thing openwebnet:bus_automation:MH200N:kitchen_rear_curtain, ignoring it.

==> /var/log/openhab2/events.log <==

2019-02-05 17:42:35.547 [vent.ChannelTriggeredEvent] - logreader:reader:9e852bdb:newWarningEvent triggered 2019-02-05 17:42:35.023 [WARN ] [.handler.OpenWebNetAutomationHandler] - ==OWN:AutomationHandler== updateAutomationState() FRAME <*2*1000#0*76##> NOT SUPPORTED for thing openwebnet:bus_automation:MH200N:kitchen_rear_curtain, ignoring it.

==> /var/log/openhab2/openhab.log <==

2019-02-05 17:42:35.576 [WARN ] [.handler.OpenWebNetAutomationHandler] - ==OWN:AutomationHandler== updateAutomationState() FRAME <*2*1000#2*76##> NOT SUPPORTED for thing openwebnet:bus_automation:MH200N:kitchen_rear_curtain, ignoring it.

==> /var/log/openhab2/events.log <==

2019-02-05 17:42:36.550 [vent.ChannelTriggeredEvent] - logreader:reader:9e852bdb:newWarningEvent triggered 2019-02-05 17:42:35.576 [WARN ] [.handler.OpenWebNetAutomationHandler] - ==OWN:AutomationHandler== updateAutomationState() FRAME <*2*1000#2*76##> NOT SUPPORTED for thing openwebnet:bus_automation:MH200N:kitchen_rear_curtain, ignoring it.

@jpcolin @Tommyshome
Hello,
the frame *2*1000#*2*76## is not an error, but to be implemented.
what version of OpenWebNet bindings are you using?