Cam Nest Binding: issue with has_motion state

Tags: #<Tag:0x00007f616eb08638>

Hi,

I’m currently running OH 2.4 using the latest Nest Binding.
In the OH console, whenever I type in the command:

item list Nest_Motion_Detect

I get the following:

Nest_Motion_Detect (Type=SwitchItem, State=ON, Label=null, Category=null)

even though no motion is occurring.

Is ON the default state for the has_motion channel type id? That would not be intuitive …

Thanks,
Randy

First, in case you missed it, Google announced that the Works with Nest API is being shut down on September 1 of this year, at which time the Nest binding will no longer work.

Second, different technologies and even different devices within one technology handle motion detection different. Some will sendCommand ON when ever it sees motion, usually with a cool down period where it goes blind but then never send OFF. Others will send ON every time it sees motion and then send OFF after a certain amount of time of no motion. Some will send ON every time it sees motion followed by an OFF and then a new ON command again for the next motion detection.

I don’t know how the Nest works in this regard but suspect it’s the first way. It send’s ON but never OFF. So any Rules that need to be triggered by motion needs to look for ON commands and not really pay attention to the state of the Item.

Thank-you @rlkoshak!

I did not know that Works with Nest API will be shut down on Sept 1. I certainly hope an API will be available for Works with Google Assistant that will enable the development of a new binding.

I used the “received update ON” in the when section of the rule and was able to catch the triggers. So your suspicion of the first scenario is correct.

Thanks,
Randy

All indications are that this will not be the case. See this thread for a more full discussion. It looks like Google will only allow access to a few heavily vetted partners. Since IFTTT doesn’t make that cut, openHAB has no chance of being approved.