Cannot select any items in HABPanel

Hi There,

I tried to create my first panel in HABPanel but unfortunately I cannot select any items in the drop down menu to bind it to a tile :frowning:
Any suggestion whats causing this?

I see from the Developertools in Chrome that it tries to call the URL when clicking on the DropDown, the response it gets is:


Platform information:
Hardware: RaspberryPi3
OS: OpenHabian (latest)
Java Runtime Environment: OpenHabian (latest)
openHAB version: 2.1

I do not have high confidence this will work, but often 500 errors in version 2.1 can be corrected using Clear the Cache.

You should be getting some exceptions in openhab.log. Can you post them if clear the cache doesn’t work?

Ha! That actually worked partly. The URL now returns a JSON with items, however the JSON array of the response is cut-off after 32740 characters and so still nothing is displayed in HABPanel as the JSON response is invalid.

I do not see an error in the logs

Ok, so it worked for the first start as written before, I now have restarted and deleted the cache several times and I never got it “working” again like the first time. I now always still get
as response…

I have attached some logs, maybe they give a clue?..
I renamed them to CSS as it’s forbidden to upload *.log or *.zip files in the forums

openhab.log.css (63.0 KB)
events.log.css (84.8 KB)

I hope someone can help. Like I said, it was a long shot.