Cannot set custom position to Aeotec Nano Shutter

Aeotec Answer:

This is normal for the current version of Nano Shutter, it does not support positional controls based on the libraries that it supports for Multilevel Switch, although the support for that command class is meant for dimming type controls.
In the Multilevel Switch controls, it supports Ramp UP, Ramp DOWN, and STOP controls only.
It does not support intermediate values.
We are looking into possibly changing this reaction to allow more positional settings for Nano Shutter.

Ok, so you should have access to these up/down commands at least so you should have control of the device.

I do and it’s working (from the beginning).
I just cannot set any intermediate value.
But, here’s the rest of my discussion with Aeotec:

In any case, I do have an OTA update but it is not yet certified , i am asking if i can provide it temporarily at this time or if there is still development going on.
I should be able to get back to you earlier next week. At the minimum, i can provide you with the new documentation.

1 Like

Got a new email from Aeotec Support.
They just made public the last developper documentation for the Nano Shutter. Now including intermediate positioning.
Can be downloaded right there:

Just to understand: will Aeotec provide a software update that will cover the custom positioning? How can this software update be installed on a device connected to openhab?
Thanks for the clarification.

You can’t. You will need special software:

Hi folks,

Got an email from Chris (Field Application Engineer at Aeotec)
Nano Shutter update is now available for positional control or venetian blinds support: Nano Shutter (ZW141) Update Z-Wave firmeware

Updated user guide: Nano Shutter user guide.

I saw that the nano shutter on the database is not updated (last update in august.
Who’s normally doing this?

Chorus of “You are!” :wink:

Well, you can at least. Probable need advice about versioning though.

1 Like

This is a community project, so, the community :slight_smile:

I’m not exactly sure what “this” is though - if there is a new firmware, and it changes the functionality, then it will require a new database entry. If the functionality is still the same (no new parameters or channels) then it doesn’t need a change.

1 Like

Sadly folks, updating the database is quite far of my knowledge I’m afraid.
I’ve done the full communication with the Aeotec guys, the firmware is released, I did upgraded (hopefully with success), but the device is not recognized:
Window Covering Position/Endpoint Aware
Unknown: type=0003, id=008d (Node:2 Complete)

Hope to be able to access the button parameters soon with the db update, because my physical buttons are not working anymore…

That doesn’t sound like any of openHAB’s business?

Well, since the device is unknown and there is no parameter for the it, I cannot edit the parameters 85, 120, 121 for instance, to setup my buttons behavior.

It’s there:

you need to upgrade to a recent 2.5 snapshot binding:

First update, then include the device, then post your xml file.

Edit: okay, you don’t need to post your xml, the parameters are already in the database, please just upgrade to a recent snapshot zwave binding:

Truth be told, I’m not using anymore OpenHab, neither Hass or any similar.
I’m using Node-Red for all my “scripting” and Zwave2Mqtt to setup my devices parameters only.
Zwave2Mqtt relies on Open-Zwave but the zw141.xml one have not been updated since June (
Would downloading the updated xml be enough in my case?

Then you need to be posting to a zwave2mqtt forum. How are we supposed to help you with software we have written and no one here uses?


At least, I’ve kept any people using —OpenHab— informed of the situation about the Nano Shutter on this topic over the months… I thought that was a “community” spirit… but I guess simply telling the truth of my real use case was a mistake (obviously by the “community” definition).
One could have said: “OpenHab is not relying on Open-Zwave, so that’s the reason blabla…” but sure, I’ve posted on Zwave2Mqtt discussions.
Thanks for the reminder.

I’ve just run OpenHab last snapshot, from scratch:
Z-Wave Node 002 (0371:0003:008D:3.0) Unknown Device
Voilà :frowning:

No - it’s not… This is the wrong entry - there doesn’t seem to be an entry for this device in the database as far as I can see.

Aeon have changed manufacturer IDs…

These are the only info I can give you when I click “show properties” while editing the Thing:

zwave_beaming true
zwave_class_basic BASIC_TYPE_ROUTING_SLAVE
zwave_deviceid 141
zwave_devicetype 3
zwave_frequent false
zwave_listening true
zwave_manufacturer 881
zwave_nodeid 2
zwave_plus_devicetype NODE_TYPE_ZWAVEPLUS_NODE
zwave_plus_roletype ROLE_TYPE_SLAVE_ALWAYS_ON
zwave_routing true
zwave_secure false
zwave_version 3.0