Cannot upgrade from 2.3 to 2.4 / bindings are failing

  • Platform information:

    • Hardware: Raspberry pi 3
    • OS: Linux / Volumio debian
    • Java Runtime Environment: java version “1.8.0_191”
    • openHAB version: 2.3 or 2.4
  • Issue of the topic: Not able to succesfully upgrade from 2.3 to 2.4

  • If logs where generated please post these here using code fences:

2019-04-19 09:45:24.815 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-package-demo': No matching features for openhab-package-demo/0.0.0
2019-04-19 09:45:24.906 [ERROR] [url.mvn.internal.AetherBasedResolver] - invalid repository URLs no protocol: system/
        at<init>( [?:?]
        at<init>( [?:?]
        at<init>( [?:?]
        at org.ops4j.pax.url.mvn.internal.config.MavenRepositoryURL.<init>( [4:org.ops4j.pax.url.mvn:2.5.4]
        at org.ops4j.pax.url.mvn.internal.config.MavenConfigurationImpl.getDefaultRepositories( [4:org.ops4j.pax.url.mvn:2.5.4]
        at org.ops4j.pax.url.mvn.internal.AetherBasedResolver.selectDefaultRepositories( [4:org.ops4j.pax.url.mvn:2.5.4]
        at org.ops4j.pax.url.mvn.internal.AetherBasedResolver.resolve( [4:org.ops4j.pax.url.mvn:2.5.4]
        at org.ops4j.pax.url.mvn.internal.AetherBasedResolver.resolve( [4:org.ops4j.pax.url.mvn:2.5.4]
        at org.ops4j.pax.url.mvn.internal.AetherBasedResolver.resolve( [4:org.ops4j.pax.url.mvn:2.5.4]
        at [10:org.apache.karaf.features.core:4.1.5]
        at [10:org.apache.karaf.features.core:4.1.5]
        at java.util.concurrent.Executors$ [?:?]
        at [?:?]
        at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201( [?:?]
        at java.util.concurrent.ScheduledThreadPoolExecutor$ [?:?]
        at java.util.concurrent.ThreadPoolExecutor.runWorker( [?:?]
        at java.util.concurrent.ThreadPoolExecutor$ [?:?]
        at [?:?]
2019-04-19 09:45:25.319 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-binding-hue, openhab-binding-exec, openhab-misc-restdocs, openhab-misc-openhabcloud, openhab-binding-network, openhab-ui-habpanel, openhab-misc-hueemulation, openhab-binding-denonmarantz, openhab-transformation-map, openhab-binding-rfxcom, openhab-binding-kodi, openhab-transformation-exec, openhab-ui-paper, openhab-binding-wol1, openhab-binding-samsungtv, openhab-voice-voicerss, openhab-binding-weather1, openhab-transformation-regex, openhab-action-telegram, openhab-persistence-rrd4j, openhab-ui-basic, openhab-binding-ntp, openhab-misc-homekit, openhab-binding-astro, openhab-binding-expire1': Error:
        Error downloading

Hi Guys,

I wanted to upgrade Openhab 2.3 to 2.4 but i’m failing. I’m running a manual installation of Openhab because it runs on a raspberry pi 3 with Volumio installed which is my internet radio in my house. Volumio cannot be installed manually so i have to install openhab manually on the Volumio image which is linux debian.

Openhab 2.3 was running without any problems but i wanted to use geofencing and wanted to use the new openweather binding. I tried to upgrade by simply copying the 2.4 files to /opt/openhab2 folder. It copied succesfully but when i started openhab, the homescreen showed in the bottom version 2.3.0, so something went wrong. After reading the manual installation for linux I saw the upgrade was just executing the command: sudo runtime/bin/update 2.4.0. But when I try that, it says I’m already on 2.4.0. Now the problem is, my logfile is filled with the error i posted above, problems with the binding. And my Bindings window in paper ui doesn’t show any bindings anymore.

Does anyone have a sollution for this, or should I uninstall openhab 2.3 and install 2.4 again. I copied all my rules files to my computer, so I guess I won’t lose any of my 1300 lines of code :slight_smile:

Always try [SOLVED] No Connection to openhabian after clearing cache first for errors like these.

Thanks, but things gone differently. Volumio wasn’t working also so I installed everyting from a clean start. Nothing wrong with that I think. I’m on 2.4 now. Having some isues with RFXCom, but will conquer that haha.