Can't access my sitemap from outside my network

Since the outage that happened yesterday (Monday, Jan 4 2016 from about 3pm to 6pm) I am not able to access my sitemap from outside my wifi network (work or 4G on my phone). It gives an error “Openhab is offline”. But I am able to access and able to login etc where I get the message that my openhab is offline.
And strangely, when I access from inside my wifi network it says not available (ERR_CONNECTION_TIMED_OUT). I’ve tried this from 4 different machines that are on the same wifi network and it gives the same error. But then from within the network the sitemap is accessible and everything is functional.
I am guessing that outage yesterday did something to my setup. Do I follow this guide?
So far the only thing I’ve tried is to delete my account and regenerated uuid (by restarting openhab) and plugged that in the account but still no go.
Thanks for any help.
Running OpenHab 1.7.1 on Raspberry Pi2.

I had a similar problem yesterday (10pm to 11pm CET) which was solved after I rebootet my server (in your case the Raspberry). I don’t know whether this really is connected with each other but the problem I’ve had where quite similar (OH offline and no possibilty to access the website from with in the LAN).

I must admit that I’m not really happy with this situation :frowning: :frowning: esspacially as I don’t know what the problem was. Maybe someone with log file access to my.openhab can analyse this problem?

1 Like

Thanks, but that did not do it. It feels as if my IP is blocked by for whatever reason. Not sure whom to check with.

What are you seeing in the logs? During the troubles yesterday (I’ll also note that while my.openhab was having problems so was this forum) I saw a lot of these lines in my log.

2016-01-05 02:47:26.578 [ERROR] [.myopenhab.internal.MyOHClient] - Socket.IO error: com.github.nkzawa.engineio.client.EngineIOException: xhr post error
2016-01-05 02:47:26.579 [INFO ] [.myopenhab.internal.MyOHClient] - Disconnected from my.openHAB service (UUID = long random string of characters, base URL = http://localhost:8080)
2016-01-05 02:47:29.088 [INFO ] [.myopenhab.internal.MyOHClient] - Connected to my.openHAB service (UUID = long random string of characters, base URL = http://localhost:8080)

Are you seeing similar lines in your log file currently?

Yes, last evening I got those errors and the last message I got was MyOHClient is shuttign down and after that it’s has not been up.
But more strange is how none of my devices from my home wifi are not able to connect to It’s as if my ISP blocked that site for me. Connecting from VPN or 4G on my phone works but shows my openhab is offline.

Hmmm. Can you ping Currently it resolves to for me. Can you ping that address directly? If yes maybe try a different DNS server. I’ve successfully used,, and in the past.

Thanks for the help.
I am able to transmit but not receive the packet.

pi@raspberrypi ~ $ ping -c 1
PING ( 56(84) bytes of data. ping statistics —
1 packets transmitted, 0 received, 100% packet loss, time 0ms

From my windows PC at home I get request timed out message. I think it’s got to do with my setup here than openhab at this point, so not sure if this forum is the right place for these questions. But would be happy to resolve this here if possible.
I made a copy of my SD card 2 weeks ago and can restore that as-is, but I don’t know how that would help me not being able to connect to

This seems to be out of the bounds of what we can help with. Something is blocking your access to the IP address where resides. At least we know that your DNS server is correctly resolving the IP so the possibilities are either something on your network is blocking access to that IP (firewall, router, IPTables, etc), your ISP is blocking access to that IP address, or is blocking YOUR IP from access.

I’m afraid I won’t be much help here.

1 Like

Ok, thanks for the possible clues I can go after. Will report back if I resolve this.

Ok resolved it. Seems like my IP address was added to the “BAND (banned?) LIST” and I had to change my router’s MAC address. Now it’s fixed.
The reason this happened is below and is true in my case. But I was just monitoring my devices (maybe a bit too much) :smile:

This problem occurs when viewing the same site over a router from more that one computer or application at the same time for a period of time. This activates something in the server software that puts your IP address on a so called “BAND LIST”.

More info on the solution here.


There seems to be a bigger problem.
The system is not available (for me between 3 and 4 am CET) and this has nothing to do with my network. The website is also not available via 4G and from my office.

Due to the time this morning I’m asking myself whether or not it has something to do with my daily (forced) dsl-reset with (most-likely) new IP. At least it happens only a few minutes after the reconnect. Maybe there is an IDS running wild? Or there is just a script-kiddie who has learned how to do a DOS attack :wink:


Ok, this happened again and I had to change the MAC address again (but toggled to default mac instead of manually assigning it). And seems like that’s all I need to get back online (but not looking forward to do this all the time). But like Dieter mentioned, maybe it’s part of a bigger problem. Let’s see if this happens again or something new comes up.

I’m quite sure that it’s a bigger problem and definitly not part of your configuration as I’ve had it yesterday from different clients on different networks (also including IFTTT).

What’s interesting for me is, that the server (after I could log in again) said that my openhab was online since Dec. 27th which is definitly not true. But the date is interesting as on this date the problems started for me.

Yes, not sure what’s going on. I am hoping these will get resolved soon. I depend on ifttt for some triggers, but after recent experience with I’ve been wondering if there are other options to set triggers and actions without ifttt.
Anybody have experience with weaved? Or other ways to access raspberry pi over the internet?

I set up OpenVPN and just port-forward a port for it and another for SSH. If I need to connect to my OH server from outside my LAN I connect to the VPN. If setting up OpenVPN is a little too difficult for you (it is a major pain to get set up) LogMeIn has a tool called Hamachi which I’ve successfully used in the past. Hamachi does not require portforwarding in your router and is much simpler to set up.

Thanks Rich, I might go that route and do have some experience (but not looking forward to setting it up). Although, something like logmein might be an easier option too.
And update on the, it shows I am online but can’t access my sitemap.

At this point I am wondering if I should transition to openhab2. I have hue bridge (with 5 bulbs 3 different ones) and 3 sensors from my rooms via MQTT (using NodeMCU) that send weather data and control few switches. Any suggestions if I should jump now or wait for the official one?

edit: removing SOLVED from title.

I’ve none. My time is a bit limited right now so I’ve invested any playing around with OH 2 so I don’t know whether or if it works with all of those bindings or whether it does something different with my.openhab or if you will end up right back where you started.

How are you trying to access your sitemap through my.openhab? If your sitemap is named “default.sitemap” the following URL should work (it works for me).

If not I think it follows the same syntax as when you access your sitemap on your local LAN with the additional “sitemap=name” parameter (which I don’t quite remember how the syntax works right now).

I had no problems for few weeks accessing This started only recently when the site was down for few hours and was reported here. Rest is documented here. Although, I think I should do a full reset of openhab as I’ve been deleting addons that I think are not necessary (but I don’t know). I initially unzipped the entire addon archive into the addon folder then realized (based on my logs) that I don’t need them as I don’t have most of those devices and kept deleting them one by one. But maybe I should revisit which addons I really need and don’t need. Is there a list of critical addons I should have? I use NTP, Hue, MQTT, Weather and my.openhab and persistence RRD4J… can I delete the rest?.
Ignore add-on question, I should obviously RTFM carefully.