Can't access OpenHAB3 via Safari on iPad iOS9.3.5

Hi folks,

Hope someone can help me out with this, I’ve searched everywhere and can’t find any advice to address this issue.

Problem:
I upgraded from OpenHAB2 to OpenHAB 3 and have difficulty to access the OpenHAB webUI on some of my devices…

I have several iPads

Newer ones (eg: iOS14), I can access my OpenHAB server via http://openhab:8080/#!/

Older ones (iOS 9), I use as a wall mounted controller and I cannot access and get this message:

A problem repeatedly occurred on "http://openhab:8080/#!/

What have I tried?
I’ve tried to connect to:

  • the server name
  • ip address
  • with and without the trailing /#!/.

I have also tried to access via Safari and Chromeniether are able to connect

Any advice? is iOS 9.3.5 not supported?

4 Likes

I have the same problem

I’m having problems with Login in as well. Mostly because i want to use my old habpanels.
Dont know if it the same issue as yours.
I can connect with the main 192.x.x.x:8080 but i can not press the login in the bottom left.
I am on an older iPad with IOS 10.3.3.

Wondering if it has something to do with Java 11.

I have the same problem too.

And me too, both with the web browser and the native app :frowning:

Is there a plan to support IOS 9.3 ? It would be nice as it gives a second life to some old ipads that work perfectly well.

Please check OH3 webapp does not work on iOS 9.3.5 · Issue #759 · openhab/openhab-webui · GitHub

Long story short

Framework7 (v5) needs Safari 9.1 and iOS 9.3.5 ships with Safari 9.0 so unfortunately MainUI will not run on iOS 9.3.5 - iOS 10 is required as minimum.

:frowning:

but thanks for the answer !

Are there any work arrounds so I can still use ipad2 as panels.

Accepting it cant use the new ui, habpanel says they need to login which takes me to the ui and doesn’t load.

Failing that I guess I could run a 2.5 instance with some dummy controls which the oh3 instance monitors.

Oh a search lead me here and down a rabbit hole, when it was actually just a simple issue that I hadn’t set the habpanel as the default.

Ipad2 running kiosk Pro displaying habpanel fine.