Can't access WebUI/Dashboard (http://Openhab:8080)

* Platform information:
  * Hardware: 
Raspberry 4/4GB
  * OS: 
latest stable Raspbios
  * Java Runtime Environment: 
openjdk version "1.8.0_272"
OpenJDK Runtime Environment (Zulu 8.50.0.259-CA-linux_aarch32hf) (build 1.8.0_272-b17)
OpenJDK Client VM (Zulu 8.50.0.259-CA-linux_aarch32hf) (build 25.272-b17, mixed mode)

  * openHAB version: 2.5.10-1
* Issue of the topic: Can't access the WebUI/Dashboard
* Please post configurations (if applicable):
  - I don't know else where to look for this Problem or errorlogs, everythings fine, only the Webserver isn't accessable/installed for :8080
* If logs where generated please post these here using code fences:
- first-boot.log is actually empty ..

Hey Community!
OH 2.5 is giving me some Headaches …
Since the last OH Update from 2.4 to 2.5.10 messed up with my Jython triggers I’ve decided to update to the Raspberry 4. I’m able to start/stop etc. the Openhab daemon, access the Samba-share and everything else is pretty much working, even the http://openhab:9001/ logviewer. I installed the last stable version of Openhab(ian) via openhabian-config. Did the same thing for the Java version.
But I can’t access Openhab:8080 to access my sitemaps or the PaperUI.
Any Help here?


As you can see, it doesn’t accept the connection
Thanks in advantage …

What is the content of openhab.log ?

What does

exactly mean ? Timeout message ? Empty page or something else ?

It’s empty…

It’s a connection refused

So

sudo netstat -tulpe --numeric-ports | grep 8080

does not show a line with the word LISTEN like

tcp6       0      0 :::8080                 :::*                    LISTEN      openhab    39461       1504/java

?

What does

sudo systemctl status openhab2.service

show ?

it shows this:

I’m using a HDD on a usb Port without a SD Card btw

The threads title ( http://Openhabian:8080 ) does not match with your description ( http://openhab:9001 resp.Openhab:8080 ). Could you correct the title, please.

What is the output of

sudo netstat -tulpe --numeric-ports

if possible redirect the output to a file by adding

> /tmp/file.txt

at the end of the above command. You then can copy the file to the samba share and take it from there to upload the file. The file will be written to /tmp directory and the anem will be file.txt.

Yeah, but the Hostname is individuell anyway, just wanted to mention in the title that this Error occurs on Openhabian.
Sorry, as you can see I didn’t get any Output in the console, but it works via a file:

Proto Recv-Q Send-Q Local Address           Foreign Address         State       Benutzer   Inode      PID/Program name
tcp        0      0 0.0.0.0:9001            0.0.0.0:*               LISTEN      frontail   45779      7811/node
tcp        0      0 0.0.0.0:139             0.0.0.0:*               LISTEN      root       42633      6836/smbd
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      root       17587      668/sshd
tcp        0      0 0.0.0.0:445             0.0.0.0:*               LISTEN      root       42632      6836/smbd
tcp6       0      0 [::]:139                [::]:*                  LISTEN      root       42631      6836/smbd
tcp6       0      0 [::]:22                 [::]:*                  LISTEN      root       17589      668/sshd
tcp6       0      0 localhost:40377         [::]:*                  LISTEN      openhab    43954      7379/java
tcp6       0      0 [::]:445                [::]:*                  LISTEN      root       42630      6836/smbd
udp        0      0 0.0.0.0:68              0.0.0.0:*                           root       16421      611/dhcpcd
udp        0      0 192.168.178.255:137     0.0.0.0:*                           root       20562      614/nmbd
udp        0      0 openhab.fritz.box:137   0.0.0.0:*                           root       20561      614/nmbd
udp        0      0 0.0.0.0:137             0.0.0.0:*                           root       20549      614/nmbd
udp        0      0 192.168.178.255:138     0.0.0.0:*                           root       20564      614/nmbd
udp        0      0 openhab.fritz.box:138   0.0.0.0:*                           root       20563      614/nmbd
udp        0      0 0.0.0.0:138             0.0.0.0:*                           root       20550      614/nmbd
udp        0      0 0.0.0.0:5353            0.0.0.0:*                           avahi      11804      317/avahi-daemon: r
udp        0      0 0.0.0.0:33137           0.0.0.0:*                           avahi      11806      317/avahi-daemon: r
udp6       0      0 [::]:546                [::]:*                              root       16432      611/dhcpcd
udp6       0      0 [::]:40658              [::]:*                              avahi      11807      317/avahi-daemon: r
udp6       0      0 [::]:5353               [::]:*                              avahi      11805      317/avahi-daemon: r

Bump.
Any Ideas anyone?

There is only one port that is related to the java binary.
The other ports that are used e.g. to access the karaf console, the dashboard etc. are not open.
You wrote that you somewhen updated from OH 2.4 to 2.5.10 but you also wrote that you updated to Raspberry 4.
What does this mean ? Was the Raspberry a fresh install or did you continued to use the udpated 2.5.10 ?

Yeah on my old Raspbi 3b+, I got everything working fine again except the Jython triggers so all my Jython scripts are kind of useless currently…

I’ve installed a fresh new stable Openhabian OS on my new Raspbi 4. So the 2 Webservers are running simultaneously at the moment in my network…

Okay allright, which ports are those and how can I open them? Or why are they closed in the first place? I’m updating currently from the last stable to the master version of OH, maybe I’ll get some more Information then …

020-12-01_21:18:24_CET [openHABian] Updating myself...
$ update_git_repo /opt/openhabian stable
2020-12-01_21:18:32_CET [openHABian] Updating openhabian, stable branch from git...
$ git -C /opt/openhabian fetch origin

$ git -C /opt/openhabian fetch --tags --force --prune
Von https://github.com/openhab/openhabian
 - [gelöscht]        (nichts)   -> origin/addHotspot

$ git -C /opt/openhabian reset --hard origin/stable
HEAD ist jetzt bei 769ea17 mention systemd timers for sync

$ git -C /opt/openhabian clean --force -x -d

$ git -C /opt/openhabian checkout stable
Branch 'stable' folgt nun Remote-Branch 'stable' von 'origin'.
Zu neuem Branch 'stable' gewechselt
OK
OK - Commit history (oldest to newest):

535d54d - force image build (vor 8 Wochen) <Markus Storm> N
 build.bash | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

c169f61 - fix timer frequency description (vor 8 Wochen) <Markus Storm> E
 includes/sdrawcopy.timer | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

29bb6b7 - fix timer frequency description (vor 8 Wochen) <Markus Storm> E
 includes/sdrsync.timer | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

769ea17 - mention systemd timers for sync (vor 8 Wochen) <Markus Storm> E
 docs/openhabian.md | 1 +
 1 file changed, 1 insertion(+)

openHABian configuration tool successfully updated.
Visit the development repository for more details: https://github.com/openhab/openhabian.git
The tool will now restart to load the updates... OK

So everything went well upgrading to the master version, but I still can’t enter the Webserver UI

they are opened in listen mode by OH software ( java ). In your case ports are not opened. The root cause needs to be found.
Try to shutdown openhab and start openhab in debug mode. Hopefully more info is shown there.
See Starting openHAB in debug mode

Hmm I can’t start my Karaf console in the first place:
image
image
Openhab on Raspbios seems a bit under construction lol - it works on my Raspbi 3b+

This ( 8101 ) is on of the ports that is not opened during startup on your host.
I was more refering to the start with the --debug option to check if there is more debug output available to get information about the root cause of the problem.