Cant change language

Hey, i´ve changed language (de_DE) of openhab 2 by openhabian config tool. After generating locals my default is still en_US. How to change language for Paper UI and HABpanel?

Im using raspberry pi 3 + Razberry

Add the following to /etc/default/openhab2:


It worked for me (in the Netherlands) for openhab1

At least PaperUI has no ability to change language. The language setting that you see is to change the configuration on the server - not the UI. This will result in some server sent messages being localised, but not the main UI itself.

Hello, I’m using openhabian on a rpi3. I don’t seem to have the directory /etc/default/openhab2. Any idea where the file should be located on my system?


Sorry cant help you moved away from openhab 12 months ago due to stability issues. So is no longer installed on my pi.

Gerard Dirkse
gezonden van mijn tablet

Ok, thanks anyway