Can't connect to FRITZ!Box 7560


  • Platform information:

  • Issue of the topic: I try to use the AVM FRITZ! Binding and the Fritzbox Binding TR064 to connect to my Fritz Box 7560, but it doesn’t work. I updated the Fritz OS to the current version 07.01, the TR064 protocol is activated and I add a new user for openHAB. I assume that’s all I have to set up at the FB

With the AVM FRITZ! Binding I am able to find the FritzBox (with name) and can add it as thing. I edit the Configuration Parameters (port, user, password) (I try to use HTTP and HTTPS). But I get the message “Status: OFFLINE - COMMUNICATION_ERROR Request is invalid”

For the TR064 Binding I edit the file fritzboxtr064.cfg. But if I go to the Inbox and select the TR064 binding nothing happens

I also tried dslf-config as user or with no user, but with the same result

Currently I don’t have any logs because I don’t know where I can find them.

I hope someone can help me


Hi Markus,
I do not quite understand what you want to do with the AVMFritz!-Binding. I’m using it to handle my Fritz/Comet-Thermostats and my Fritz-Sockets. I don’t think that you can use it with HTTP or HTTPS(it’s another Binding). Have you read the Docs. As I understand, the Thing you added is only the Bridge(Fritz-Box) but no Things for the devices you want to control.
As TR064-Binding is OH1, I think no Auto-Discovery will work(I do not use it, so it’s only my thinking).

Cheers, Peter

Hi Peter,
That’s correct, I don’t have any devices connected to the Fritzbox. But I assume even without any devices I shouldn’t get an error message.

With HTTP or HTTPS I don’t mean the HTTP binding. In the configuration of the AVM Fritzbox Binding you can enter the IP address of the Fritzbox and also the port (49000 for HTTP and 49344 (I guess) for HTTS). I tried both.

What do you mean with OH1?

Aaah, I understand what you mean with Port:

Thing Configuration


ipAddress (mandatory), default ""
protocol (optional, http or https), default "http"
port (optional, 0 to 65335), no default (derived from protocol: 80 or 443)
password (optional), no default (depends on FRITZ!Box security configuration)
user (optional), no default (depends on FRITZ!Box security configuration)
pollingInterval (optional, 5 to 60), default 15 (in seconds)
asyncTimeout (optional, 1000 to 60000), default 10000 (in millis)
syncTimeout (optional, 500 to 15000), default 2000 (in millis)

But it’s optional. As I understand it you can use 80 or 443. I don’t use it in my Bridge, which looks like this:

Bridge avmfritz:fritzbox:Fritz-Box-7490 @ "Office" [ ipAddress="", user="myusername", password="myusername-password" ] {
  //up to ten switchable outlets
  Thing FRITZ_DECT_210  116570136076 "FRITZ!DECT 210 #1"                    [ ain="1165701xxxxx" ]
  //up to twelve heating thermostats
  Thing Comet_DECT      119601003400 "Comet DECT #1"        @"Office"       [ ain="1196010xxxxx" ]

…and you can use “” as IP-Adress, as shown above in my example.

OH1 is the first Version of openHAB, but it has not the Features of OH2. So e.g. in OH1 you have to use cfg.Files for Configuration. Ther are some Bindings which are not upgraded to OH2, but you still can use it with OH2.

You can see what kind of Binding you are using, when you look in the “Add-ons”-Section in your Paper-UI


So now I have to ask, what is HTTS ? (Sorry, but I’m a Dummy :wink:)

Cheers, Peter

HTTS is just a typo. Should be HTTPS of course.

Ok, I don’t know why, but I tried it again an the Fritzbox using the AVM Binding is online. But I have to let the port and user blank and just enter the password. It doesn’t work with the other user I added for openhab.

But the TR064 Binding still doesn’t work. I comment out all settings in the conf file. Then I go to the Paper UI Configuration/Bindings and edit the parameter of the TR064 Binding. Then I go to the Inbox, hit the +, select the TR064 Binding, but then nothing happens. I just get the headline " Inbox > FritzboxTR064 Binding > Choose Thing", but no Things, no messages.

Can’t get the TR064 Binding to work. Any suggestions?

For me it seems, as if your Fritz-Box-Settings are either mit Kennwort or ohne Kennwort but not with Benutzer und Kennwort

My Fritz-Setup looks like

As said above, TR064 is a OH1-Binding which is not configurable via Paper UI, you have to use a cfg.File as described in the Docs here and using .items-File(s). But I saw that your Fritz-Box 7560 is not in the Hardware-List. Maybe this could be a reason too. What you can do, is to install the Binding via Paper UI. Did you ?

But be aware that the using of the Bindings have different purposes. The AVMFritz!-Bindings is for handling several Devices, connected to the Fritz-Box and TR064-Binding is dealing with the core of the Fritz-Box.
As I’m not using this Binding I can’t help you in this case. So you have to look in the posts on this platform or in the german community here. Maybe there are some hints and tips for you.

Cheers, Peter

You are right. I had the default setting with “Anmaldung mit dem FRITZ!Box-Kennwort”. Now the user and password works for the AVM Binding.

I know that these bindings have different purposes. I want to be able to use the TR064 binding for presence detection (if no Smartphone is connected to the router no one is at home)

I will try to add things and items manually. Thanks for your help

I hope you have created a FRITZ-user, which has all rights :wink:. Do you have iPhones in use ? If yes, I think you can come in to trouble, as it has a"special algorithm"(goes sometimes to sleep and wake up again). But if not, you also can use the network-binding to detect your smartphones, if they are online or not.

Maybe this can be another solution for you (and it’s OH2-Binding)

No iPhones. Thanks for the suggestion. Will test it

Could you post your item definitions?
I would like to try network binding

…no problem.


Thing network:pingdevice:printerWF2760      [ hostname="", retry=1, timeout=5000, refreshInterval=60000 ]
Thing network:pingdevice:pi3b_ohtest        [ hostname="", retry=1, timeout=5000, refreshInterval=60000 ]
Thing network:pingdevice:raspi_office       [ hostname="", retry=1, timeout=5000, refreshInterval=60000 ]
Thing network:pingdevice:iPhonePeter        [ hostname="", retry=1, timeout=5000, refreshInterval=60000 ]
Thing network:pingdevice:iPhoneClaudia      [ hostname="", retry=1, timeout=5000, refreshInterval=60000 ]

. items

Group:Number:SUM    gNet                        "Netzwerk [%d]"                                 <network>               // Number of "Online"-Devices
Switch              Printer_WF2760              "Drucker WF-2760 [MAP(]"            <workforce>   (gNet)    {channel="network:pingdevice:printerWF2760:online"}
Switch              Pi3b_online                 "RPi3b OH-Test   [MAP(]"            <network>     (gNet)    {channel="network:pingdevice:pi3b_ohtest:online"}
Switch              RasPi_online                "RPi3b+ Office   [MAP(]"            <network>     (gNet)    {channel="network:pingdevice:raspi_office:online"}
Switch              iPhone_Peter                "iPhone Peter [MAP(]"               <iphone>      (gNet)    {channel="network:pingdevice:iPhonePeter:online"}
Switch              iPad_Peter                  "iPad Peter [MAP(]"                 <network>     (gNet)    {channel="network:pingdevice:iPadPeter:online"}
Switch              iPhone_Celine               "iPhone Celine [MAP(]"              <iphone>      (gNet)    {channel="network:pingdevice:iPhoneCeline:online"}
Switch              iPhone_Claudia              "iPhone Claudia[MAP(]"              <iphone>      (gNet)    {channel="network:pingdevice:iPhoneClaudia:online"}