Can't connect via SSH, no log, UI and rules working

Hi guys,

this is my first question here, so please don’t be mad at me if I do something wrong, e.g. not giving you enough or the right info.
I’ve been playing with openHAB for a few days now. I have no programming skills, no Linux skills and started completely from scratch,- total noob, so to say. :slight_smile:
openHABian is installed on a RPi 3, connected via WiFi.

Everything appeared to be stable so far, I got all my things and items added (Z-Wave, WiFi, Hue Bridge with plugs, bulbs and motion sensor, openocean), ~20 things total.

Since I found the rules engine it started to be fun, but the more rules I added the more I thought about what would happen if the system crashes with all the work lost. So I wanted to do a backup as descibed here but I couldn’t access the Pi with PuTTY anymore: “Network Error: Software caused connection abort”. The log on port 9001 wasn’t accessible either.

Paper UI and rules are still working normally.

So I pulled the plug off the Pi because I didn’t see any other way to shut it down “softly”. I had to pull the plug two more times for the Pi to boot successfully.

Now it was accessible again and I ran the first script


and it failed, it always said “can’t create… folder is read-only.” After this: the same problem as before. After a short time I can no longer connect to the Pi via SSH (and some other things like the log are messed up too).

Please help!

Use openhab-cli backup instead. This shortcut deals with folder locations automatically. I believe the issue was that you weren’t in openHABs root folder?

If you still have issues using that command, could you post the results of openhab-cli info? :slight_smile:

Thanks for the quick reply, Ben. After another “hard reset” openhab-cli backup worked and it got me a zip file! Awesome. How do I apply that backup zip when I need it?

But my main problem was that the system beyond the web UI crashes in some way and the only thing I can do is cutting off power. How can that be? Could that be a WiFi issue? Might it be helpful to do a new setup with Ethernet instead?

Edit: log viewer is still not working, even after reboot… trying to reinstall it with config ends with some memory access error.

/opt/openhabian/functions/ Zeile 17:  2692 Speicherzugriffsfehler  "$@"
FAILED (frontail)

Keep that zip file somewhere safe, it can be applied by using:

openhab-cli restore /path/to/zip

The default location is /var/lib/openhab2/backups but you might want to move it somewhere separate.

Hmm, sudden lack of access to ssh implies a problem on a system level, not just with openHAB. You could try using Ethernet, but it would also be a good idea to check if the power supply to the is stable.

Thanks for the info about the backup, because I think I’m gonna need it. After two days out I came back home and again something went wrong in the meantime. No rules working, neither UI nor SSH connection possible. In PuTTY I get asked for username and password, but after this no further reaction.

I bought a new 3A power supply. How do I check if it is stable?

So far everything is stable, but still I can’t get the web log back running. When I try

npm install -g frontail

it just says “Speicherzugriffsfehler”, memory access error. Is that about the SD card?