Can't install InfluxDB persistence

I’m having problems when trying to install InfluxDB persistence under OH3 through MainUI–>Other Add-ons–>Persistence Services.

Log file show following errors:

2022-11-22 13:44:40.175 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-persistence-influxdb': Error:
	Error downloading mvn:org.ops4j.pax.logging/pax-logging-log4j2/2.0.12
	Error downloading mvn:org.ops4j.pax.logging/pax-logging-api/2.0.12

I have restarted OH but I still get the error messages. Any ideas?

Which OH version
3.0 … 3.0.2 so have Problems because of shutdown of bintray maven repo.
Version In development Max have other problems. In case of stabile version it could be a problem of your network.

I’m running OH version 3.3.0. Unfortunately I haven’t had time to look at this problem but when restarting OH I do get these errors constantly so OH is trying to install the InfluxDB persistence.

I have tried to find any hints on the forum but no luck so I wonder why installation of InfluxDB persistence fails.

Did you check if antivirus or firewall blocks the access?

Yes, I have turned off the Windows Defender and F-Secure Client Security. I have also tried now to install Miele Cloud binding but this fails also. Something strange with my OH.

EDIT: Just remembered that I got a new cable modem some weeks ago so I need to check that the cable modem is not blocking.

You stated that you run OH 3.3.0. I am running that version on a Pi and I checked the installation for the above mentioned jar library.
As far as I can see on my system that library ( pax-logging-log4j2 ) should come with the basic installation but instead of 2.0.12 version 2.0.16 is provided with the core installation:


Was this OH 3.3.0 installation updated based on an earlier installation ?
To be more precise my installation is 3.3.0-1. Most probably pax-logging-log4j2 was updated due to dependencies to log4j2 which is vulnerable to specific attack vectors.
Although this may explain why an older version is being tried to installed/downloaded this does not explain why it is not installed - apart if there would be software that refuses to download the older version.

Wolfgang, it could be that something is preventing now installation of any binding because I have now tried to install Miele Cloud binding which also fails. Only change I have made in my home LAN is that I got a new cable modem some weeks ago. Unfortunately I don’t have access now to it from work with VNC because I can’t remember the admin password for the cable modem.

I had forgotten completely that I had problems with installation of DSC binding in early October. Solution was in this post.