Cant make openHAB Cloud or the hue binding work with Echo dot to expose KNX Items

Tags: #<Tag:0x00007f617db3e418>

I have set up the KNX Binding with some lights within our home and am now trying to expose those items to the echo dot. I have tried to make it work with the Hue emulation service, however, was not able to make it work. I am running openHAB2 on a win10 PC with the newest version as well as the newest openHAB version. The Cloud has been set up and is working. All Items are visible and work if I control them. I just cannot get them to be exposed to Alexa. I have read a few posts, but none of the proposed ways of fixing the issue worked for me. I have tried getting rid of the www., changing the URL to something wrong, restarting changing it back to the actual URL, and updating java to the newest version. Id appreciate any help I can get with this.

Best
Philip

Are you using files for items? If so, try renaming the file then restart OH and see if Alexa discovers them. BTW are you using tagging on the items e.g. [“Lighting”]?

Full example with V2 tagging:

Switch CouchLight "Couch Light" <light>  ["Lighting"]  { channel="mqtt:topic:pibroker:sonoff2:power" }

Thanks, but Im using PaperUI since I cant figure out how to configure items with files, and because its probably easier with PaperUI. I have tagged them with Lighting in the category option and labelled with where I need it.

I don’t think this is the same as [“Lighting”] on the item but you can use REST API to add the tag if not planning to use files. BTW, if you want to use files the location is /etc/openhab2/items for linux. You will need to check the docs for the correct location on windows but it’s not hard to do after you’ve done one.

The issue isnt that I dont want to use item files, but that there are none in the folder. Im going to take a look at the REST API. Thanks.

You will have to manually add them to the file with a text editor e.g. nano, vim, VSCode. BTW, VSCode is by far the best for file configuration.

Items file example:

Switch LivingRoom_Light "Living Room Light" <light>  ["Lighting"] { channel="mqtt:topic:pibroker:sonoff11:power" }
Number LivingRoom_Light_Temp "Temperature [%.1f °F]"      <temp>             { channel="mqtt:topic:pibroker:sonoff11:temperature" }
Number LivingRoom_Light_Humidity    "Humidity [%.1f %%]"    <humidity>       { channel="mqtt:topic:pibroker:sonoff11:humidity" }

Switch CouchLight "Couch Light" <light>  ["Lighting"]  { channel="mqtt:topic:pibroker:sonoff2:power" }

Switch OfficeLight "Office Light" <light>  ["Lighting"]  { channel="mqtt:topic:pibroker:sonoff55:power", expire="180m,command=OFF" }

For the channel info just copy it from PaperUI Things channels. You will want to unlink the item channel in paperUI before saving the item file as it will automagically make the link once the file is saved…and you don’t want multipule links on the same item.

Okay, thank you very much. Ill give it a shot.

And is this the correct channel ID?? knx:device:5268a70a:B
This is the one displayed below the channel

For using VSCode here is a good video(link to post with video) to set everything up.

That’s windows so not 100% sure about the location but you can check the readme file to verify.

Is this file set up correctly to be exposed as a dimmer to alexa via the hue emulation?


Its probably user error, but I still cant make it detectable by Alexa. I have put it into binding mode, saved and then tried to detect it. Still didn’t work :frowning:

I do not use hue emulation but the tagging for Alexa and item looks correct.

Add the switch item to your sitemap if you haven’t already and verify it works. That way we know the issue is not in the configuration. Do you have the OH skill added vai the Alexa app? Are you using the OH cloud connector?

I have got it to show up, alexa wont turn it on. Next step is to try and control it via the hue app if it shows up. The KNX Device itself works perfectly fine.

Does Alexa say anything like, Kitchen LED not found or other?

It literally says, “Okay” and sounds like its turning it on. Problem is: It doesn’t… Going to try and fiddle with it a little more and see what happens

That’s a good sign. Try saying “Alexa turn on Kitchen led” or “Alexa turn the kitchen led on” sometimes my echo will what me to ask a different way.

Can you go to the Alexa app and turn the light on?

It doesn’t display as a light but as an “Other” device, so no. It doesn’t show up in the Hue app either, but it is being detected by Alexa. This is super weird: It displays as 100% in openhab when Alexa enables it but doesn’t enable it. If I enable it manually via PaperUI Control, it displays it as on and actually turns on (If that makes sense :wink: ). Thanks for the quick replies and help, appreciate it!

Do you have the OH log open and watching what’s happening as you ask Alexa to turn on the light? Did you unlink the item channel in PaperUI before saving the item file, if not you may have a duplicate link and/or item.

You can delete the item in PaperUI, comment out the item in the file with a # in front then save file. Then rediscover and remove the # in the file to recreate and link it. The other suggestion is rename the item file as this has been known to solve some google issues.

I have removed all links before, give me 2 mins, I’m not sure if I have fucked up some group addresses during testing this and got a big mess.

Okay, so. I dont seem to have fucked the group addressing up but now it says that the “Kitchen Spots is malfunctioning”. This is getting more cunfusing by the second.

Okay, so apparently if I have 2 switches, 1 a dimmer and 1 a switch, they interfere. So If i tell alexa to turn off the dimmer, it wont and vice versa. I have removed it and now it seems to be working apart from Alexa saying “Device Kitchen Spot is malfunctioning” but it working-ish.
I cant say turn it on either, but only specify the value. Thanks for the help!

You may need to create a dimmer item for the brightness in addition to the switch you already have. Click the “plus” icon for channels and see if there is a dimmer channel listed in PaperUI. If so, copy the the channel info and place it in the item file like with the switch.

Example:

Switch BedroomLight "Bedroom Light"    <light> ["Lighting"]  { channel="mqtt:topic:pibroker:zigbee2mqtt:power", expire="120m,command=OFF" }
Dimmer BedroomLight_Level "Bedroom Light Level [%.0f %%]"    <light> ["Lighting"]  { channel="mqtt:topic:pibroker:zigbee2mqtt:dimmer" }