Can't reinstall the dev environment


(Markus Michels) #1

Hi, I had the problem that Eclipse marked any annotation as an error (seems to be an Eclipse bug). So I cleaned the openhab-master folder and want to re-install the environment. I tried it now several times, basic install goes through, but when Eclipse wants to exec the startup tasks the process aborts. I already tried to include more or less of the installation options with the same problem.

Can anyone help?


MagentaTV / EntertainTV Binding for Deutsche Telekom MR 3xx and 4xx
(Stefan M. Haller) #2

I can confirm this issue. Just had the same with a fresh setup

Cheers
Stefan


(Slaviša Lukić) #3

Can Confirm that too.
Tried on my Mac, was not sure doing something wrong, so tried on Ubuntu, same issue.


(Christoph Weitkamp) #4

Sry guys, You will have to wait a little bit until it is working again. Bugfix is on the way:


(Holger Eisold) #5

@cweitkamp @Kai any news on when the fix will be merged and the IDE is working again?
Thanks


(Markus Michels) #6

nope, I’m also not able to run an mvn install


(Kai Kreuzer) #7

PR is merged and I did a new ESH stable build - the openHAB build & IDE should work again!


(Markus Michels) #8

IDE reinstall works now!!

Thx :heart_eyes::+1::+1:


(Slaviša Lukić) #9

I cannot see the git projects option any more?!

I cleaned .p2 .eclipse and openhab master directory
started eclipse installation-> advanced option-> ? no git projects

same for mac and ubuntu.
I am sure I have to do some more clean up, or I did too much cleanup?


(Jerome Luckenbach) #10

I think those option should com efrom eclipse installer.
Maybe you should download the installer again freshly and try it with that version


(Slaviša Lukić) #11

I did a fresh download, at least at the ubuntu installation, which does not ask for updating installer.
The Mac version asks for update and restarts installer after update.
The result is the same, not git projects


(Markus Michels) #12

I did Mac with and w/o updating the installer and it worked. However, I have problems with a mvn build - same project, but now it can’t localte the javax.servlet package.


(Kai Kreuzer) #13

@lukics You seem to be at step 3 of the setup - you need to choose the underlying Eclipse IDE version, the Github projects will only be shown in step 4.


(Slaviša Lukić) #14

Sorry about this. should have read the docu once again an look exactly at the pictures. The two views (3&4) look for beginners similar


(Slaviša Lukić) #15

BTW:
Why are there so many error when initial installing the IDE.
e.g modbus1, modbus1.test, karaf (pom.xml)

Is this normal?
I close this project to proceed, but …


(Jerome Luckenbach) #16

This is described in the eclipse smarthome ide docs.
You have to run clean projects, get rid of those errors.

And since this will important on several other places/development steps:
I would recommend you to open up the eclipse smarthome binding docs paralllel to the openhab binding docs.

Many content from eclipse smarthome is copied to the openhab docs, but from my experience it seems that smarthome docs are a bit more up to date or have some additional information compared to the openhab docs.

I am getting a better progress with reading through both doc sites.
This is my current experience as a binding development rookie.


(Markus Michels) #17

maybe the better approach is to consildate the docs


(Jerome Luckenbach) #18

I am already making notes, while working in my binding.
Maybe this would be an additional usecase for a dynamic docs build, like we already do for the binding docs.

@Kai
This is something we could maybe talk about @ smarthome day if there is some spare time.


(Markus Michels) #19

I could say from personal experience that getring up to speed with OH development is not easy. The open sourxe code of many components is fine, but good tutorials and documentation could make a change.


(Markus Michels) #20

Hi,

I still have problems when trying to use the Eclipse environment (mvn builds are working). After a fresh install, clean and re-build I’m not able to debug the binding:
24

As a result I can’t access PaperUI at 127.0.0.1

Those plugins are all marked to load in the debug config openHAB_Runtime

Any idea?