Cc2531 USB Stick not working - openhab 2.5

  • Platform information:
    • Hardware: raspberrypi 3b+
    • OS: openHABian 2.5.1-2 (Release Build)
    • Java Runtime Environment: openjdk version “1.8.0_222”
    • openHAB version: openHAB 2.5.0 Release Build
    • Zigbee Binding: binding-zigbee - 2.5.1

The Thing File:

Thing zigbee:coordinator_cc2531:stick1 "Zigbee USB Stick" [zigbee_port="/dev/ttyACM0", zigbee_baud=115200, zigbee_panid=35637, zigbee_extendedpanid="118E309DE90CC829", zigbee_networkkey="14 c6 a2 c7 fb e0 c3 19 8e 7c 36 30 dc ad a5 96"]

Status of the Zigbee Thing in openhab is unknown. The green light of the stick is not on.

The log file:

2020-01-19 15:54:20.517 [WARN ] [] - Dongle reset failed. Assuming bootloader is running and sending magic byte 0xef.
2020-01-19 15:54:25.523 [WARN ] [] - Attempt to get out from bootloader failed.

Has anyone any idea how to make the stick working? it did before…

Has the Stick any Firmware on it? Mostly the Sticks comes without any Firmware.

Yes, it was shipped with firmware. As I mentioned, it did work before. I’ll try to get the firmwares name and version to post it here.

When did it work? There has been no change to the CC2531 driver in the binding since before 2.4 was released, so if it now doesn’t work, and it worked for 2.4, then maybe the hardware has a problem?

It did on saturday. Then I saw, that a sensor isn’t working any more (airpressure). After fixing my os for other reasons, installing openhabian instead of raspian, it all fell apart. :frowning:

If there is no change to the firmware or binding which might cause the malfunction, maybe it is the hardware. Linux is recognising the stick in dmesg though… which led me to the conclusion, that the stick might work. But maybe it is recogniseable but not working.

Well, if it worked 2 days ago, and now doesn’t, I guess the first question is if YOU changed anything (eg did you change the firmware or even update the binding)? Nothing has changed for the binding for a while (as I said, the CC2531 driver is basically the same as it was over 1 year ago. I know others are using it, so it should work.

The error message you mention indicates something fundamental is wrong with the communications - either the stick, the serial port, or configuration, but I’m not really sure how to narrow this down further for you unfortunately.

No, I didn’t change the fimrware. I did change the OS of the reaspberry pi as i mentioned. Another major change is the change from OH 2.4 to OH 2.5. Honestly I cant remember wich version of the binding I did use before. I do now use the binding version as mentioned above.

I think as well, the communication is not working. If I plug the stick in, the green indicator lights up, the stick is recognized by the system. After a while the green light stwisches off and there is no communication to the stick anymore.

The relevant users have access to tty an dialout, the obenhab.conf is changed in accordence.

The binding website does mention the firmware needed. What I want to do is to check the firmware installed. If this is the one which is needed, it might be indeed the stick itself. Does anbody know how to check the firmware?

Try this link:

thx. I am still trying to get the firmware version. Meanwhile I found this in the log file:

2020-01-19 15:50:23.846 [WARN ] [core.thing.internal.ThingManagerImpl] - Cannot unregister handler. No handler factory for thing 'zigbee:coordinator_cc2531:stick1' found.

EDIT: I checked the buyingoffer: the firmware is: CC2531ZNP-Prod.hex - 20190619 by Koenkk

That works well with:

It should work fine with the binding.

That’s what I really like about OH, you have choices. :smiley:

1 Like

Which binding would you suggest to use with the “mqtt-service”, still Zigbee???

I have not tried the Zigbee binding but I don’t think you need mqtt to use it?

If you plan to use Zigbee2mqtt then you will need to install the mqtt binding in PaperUI under bindings section (not the embedded one in Misc section). Also recommed to use mosquitto broker and you can install it using openhabian-config tool.

guess I had the same issue but on OpenHABin. I created a thread with a similar question which you can find [SOLVED] - OH (Openhabian) in V2.4.x - Image needed

Have a look, it might help you.