Chamberlain MyQ Binding

Brand new to Pi and openHAB here. Shoutout to @DigitalDan for the work on this OH3 MyQ binding, works great…first time!

Thanks much also to @scooter_seh for the OH2 binding, also worked great…first time…for the short time I used it.

The trouble I had is the stuff of newbies : trying to install the OH2 binding in OH3, having to setup a whole new OH3 model because not backing up my OH2 model, etc. Still, proud of those
mistakes, made me learn fantastic amounts about the hardware and software (chmod (yes yes in case you doubted the newbie tag), putty, filezilla, samba, start/stop services, clear cache, karaf (WTH…!), backup/restore, Win32DiskImager, etc.).

I want to say I love the OH3 UI, SO MUCH BETTER more friendly and intuitive than OH2, was 100% worth the hassle.

Thanks to all contributors for your trials and errors, serves the rest of us! Keep up the good work.

1 Like

I have the same. Usualy, I restart openhab and everything come back.

edit: well, it seems not this time

Stop OH, clean cache then reboot fixes it for me.

I just reinstalled all of my OH from scratch 2 days ago… I hope not having to clear cache each 2 days

edit: just tried, didn’t work

I encounter the same problem as you did. I restarted OpenHAB (on a Pi running Openhabian, sudo systemctl restart openhab2.service). It looks like it is working again.

After a couple of days, it is still working, and continues to work well. It is so much more reliable and responsive than the MyQ app provided by Chamberlain.

I have been trying to get this to work as well. A workaround is to use Shortcuts app on iPhone. Use the Item “Garage Door Switch” and tag as Homekit “Switchable”. It will show up in Home as a switch, which should work as On/Off no problem. Getting Siri to open the garage door will mean, “hey Siri, turn on garage door (switch)”. It works, but obviously not precise enough for OpenHAB geeks like me. Using Shortcuts will fix that. In Shortcuts, select add shortcut (+)—>Add Action—>Apps—>Home—>Control My Home—>Scenes and Accessories. Select your Home Item (Garage Door Switch), then Next. Tap Garage Door Switch so action is Turn On, then Done. Then hit next to name your shortcut, in this case Open Garage, which will result in “hey Siri, open garage”. Of course you will need a shortcut for close garage, which is exactly the same but tapping item at action so it shows turn off. I use this method with Apple CarPlay and it works fine.

may be you missed my hints here: Chamberlain MyQ Binding - #661 by bodo.riepl

I tried your hints. Could not quite resolve what you meant by:

main object garagedooropener

I tried multiple, including Rollershutter. Lots of errors in log around Homekit recognizing Rollershutter. In any event your configuration did not work for me with this binding. Using shortcuts meets the same goal.

with the main object i talk about the garagedoor opener root thing, please check the example in to screenshot below

All the information you need is in the homekit system integration documentation. There are 3 mandatory characteristics for the garagedooropener accessory tag for homekit and it appears all 3 are needed. And none of them is a rollershutter type :). I set their homekit metadata tags as follows from the MyQ item channels:
MyQ garagedoorcontact set homekit metadata to GarageDoorOpener.ObstructionStatus
MyQ garagedoorstatus set homekit metadata GarageDoorOpener.CurrentDoorState
MyQ garagedoorswitch set homekit metadata GarageDoorOpener.TargetDoorState

Now you should get a functioning homekit garagdooropener type along with the graphic in homekit showing opening, closing, and generating homekit notifications if that is what you like. The notifications are visible in carplay on your dash as well if you use it in your vehicle.


1 Like

Did something change with the MyQ binding or API?

All of a sudden I seem to only have three channels for the door.

so without the Contact item, I need to figure out the best way to convert the switch to open/closed, unless somehow I’ve done something wrong with the binding.

since last snapshot update (or the one before) binding stopped working, anyone with the same?

10:06:48.059 [WARN ] [org.apache.felix.fileinstall ] - Error while starting bundle: file:/usr/share/openhab/addons/org.openhab.binding.chamberlainmyq-3.0.0-SNAPSHOT.jar
org.osgi.framework.BundleException: Could not resolve module: org.openhab.binding.chamberlainmyq [208]
Unresolved requirement: Import-Package: org.apache.commons.lang; version="[2.6.0,3.0.0)"

    at org.eclipse.osgi.container.Module.start( ~[org.eclipse.osgi-3.12.100.jar:?]
    at org.eclipse.osgi.internal.framework.EquinoxBundle.start( ~[org.eclipse.osgi-3.12.100.jar:?]
    at org.apache.felix.fileinstall.internal.DirectoryWatcher.startBundle( [bundleFile:3.6.4]
    at org.apache.felix.fileinstall.internal.DirectoryWatcher.startBundles( [bundleFile:3.6.4]
    at org.apache.felix.fileinstall.internal.DirectoryWatcher.doProcess( [bundleFile:3.6.4]
    at org.apache.felix.fileinstall.internal.DirectoryWatcher.process( [bundleFile:3.6.4]
    at [bundleFile:3.6.4]

Hi, there is an official binding called “myq” now included in the latest version of openHAB 3.1.0 Milestone 2, see MyQ - Bindings | openHAB for more information. The apache issue you are seeing is b/c we have removed the apache common language library from the latest version of openHAB as well as the supported bindings.

Thx for info! Quite easy - thats the trick!

I see that listed in the OH documentation, but I do not see it listed when i browse the bindings list to add from, is there a step im missing?

What version of OpenHAB are you running? It is on the latest 3.1.0.m2. If you are on on earlier version you would need to upgrade your OH

Looks like im on the 3.0.1 release build, should i be on another branch to get the MyQ binding working?

Yeah you would need to be on the “Milestone” install. You can see instructions on the download page for getting that version with your install method.

Switched to the main branch, ran upgrade system. Looked like it did…something…but the web UI still says 3.0.1 release. The download page talks more as if I were to do a fresh blank install, is that the only way to change over? Re-flash off a SD?

I’m guessing you are using openhabian image? I’m not 100% familiar with the language there but in APT the milestone releases are referenced via “testing” channels. I’d try switching to ‘test’