Change parity on serial binding

Hi,

are there any options, how to change parity in serial binding? My device works only on 19200baud and even parity. I was trying to set something like this: { serial="COM1@19200,8,1,E } but i doesn`t work. So I had to create a workaround with exec binding to batch script, where I have: @mode com1: baud=19200 PARITY=e DATA=8 STOP=1 >NUL @type scritptorun.out >com1:

Any suggestions? Thanks in advance.

A previous discussion


it doesn’t help, it seems the binding setup is currently hardcoded 8/1/N.

It is a pity that the other options are hardcoded :disappointed:

Receiver and projector works well, only lights, where i was expecting no problems, is the reason why to chose some workaround.

Solved with TCP / serial converter, where I was able to set parity. Then TCP binding and it works like a charm!