Charts are not working as before anymore - broken?

Hi, since i upgraded my openhab installation to the snapshot oh 2.3 #1220, the integrated charts functionality is not working any more like before.

I had a charts.cfg in the services-directory to make the chart bigger for my full hd screen. This worked very good, until i made the upgrade to snapshot #1220. Formerly i was on the build #1210 or something around this.

On my android phone inside habdroid charts are now very ugly, they look like ms-dos style. Before they were white and in high resolution, now they have low resolution, black background and big font.

In basic ui i get a very small chart. in classic ui, the small chart is only zoomed to look bigger, but you can see this, the graphs and fonts are very blurry.

Maybe this is related to this?

Is there a new way to make the settings for the chart? How can i do this?

Is there no expert who can answer this?

Check in Paper UI in the system settings the new chart section. You should find the values from your config file.

There is no charts section.

Now i´m on #1221 and i made some openhab service restarts and even complete server reboot.

But there is no charts-section somehwre in the paper ui settings.

I also removed the service.cfg file. Still no charts section.

Where should this be placed? In PaperUI --> Configuration --> System? There is no such menu inside.

Yes it should be there. Will check again later the exact location.
By the way, what is important is your config file. Can you provide its content?

charts.cfg

org.eclipse.smarthome.ui.chart:provider=default
org.eclipse.smarthome.ui.chart:provider=rrd4j
org.eclipse.smarthome.ui.chart:defaultHeight=800
org.eclipse.smarthome.ui.chart:defaultWidth=1500
org.eclipse.smarthome.ui.chart:scale=0.8

You set the provider twice, this is not normal.
You should not set this setting, as default is the only available chart provider. Or set it only to default.
i can see my chart settings in Paper UI in the third section in configuration / system.

Sorry, i made a mistake.

I only have rrd4j as provider. I removed the # sign before the default-line…

In PaperUI --> System i have:

Add-on management, audio, inbox, item linking…

Last setting is for voice.

But no chart-setting available.

rrdj is not a valid value for chart provider setting.

rrd4j worked for me, i was able to choose between default and rrd4j. The chart was different. But only the design was different, data was the same.

But now charts work only like it did before without any configuration.

I tried many combinations. I removed charts.cfg completely, changed some values, i made a snapshot update to #1244, server reboot.

But nothing changed. There is still no charts-section in my paperUI.

Maybe a developer can say something abot this new functionality?

You mean another developer ? :wink:
I will install last snapshot to check.

Oh sorry. I thought, you were a user, not a developer. Because there is no “developer” under your name here in the forum.

I just installed the snapshot 1224 and I can confirm that the chart settings have disappeared.
They are present with the snapshot 1212. So they disappeared after.
Issue opened:

Sadly, with snapshot #1225 there is still no charts configuration in paper ui.

You will have to wait for a new stable ESH build to be included in OH snapshot.

By the way, I forgot to check if settings from cfg file are ignored as you mentioned.

How often will the esh builds be updated inside openhab?

Not with every snapshot like distro, addons and linuxpkg?

I made a snapshot upgrade to #1231. The new eclipse smarthome release is included.

Now i get the charts-settings inside PaperUI.

But it doesn´t seem to work.

The charts look the same like before. Inside Basic UI and inside habdroid also. No change.

Do i have to keep the charts.cfg file or do i have to remove it? Which settings will be used if i have both positions configured with different values?

Is there some progress? Now i´m on snapshot #1248 and it is still not working.