Charts are not working as before anymore - broken?

I finally found the time to test and it seems you’re right, the chart settings defined in a cfg file are now ignored. I opened an issue:

Settings inside paper UI are also not working for me. I renamed my charts.cfg to .txt but nothing changed. Still only default charts.

1 Like

I have now fixed the issue.
Please be patient, this will require a review and merge, a new ESH build and then finally a new OH snapshoit.
Please read the content of my issue, you will discover that path ofr settings was updated, use now org.eclipse.smarthome.chart rather than org.eclipse.smarthome.ui.chart

Thank you very much. I hope i will see an announcement somewhere in the forum, when there is a new esh build in the snapshots available.

With this fix, can i remove my charts.cfg file and do all settings inside paper ui or can i keep it and openhab will use only my charts.cfg? Or will OH only use the values from the charts.cfg and all other non declared values from the paper ui?

Now -> distro 1253!

Thanks!

Now i´m on #1253 and now i don´t get charts anymore.

Many erros in the log…

2018-04-10 10:37:54.120 [WARN ] [eclipse.jetty.servlet.ServletHandler] - 

javax.servlet.ServletException: Could not get chart provider.

	at org.eclipse.smarthome.ui.internal.chart.ChartServlet.doGet(ChartServlet.java:281) [151:org.eclipse.smarthome.ui:0.10.0.201804091757]

	at javax.servlet.http.HttpServlet.service(HttpServlet.java:687) [32:j

... and so on ...

It makes no difference if i remove my charts.cfg-file and only make paper ui settings or if i change something in the charts.cfg-file.

I can confirm that it’s working with paper ui settings. But first time I couldn’t see any chart (upgrade to 1253)…a reboot did help and everything is fine now :slight_smile:

For me it is not working. Now i made 2 reboots. Still the same warnings like i posted above.

Any idea?

I renamed the charts.cfg to charts.cfg_txt but still not working.

Where can i make settings for default charts provider?

When i want to open only the icon for the broken image inside my browser, i get this:

HTTP ERROR 500
Problem accessing /chart. Reason:

    Server Error
Caused by:
javax.servlet.ServletException: Could not get chart provider.
	at org.eclipse.smarthome.ui.internal.chart.ChartServlet.doGet(ChartServlet.java:281)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:687)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:790)
	at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:848)
	at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:584)
	at org.ops4j.pax.web.service.jetty.internal.HttpServiceServletHandler.doHandle(HttpServiceServletHandler.java:71)
	at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:143)
	at org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:548)
	at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:226)
	at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:1180)
	at org.ops4j.pax.web.service.jetty.internal.HttpServiceContext.doHandle(HttpServiceContext.java:284)
	at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:512)
	at org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:185)
	at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:1112)
	at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:141)
	at org.ops4j.pax.web.service.jetty.internal.JettyServerHandlerCollection.handle(JettyServerHandlerCollection.java:80)
	at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:134)
	at org.eclipse.jetty.server.Server.handle(Server.java:534)
	at org.eclipse.jetty.server.HttpChannel.handle(HttpChannel.java:333)
	at org.eclipse.jetty.server.HttpConnection.onFillable(HttpConnection.java:251)
	at org.eclipse.jetty.io.AbstractConnection$ReadCallback.succeeded(AbstractConnection.java:283)
	at org.eclipse.jetty.io.FillInterest.fillable(FillInterest.java:108)
	at org.eclipse.jetty.io.SelectChannelEndPoint$2.run(SelectChannelEndPoint.java:93)
	at org.eclipse.jetty.util.thread.strategy.ExecuteProduceConsume.executeProduceConsume(ExecuteProduceConsume.java:303)
	at org.eclipse.jetty.util.thread.strategy.ExecuteProduceConsume.produceConsume(ExecuteProduceConsume.java:148)
	at org.eclipse.jetty.util.thread.strategy.ExecuteProduceConsume.run(ExecuteProduceConsume.java:136)
	at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:671)
	at org.eclipse.jetty.util.thread.QueuedThreadPool$2.run(QueuedThreadPool.java:589)
	at java.lang.Thread.run(Thread.java:748)

How do i have to configure the charts.cfg-file?

org.eclipse.smarthome.chart:defaultHeight=800
org.eclipse.smarthome.chart:defaultWidth=1500
org.eclipse.smarthome.chart:scale=0.8

This way or with .ui. inside?
–> org.eclipse.smarthome.ui.chart:defaultHeight=

I don’t have a charts.cfg…did you try to delete this file and change the setting directly in the paper ui to something different? Maybe a change is needed to save something in a config-file…but I’m not sure.

Probably because you defined a chart provider different from default ?
Erase your files chart.config and chart.cfg and restart OH.

If I correctly remember, you insisted to set the provider to rrd4j while only default is a valid value.

I have tested with provider:default too, but with no success.

Where is the chart.config saved? I only know the charts.cfg-file?

EDIT:
I removed the charts.cfg completely, made settings inside paper ui charts section, server reboot, changed settings inside paper ui charts, openhab service restart

Still no success. Same error as before.

EDIT2:
After another server reboot, now it works!

But with habdroid android app the charts are still ugly. No such charts like on the webbrowser, only black background with ms-dos like (text style, no graphic ui) descriptions.

Is there a way to get the charts style back to the style of the webbrowser-charts?

Maybe someone can tell me, if the ugly charts on habdroid is an error (or feature?) of habdroid (openhab android app) or of the openhab-software itself?

On former versions i got the same charts like on the webbrowser. White background and so on.

Now it looks this way:

If I’m not mistaken the “ugly” chart shown is not from HABPanel! IMHO it is the actual way charts are displayed on HABDroid.

Yes, my mistake… i corrected my post.

It´s from habdroid.

But some time ago i got the same charts inside habdroid like on the webbrowser view.

Where has this changed? Inside habdroid? I can´t remember exactly, but i thought it was after an openhab snapshot update some time ago, so it has to be an openhab server side thing? Not a client side (habdroid)?

IMHO, Yes.

Have a look now, habdroid has been updated.

I was on 2.0.48 beta and now on 2.1 stable , but it looks the same for me. Charts in Webbrowser are still different.


Oh, yes the grey colored surrounding is missing in the app. /sarcasm out/

Look here. The numbers are scaled too. In habdroid, they are still very big.

If you have many numbers in one axis, sometimes in habdroid they are too big. Also the legend (description) is much smaller in the webbrowser. Looks like i get different views than you.