Charts show only the same value

  • Platform information:
    • Hardware: Raspberry Pi 3B+
    • OS: openHABian buster
    • Java Runtime Environment: newest
    • openHAB version: 2.5.2

Hello, my charts stopped working after a previous openhab update, but i dont know which.
The picture is there but the value is still the same, so its not creating a curve, only a horizontal line.

My sitemap entry’s look like this:
Text item=Waschmaschine_W label=“Verbrauch [%.1f Watt]” {
Switch item=Watt_Periode label=“Zeitspanne” mappings=[0=“Stunde”, 1=“Tag”, 2=“Woche”]
Chart item=Waschmaschine_W refresh=10000 period=h visibility=[Watt_Periode==0, Watt_Periode==“Uninitialized”]
Chart item=Waschmaschine_W refresh=10000 period=D visibility=[Watt_Periode==1]
Chart item=Waschmaschine_W refresh=10000 period=W visibility=[Watt_Periode==2]

What i already tried:
systemctl stop openhab2
openhab-cli clean-cache
systemctl start openhab2


curl -X GET --header “Accept: application/json” “
gives me 360 current datapoints

Looks like it must work, but it did not.
Please help :slight_smile:

Some question on that:

  • Confirm you do see different values when using the call to the REST API.
  • Does the chart display the current value as a horizontal line?
  • Does a chart displayed via a Habpanel widget show correctly?

I have seen such behaviour after moving from a SSD based system go a SD card based one (new image of openhabian and saved config and .rrd files copied over). Since then after each restart on the raspi I had to clean the cache, restart openHAB and then manually restart all bundles that remained in “resolved” to get a back to a working system.
I have NO idea what is causing this.

One other thing to check, is your default persistence service set to rrd4j?