Commands send but not executed

Hey, i have a strange Problem and don´t know what to do.
I use Openhab 3.3. on a rpi3b+.
The system worked fine for a very long time but then from time to time it happens that devices stop responding to the system.

when i walk into a movement detector i can see in the logs that ist was triggered and the system sends the command to the lamp but nothing happens. the strange part is, that EVERY recieved command is displayed in the logs and EVERY send command doesnt execute.

when i press a zwave button it is shown in the logs.
when i send a command to a zwave device the logs say “command send xyz predicted to become …” but nothing happens.
when i trie to send a command to a hue bulp the logs say “command send xyz predicted to become …” but nothing happens.
when the state of a shelly plug changes it is schown in the logs and coresponding rules are triggered but when i trie to switch the state of this plug the logs say “command send xyz predicted to become …” but nothing happens.

when i restart the system everything works fine for one or more days and than it happens again.

Didi anyone have the same issue?

I’ve never seen nor heard anything like this before. The fact that it happens to more than just one binding shows it’s something likely going wrong in core instead of the bindings.

It seems like the bindings are not receiving the command events for some reason.

Do you see anything of interest in openhab.log?

Put one or more of the add-ons into trace level logging and see if there is any indication that the binding is receiving the commands or not.

I’ve not seen this reported before so there might be external factors at play like a failing SD card, networking issues, etc.

i made a few steps forward. i think this is a realy old problem that just didn´t bother me because i took a bigger harddrive. i decided to make a comletely new system.

the old problem was that the system got unresponsive and the after a while some items and things were deleted.
i thought it had something to do with the rule dsl engine. after i replaced nearly all dsl rules with ecma rules everything worked fine for the moment. at this time i also changed my 16gb sd card for a 120gb ssd. i think the issue had something to do with space, not deleting log files or something like that.
i don´t realy know if the problem is related or not but it doesn´t matter anymore because i decided to start a new installation without using a backup.

i didn´t had the best start and ran into the next issue …

but this is a different story…

For everyone who has the same or a similar problem, i deleted temp files and cache from a few folders and disabled all dsl rules. Now everything is working fine since about 3 days.

After about 4 days the problems started again.
I set up a whole new system with new raspberry, new sdcard, new zwave-stick and i didn`t copy a single file from the old system but my new system got the exact same problem after one day.

the interesting part is, that all commands look good in the log files but outside the system nothing happends.

i press a zwave button to turn on a hue light, the buttonpress is recognized and the log says lamp recieved command on lamp predicted to become on but the light stays off.

same if the target is a zwave device.

telegram text masseges are send properly.

i noticed a warning in my logs

2022-08-28 09:33:07.331 [WARN ] [ence.internal.PersistenceManagerImpl] - Querying persistence service 'rrd4j' takes more than 5000ms.

and i had some problems with the log viewer when i made the new system.

Reading this I’m reminded of a strange issue of rules
somehow not being triggered any more
. (Everything scripted in jython).

I never found the cause but grew suspicious towards a group of rules doing presence detection and an alarm system. There was nothing in there that looked suspicious, just those effects appearing more often after a logOut/alarm/login.

What I did was to install habApp and then migrate/rewrite the functions within that framework. I ended with a much clearer implementation and I haven’t seen that issue again.

If i get it right, the rules were´t triggered in your case. in my case the rules are triggered and the result (for example “turn on light”) is executed but the light won´t turn on.

does a restart of OH heal the situation for you?

yes but just for about one day.

When the system becomes unresponsive, can you still trigger things using the UI? Is it just rules that don’t work?

no, i cant trigger things from the ui.
they are shown in the logs as triggered but they just dont do anything.

I’m just guessing but it seems like maybe the system is just getting swamped. Have you tried the Systeminfo binding to monitor how hard the PI is working? How many bindings, how many things/items, how many rules?

i use mobaxterm for my ssh connection and this shows ram usage, cpu usage and so on. everything looks fine for me.

11 Bindings:

  • astro
  • chromecast
  • harmony hub
  • hue
  • mqtt
  • network
  • shelly
  • telegram
  • xiaomi mi smart home
  • yeelight
  • z-wave

at the moment 97 things, 259 items and 15 rules. All rules are done with blockly.

i will trie the suggested binding next time my system fails.

How many GBs RAM?
Do you have other services running on the same Pi?
Grafana, DB for persistance, mosquitoMQTT, Pihole or any thing other then openHAB. With a brand new test system I’m guessing not but just asking

it has 1gb of ram but only 580mb are in use. it is a fresh installation. normaly i would have mqtt running on it but at the moment it is just openhab.

I have a realy bad wifi at the moment. but i don`t think this has something to do with the problem because nearly all my smart home components are connected with ethernet cables.