ConBee 2 and openHAB 3 in Docker on RP4 keeps Initializing

  • Platform information:
    • Hardware: Raspberry Pi 4
    • OS: Raspberry Pi OS / x64 / 11 (bullseye)
    • Java Runtime Environment: 11.0.15 (Temurin-11.0.15+10) (running in Docker)
    • openHAB version: 3.3.0 (running in Docker)
    • ConBee 2 USB stick

Dear community,

I’m completely new to the field of home automation and making my very first steps. My goal is to control some Philips Hue Smart Plugs via ZigBee.

As you can read in the platform information, I’m running openHAB 3 on my Raspberry Pi 4 via Docker. For this I’ve created a dedicated openHAB user called myopenhabuser on the host that is used for the Docker container.
I can successfully access openHAB’s UI via http://myRaspi:8080.

I’ve bought a ConBee 2 USB stick as ZigBee gateway. When plugging-in the stick, I can successfully see it as /dev/ttyACM0. Then I’ve executed sudo usermod -a -G dialout myopenhabuser and restarted the openHAB Docker container with the following command:

docker run --name openhab \
  --net=host \
  -v /etc/localtime:/etc/localtime:ro \
  -v /etc/timezone:/etc/timezone:ro \
  -v /opt/openhab/conf:/openhab/conf \
  -v /opt/openhab/userdata:/openhab/userdata \
  -v /opt/openhab/addons:/openhab/addons \
  -v /opt/deconz:/opt/deCONZ \
  -d \
  -e USER_ID=999 -e GROUP_ID=994 \
  -e CRYPTO_POLICY=unlimited \
  --restart=always \
  --device=/dev/ttyACM0 \

I can still access http://myRaspi:8080. After installing the deCONZ binding, I’m adding a deCONZ-Gateway with the following settings:

  • IP address: myRaspi
  • HTTP port: 8080
  • API key: the 16 digit Install Code that was printed on the ConBee’s packing.

And now the status is stuck in INITIALIZING:

Any help would be really appreciated :slight_smile: thx a lot in advance!

@Wolfgang_S I saw your input here, maybe you have an idea for me as well?

Is there any specific reason that you do not use openhabian as OS ?
openhabian supports setup for Conbee. So it would not be required to run it in docker environment.

'm hosting several other applications on my Raspi which are running in Docker as well. So the Raspi/Docker setting existed long before getting started with openHAB and a dedicated Raspi just for openHAB would just be a waste of resources in my case.

Is that correct ?

Above you wrote

so the device passed to docker should be this one.

Ah sry, that was just a typo in the question, I edited the text. I’m passing dev/ttyACM0 to the Docker container.

Okay, it was a hell of a ride, but now it’s working :muscle:t2: I had to do the following:

  1. Run the following docker-compose.yaml via docker compose up -d on the Raspi:
version: "3"
    image: deconzcommunity/deconz:latest
    container_name: deconz
    restart: always
      - 9080:9080
      - 9443:9443
      - /opt/deCONZ:/opt/deCONZ
      - /etc/localtime:/etc/localtime:ro
      - /dev/ttyACM0
      - DECONZ_WEB_PORT=9080
      - DECONZ_WS_PORT=9443
      - DECONZ_DEVICE=/dev/ttyACM0
    image: openhab/openhab:latest
    container_name: openhab
    restart: always
    network_mode: host
      - deconz
      - /opt/deconz:/opt/deCONZ
      - /opt/openhab/addons:/openhab/addons
      - /opt/openhab/userdata:/openhab/userdata
      - /opt/openhab/conf:/openhab/conf
      - /etc/timezone:/etc/timezone:ro
      - /etc/localtime:/etc/localtime:ro
      - /dev/ttyACM0
      - CRYPTO_POLICY=unlimited
      - GROUP_ID=<<group ID of the openHAB user>>
      - USER_ID=<<user ID of the openHAB user>>
  1. Navigate to http://myRaspi:9080 and create a new Phoscon gateway with a password.
  2. Still on http://myRaspi:9080, navigate to Einstellungen → Gateway → Erweitert.
  3. Open a new tab for http://myRaspi:8080 (openHAB) and navigate to Settings → Things.
  4. If not already done, install the deCONZ binding and create a new thing of type deCONZ Gateway with the following parameters, BUT DO NOT YET SAVE:
    • IP address: <<IP address of your Raspi>>
    • HTTP port: 9080
    • Websocket port: 9443
  5. Switch to the Phoscon tab (http://myRaspi:9080), click App verbinden (a timer of 60 seconds should start), switch back to the openHAB tab and now click save.

After a couple of seconds, the configuration could be finished and the gateway came online :muscle:t2: when adding new deCONZ things (e. g. a light sensor) with the newly created bridge/gateway within openHAB, they do also appear on http://myRaspi:9080.