ConnectedCar Binding myAudi, Volkswagen, VW ID, Skoda, Enyaq, Seat, Ford, WeCharge

ah, found it thanks

Be carefull, this is the openHAB 2.5 branch, there is also an openHAB 3.3 one, which contains latest code.

Support for OH 2.5 has been dropped, requires at least 3.2
@tknaller has forked my repo and did the last changes
we need to merge those, but I’m still buys with the Shelly binding

It appears that some values were dropped by mid June, probably by the API/vendor. While I earlier had channels for windows’ status (open|closed) and position (%), I now only get statuses. TRACE log doesn’t carry window positions. Same for totalRange (now only PrimaryRange and SecondaryRange), fuelMethod and tempOutside. Missing those is not harming, but worth mentioning here, to see if other values were dropped similarly.
In log I found a value I didn’t see before: status#carMoving, but not exposed in MainUI or accessible via text config.

WVWZZZxxxxxxxxxx: Channel status#carMoving updated with OFF (type class org.openhab.core.library.types.OnOffType)

Since the Fiat 500e was the best selling eCar in 2021 in Germany I would appreciate it if it could be implemented here. At the moment I am using ioBroker solely for this purpose.

HI,

tried to get the connected car binding with my ID3 working on OH 3.3 today, but after installing the binding, redefining the things for the bridge and the car, there are no channels shown for the car thing.

I took this snapshot release:

Opening the channels of the “connectedcar:idvehichle” thing there is only this message: “This thing has no channels. Either the thing type doesn’t define channels, or they may be detected and appear later.

I had no problems in 3.2. and there is nothing in openhab.log

Are there any ideas?

Hello @kuczerek,
I am also using new OH 3.3, still successful with no changes compared to 3.2.
BUT: I had a same issue in a totally different binding, also from a separate .jar in addons folder.
What helped: I misconfigured the Thing intentionally by mistyping the Thing type, here e.g. “idvecle”, see it disappearing from Things list, and re-created by correcting that back to “idvehicle”.

Despite of the missing channels and to exclude the typo in your description “idvehichle”, is the car thing marked green/online? Is there a message under the “Status”? Do you use text file config or through MainUI? Does the Bridge present the car thing in Inbox before you create it?

As I found out, the Github user andig has implemented the Cupra Born into evcc.io and the user TA2k into ioBroker.vw-connect. The code is openly available on Github.

As far as I have read, it is quite comparable to the VW ID.

Unfortunately, I don´t have the capability to code it into the ConnectedCar Binding. Is anybody interested in having a look to it and integrating the Cupra Born? I would of course highly appreciate to support the development by testing.

hi,

after upgrading to OH3.3 i am receiving the following error in the logs.

2022-06-29 13:51:27.000 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'connectedcar:volkswagen:f845fd705e' changed from UNKNOWN to OFFLINE (COMMUNICATION_ERROR): API call failed

2022-06-29 13:51:27.001 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing 'connectedcar:cnvehicle:f845fd705e:WVW12346789087645' changed from UNKNOWN: Initializing to OFFLINE (BRIDGE_OFFLINE)

i am using the latest snapshot from github

281 │ Active │  80 │ 3.2.0.202110251157     │ openHAB Add-ons :: Bundles :: ConnectedCar Binding

can someome help me to get the bridge and things back online?

Hi @philf90,

I suggest you update the binding to the even newer one, as promoted in this thread from time to time:
https://github.com/tknaller/openhab-addons/releases/tag/connectedcar_snapshot_20220225.

1 Like

Hello @markus7017 – I am using latest snapshot 20220225 with Ford and when I enter my credentials I am getting an “API call failed” status. Has there been an update to the FordPass API that hasn’t been updated in the binding? Thanks!

Hi @cwi,

thanks for the advice. In my case I didn’t change the spelling of any thing. I just upgrade the core and left all configurations untouched.

Anyway - I tried again today and everything is fine. Don’t know why it didn’t work some days ago.

Thanks for your support!