CT80 thermostat / ZWave / humidity

I have a CT80 Radio Thermostat, with Zwave, which has been accurately discovered by openHAB and the Zwave binding. I see this in Karaf as a result of a smarthome:items list command:

Thermostat_ThermostatFanMode (Type=NumberItem, State=0, Label=Thermostat Fan Mode, Category=Temperature)
Thermostat_SetpointHeating (Type=NumberItem, State=5E+1 °F, Label=Setpoint (heating), Category=Heating)
Thermostat_SetpointCooling (Type=NumberItem, State=85 °F, Label=Setpoint (cooling), Category=Heating)
Thermostat_ThermostatOperatingState (Type=NumberItem, State=0, Label=Thermostat Operating State, Category=Temperature)
Thermostat_SensorRelativeHumidity (Type=NumberItem, State=NULL, Label=Sensor (relative humidity), Category=Humidity)

My question is, how do I get the humidity to be retrieved? It shows up on the display, but not in openHAB.


Your thermostat state is still NULL, thats the reason it is not showing up. Has the device been queried completely by Z wave? Sometimes it takes time for the device query to be complete.

Also is there any association missing for the Z wave device? Looks like it is not sending humidity values.

The device has been online for a few weeks now. I can change the thermostat state and temperature setpoints, I just can’t get a humidity reading. I have a thing for humidity and that is linked to an item. Why would I need an association? What would I associate humidity to?


Have you linked the channels of your Z wave device(CT80 Thermostat) to your humidity item?

There is only one “thing” ie Z wave device right? It will have channels which you can make use of.
Have you configured the device with item and thing files or with paperUI?
There might be configuration parameters that needs to be set up for the Z wave device. You can use HABMIN to do the configuration.

Yes. There is a channel, zwave:device:586a2f02:node11:sensor_relhumidity1, which is linked to the item Sensor (relative humidity) (Thermostat_SensorRelativeHumidity). That shows up as -NaN in PaperUI. Everything is configured from PaperUI, and I can confirm the configuration in HABmin. There, it shows up as:


So, everything seems to be configured. It’s just that the value is queried.

In the configuration in HABmin, the description for Associate Groups says:

I’m not sure what that means, but it does seem to say that the way to get humidity is to request an Encapsulated Report. I don’t know how to do that!

I am not sure about the encapsulation, but i think some other members might be able to help you with that. Maybe @chris or @5iver they are involved with the Z wave bindings.

I don’t have this device, but it looks to me like parameter 12 might be what you need to set.

I tried setting Multicast (parameter 12) to 1 and there is no change. Except in Habmin, it says pending by that parameter now.

Sorry :roll_eyes:… I looked at the manual and got 12 stuck in my head trying to figure out what multicast does… turn that back off. Parameter 5 enables humidity reporting and it defaults to off, though the manual says the device defaults to 2. In case you don’t have a manual.

I had already set that to 3%. That says pending too! I tried reinitializing the device, but that doesn’t seem to help. Any ideas how to get rid of the pending status? I don’t have the ability to physically interact with the thermostat since it is 1500 miles away!


Is it using the C-Wire or batteries?

It uses the C-wire.

It finally, a few minutes ago, re-initialized. Interestingly, there is no mention of humidity in the XML file that is created in /openHAB/userdata/zwave/network

network_0184da03__node_11.xml (10.3 KB)

Check the Z-Wave Thing for Association Groups with Node1, your controller.
That fixes a lot of update problems, but if it still persists, go to the Humidity Item and select auto update.

There was no association with the controller, so I added that. The debug log shows:

20:34:03.968 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - ZWaveReceiveThread queue empty
20:34:03.972 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - Transaction SendNextMessage 0 out at start. Holdoff false.
20:34:12.347 [DEBUG] [nding.zwave.handler.ZWaveThingHandler] - NODE 11: Configuration update received
20:34:12.358 [DEBUG] [nding.zwave.handler.ZWaveThingHandler] - NODE 11: Configuration update set group_1 to [controller] (ArrayList)
20:34:12.364 [DEBUG] [nding.zwave.handler.ZWaveThingHandler] - NODE 11: Unknown association group 1

That was done through HabMIN. I’ve also enabled autoupdate, through PaperUI.

Also, I just installed the Domoticz home automation software, which has OpenZwave. That also doesn’t show humidity :neutral_face: Seems that the secret is in the encapsulation mentioned in the docs,

I got back into looking at this again. I got a different Zwave module with a later firmware version, but that has made no difference. I still see a thing for the thermostat and a sensor for humidity. However, a humidity value is never shown (it’s always -NaN).

Running Domoticz, I do see humidity, but the sensors are shown differently, as a combined temperature and humidity sensor.

Using the OpenZwave control panel, I also see humidity:

So I don’t know how to proceed in resolving this. It appears to be a bug, but I am not sure what data to collect to help figure it out.

Any ideas?

Did anyone make any further progress on this? I have the same unit with the same issue.

I haven’t seen any updates. I kind of live with it for now. I’m hoping that HomeAssistant picks up some steam and I may switch to that at some point. I can’t change the temperature either on the CT80. The change gets submitted, but it never commits.