Danalock V3-BTZE not working in openHAB 3.1.0.M4

It seems that Danalock V3 stopped working with last Openhab update. Now deleting, resetting and re include does not work. I tired to find out the reason.
As I saw Davalock V3 id’s are in the actual database:

 Checking zwave:polycontrol_umv3btze_00_000: Manufacturer 010E, Type 0009, Id 0002, vMin 0.0.0, vMax 255.255.0

Original XML:


If I add things with textual configuaration in right ID it goes to online but channels are not working as security is false. It needs to recognized true during the pairing process. Is there any way to correct it?
I have all logs as I set up to trace level in the inclusion process if any additional data is necessary.

That is a different device type & ID than is listed in the database entry. We can add that to the same entry if needed.

from OpenSmartHouse Z-Wave Device Database

Thanks, it would be good. As it requires secured connection if it is not in the database I do not know how I can configure it manually.

Other than the device type/id does the manual there look the same as yours? If so we can just add it to the same entry.

Sorry forget to mention. It is exactly the same.

1 Like

Oops I was mistaken.

is the same as

For secure inclusion you need to reset the device before trying again. Secure inclusion is required rto be completed within 10 seconds. Sometimes people find a strong signal is needed for that.

I think I know the problem. Danalock has Zwave lock including bluetooth and Danalock has universal Zwave modul. This one is the universal modul and I do not know why my original lock does not recognized. This is a newer product.

I know and I made reset and put the stick within 1 meter. But it was not recognized. If I use UI adding this is the result:

Any ideas @chris ?

One thing, it was working till I have not updated to this OH version. After that channels were dissaperared. Then I tried to reset and rebind but this is the result.

When you updated, was all the configuration retained? You didn’t loose the security key did you?

What channels have gone? All of them or what?

The database still has channels included - if you see no channels then there has been another issue somewhere else. Maybe you need to now reset the device an add it back if the key has changed.

Symphtom was that thing was online but channels dissapeared after the update. Sounds strange I know. I use textual configuration for both items and things. Complete Openhab backup is saved before the update, so I have all old configuration files with all system data. But as I reset the lock I need to reconfigure. I thought that the reset and reconfiguration would solve as you suggest. So I did it but this version of Openhab does not recognize and connect the device secured. Sorry all channels gone.

I would suggest to use the latest snapshot to see if that helps.

1 Like

Ok. I try tomorrow. I have changed from snapshot to milestone this time. Now I go back.

I updated to: openHAB 3.1.0 Build #2366
I have deleted previous data from inbox, from user/zwave xml
Deleted data direct from controller with Z-Wave PC Controller 5.
I have tried 3 times. All the time device recogntion was ok.
But security is false.
I have saved the logs about the last inclusion. Files are attached.
There is one suspicious line in the log what might help:

2021-05-08 07:48:57.387 [INFO ] [alization.ZWaveNodeInitStageAdvancer] - NODE 134: SECURITY_INC State=FAILED, Reason=GET_SCHEME

node134inclusion.log (391.1 KB)
network_d8a23a12__node_134.xml (3.9 KB)

If I add doorlock switch channel and try to lock or unlock It has the following error message:

2021-05-08 08:17:29.078 [TRACE] [nal.protocol.ZWaveTransactionManager] - Transaction SendNextMessage nothing
2021-05-08 08:17:29.637 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 134: Command received zwave:device:controller:node134:lock_door --> OFF [OnOffType]
2021-05-08 08:17:29.637 [WARN ] [nal.converter.ZWaveDoorLockConverter] - NODE 134: Command class COMMAND_CLASS_DOOR_LOCK not found
2021-05-08 08:17:29.637 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 134: No messages returned from converter

May be door_lock command class is missing due to non secure recognition.

I added Zwave controller through the UI instead of textual config in order to try to fix inclusion mode and security inclusion mode:

Will see the result.

That has been the recommended way for years. I have never defined Things using text files. Just Items, sitemaps, & Rules.

Yes, that is true. But moving from OH2 to OH3 with 100+ zwave devices was easier to change textual config and migrate this way then reconnect all from the beginning.

The network is stored on the controller and the network key moves with an upgrade. No need to reinclude.

Ultimately, this is the problem. If the device isn’t using security, or the secure inclusion / key exchange failed (which is the case), then the binding can’t communicate with the device. It must be securely included to work.

If secure inclusion fails, then you need to reset the device and reinclude it. It MUST be included using the binding - ie with the stick plugged into the PC.