Danfoss LC-13 E5 error

Good morning at all over openHAB community.

I have Danfoss LC-13 Living Connect Z Thermostat, other Z-Wave device and Openhab running at the Raspberry.

Here is my setup:

Raspberry Pi 3 model B Rev 1.2 with Raspbian
openHAB 2.2.0-1 release Build

Z-Wave ZME UZB1 Me serial controller
Danfoss LC-13 Z thermostat:
LC-13 [DF-014G0013.EU]
Type: living connect Z;
Rel. SW 1.01; SDK 4.55
Product date: 17 oct 17
Purched: Amazon jannuary 2018
Installed: february 2018

LC-13 Z thermostat was included correctly to Openhab.

During the first hour it works correctly, changes and displays the correct setpoint temperature. Following an extract of the log file:

2018-03-30 21:17:38.720 [ome.event.ItemCommandEvent] - Item ‘Setpoint_calorifero1_Sala’ received command 22
2018-03-30 21:17:38.727 [vent.ItemStateChangedEvent] - Setpoint_calorifero1_Sala changed from 21.75 to 22
2018-03-30 21:17:55.927 [me.event.ThingUpdatedEvent] - Thing ‘zwave:device:161afdc0990:node5’ has been updated.

But exactly after one hour it displays E5 and a flashing bell permanently and I can’t control the thermostat anymore.
To make the thermometer still properly working again I have to remove one battery for a few second and then put it back in, or change the wakeup interval through the HABmin panel. After an hour the thermostat display E5 again.

Anybody know what to do?

Thanks in advance!

I have a few of these myself and had similar problems. For me it was a combination of adding in a Z-wave repeater and removing them from my Z-wave network and adding them back in again.

In my setup my controller is in the garage and about 10 feet away from the house, so assumed that my problem was down to network performance. Hence the repeater.

Thanks for the answer Maximo,
in my case, however, i don’t believe is a problem of network becouse the thremostat after a power back or a new wakeup time interval, is working correctly again for an hour. What happen after one hour?

Hi LP,

I had the same sort of issues that you originally described. They would work for a short period of time and then the E5 error would display. resetting a battery would bring them back online for a time. All my other Z-wave devices worked fine, both mains and battery devices. It was only once I had bought the repeater and removed and re-added the LC-13’s back into my Z-wave network did they start to behave as they should.

Hi Maximo,

do you have the same type of thermostat that I have ?
Did you try to put the thermostats near the controller before to buy the repeater?
Which model of repeater did you buy, and which is the maximum distance amang the repeater and the thermostats?


Yes I have 9 of the LC-13’s. I run OH on a virtual machine from a server located in my Garage, so it wasn’t possible to trying working a LC-13 near the controller.

I’ve bought the Aeon Labs ZW 117. I would trying removing your LC-13 from your z-wave network first and then re-adding using the z-wave controller rather than adding via OH before you go and buy the repeater. Also well worth putting your z-wave logging into TRACE if you haven’t already done so. I’m sure the likes of @chris will be able to offer some advice in terms of the log contents once you have some.

Ok Garry, I will follow your suggestion, but which is the route to add the LC-13 using the z-wave controller rather than adding it via OH? Sorry but I am a beginner in OH.
Thanks a lot.

That all depends on your controller, if it’s a Z-Stick then it’s a case of unplugging it and taking to the LC-13 and pressing the button on the controller. Then put the LC-13 into include mode. Once it’s all done, plug it back into your RPi and restart it.

Hello everyone, I finally updated OpenHAB to version
The thermostat Danfoss still doesn’t work (it continues to show E5 error), so I activated the DEBUG mode of the LOG Viever.
I tried to understand why the thermostat does’not work using the ZWave Log Viewer on Chris Jackson’s site (https://www.cd-jackson.com/index.php/openhab/zwave-log-viewer).
I believe, in the end, that the problem is that there is no comunication between the thermostat and the controller due to the fact that the device does not support associations.
This could be in agreement with what is reported in the device list on Chris Jackson’s site (https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/165): “Device definition contains errors - Device has association groups defined, but does not support the ASSOCIATION command class - These errors must be removed before the device can be approved”.
At this point, I kindly ask Chris if this is a realistic hypothesis and, if possible, to explain the meaning of the above statement present in the Living Connect Z Thermostat list.
But what amazes me is that there are several users who use the Danfoss thermostat that report that the thermostat is working properly!
So is it a problem of firmware versions?
To try to solve the mystery I ask those who are using the Danfoss thermostat to tell me what they think of this and if they can kindly tell me what version of the thermostat they are using.
The version of the thermostat I’m using is the one shown at the beginning which I report below for convenience:
Danfoss LC-13 Z thermostat:
LC-13 [DF-014G0013.EU]
Type: living connect Z;
Rel. SW 1.01; SDK 4.55
Product date: 17 oct 17

Thanks to all those who can help me.

An upgrade:
I have collected a debag log file of my system of some hours after turned OFF and ON the Raspberry.
I have analysed the log file with the ZWave Log Viewer on Chris Jackson’s site. In relation to node 2 (LC-13) I noticed that:

  • the node is present;
  • every wake-up time (5 minutes) sends “State update”;
  • automatic “State update” are sent for an hour after the last manual wake up;
  • after an hour the “State updates” are sent every half hour instead of every five minutes (wake up time) and from this moment the thermostat shows error E5.

I’m desperate, can anyone give me a hand? Please Chris to help me solve the problem, thank you so much.

Hi Lupe,
I think Maximo gave you already some hints how to include properly.
E5 means that device lost connection to the network.

I included the LC-13 directly at the controller, mounted it on the heater and started a manual healing immediately.
Even the LC-13 was just a few meters (and a wall) away from controller it found its way via two other devices to the controller.
Since then I am doing so with every battery driven device.
Maybe it helps …

I would suggest to update to 2.5 for starters.

The problem with this is that I personally do no know what exactly E5 means - I know it means that the device thinks it is not in contact with the controller, but it’s unclear what that really means “under the hood”. ie - exactly what the device is looking for is unknown and without this, it’s hard to know how to fix it as it seems to be a non-standard implementation on the part of Danfoss.

first of all thanks to both of them for answering me, so I don’t feel abandoned to myself.

I believe I have included the thermostat properly. The thermostat is located about 2 meters from the controller, from node 3 (Fibaro Motion Sensor FGMS-001) and from node 4 (Relay Switch Fibaro FGS-212).
What I’ve noticed is that messages destined for the LC-13 node are queued and the queue is never emptied. The queue increases at each wake up time; to empty it, it is necessary to give a manual wake up.
Any ideas?

Chris4789, what kind of controller and what version of LC-13 do you have in your system?

The queue will only empty when the device wakes up. When this happens, it should send a special message - if it’s not doing this, then the wakeup period if not configured.

I have a RaZberry2 sitting on a Pi 3B.
I will post my LC-13 version when I’m at home at evening.

I did not find how to get detailed infos from my device as you have listed above.
Got just firmware version 1.1 from habmin.

In the thermostat battery compartment.

… if it’s not doing this, then the wakeup period if not configured.

Hi Chris,
the wake up time is defined (in Habmin) and equal to 5 minutes.

I attach the debug log file and below some comments.
At 18:29 - start Raspberry
at 18:43:41 - manual wake up
at 18:45:30 - manual wake up
from 18:47:38 to 19:16:40 “STATE UPDATE” about every 5 minutes
at 19:18:00 - I changed wake up time with Habmin from 5 to 4 minutes
at 19:19:00 - manual wake up
at 19:20:00 - manual wake up
from 19:25:23 to 20:27:21 “STATE UPDATE” about every 4 minutes and then every 30 minutes!

Thanks in advance.

openhab_030919_A_rid.log (1001.5 KB)

Sorry for my late reply, I have now deactivated my lc-13 and removed batteries.
In the battery compartment I had the same details you posted, except production date which is one day later, 18.10.17.

Thank you very much Christian !
I still have one last thing to ask you, the version of OpenHab and that of Zwave Binding,
Thanks again.