Dash button rule doesn't run

I have a Raspberry PI 3 with OH 2.3 full running.
My .rules file has a dozen of rules, all runnig w/out problems.
I bought and configured an Amazon Dash Button. I can see the button thing “Online” and when is pressed I can see in the log this entry:

2018-10-26 21:31:36.912 [vent.ChannelTriggeredEvent] - amazondashbutton:dashbutton:38-f7-3d-xx-yy-zz:press triggered

I added this simple rule:

rule “dash_button_1_rule”
Channel “amazondashbutton:dashbutton:38-f7-3d-xx-yy-zz:press” triggered

but when the dash button is triggered the switch_item_01 doesn’t change his state to ON.
I tried to change the command with:

logInfo(“amazondashbutton”, “Dash Button has been pressed”)

but nothing change, I can’t see the log entry
What I’m wrong, why my rule doesn’t work?
Thank you

If the button is a thing try using that in your rule e.g.

Which editor do you use?

Your " " look incorrect?!?
What does the log say if you save your rule?

rule "dash_button_1_rule"
Channel "amazondashbutton:dashbutton:38-f7-3d-xx-yy-zz:press" triggered

Should be correct now

1 Like

@Boogieman good catch, I just copied the rule over to VSCode and the " " were indeed wrong.

founded the solution here:

After update seems something goes not ok.
clear chache solved
Thank you