Dashboard problem (LAN access) openhab 2.3.0 on CentOS

Hello community. NB to openhab. Just finished installing Openhab 2.3.0 on CentOS 7 machine. Everything went fine. Service is running and I can access the dashboard locally (from the same machine on which openhab is installed). I am not able to access the dashboard from any other computer browser on the same LAN. Do I need to do something that is not in the install document ?

Nothing unusual in logfiles

Failing In any browser (other than running on server) http://:8080
works on the server http://localhost:8080

Let me know if any other details needed

What url do you use from a remote host?

http:// :8080 in my case it is

sorry for some reason its blanking out openhab machine IP within tags please read it as openhab server IP:8080
now I know why you asked ;-(

Do you have multiple up addresses for openha b server? If so have you tried both?

I had a pi that would not show the dashboard on wired only wireless. As I was planning on using wireless, I never looked into the issue.

not sure if its related but accessing dashboard locally (i.e. http://localhost:8080) using paperUI I tried to install bindings and getting a spinning cursor (no install) checking log file found
[ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing ‘openhab-binding-wifiled, openhab-binding-network, openhab-binding-mqtt1’: Error:
Resource mvn:org.openhab.binding/org.openhab.binding.wifiled/2.3.0 does not contain a manifest

Any idea what’s going on ? Is it related to not able to open dashboard from any other computer browser ?

nope just one IP only

1 Like

Just to test more. I connected the openhab server running on CentOS to a different wifi router and try to access the dashboard on new LAN but still no success.

New IP address of CentOS 7/OpenHab server
Tried to access the dashboard from a computer (IP using chrome/firefox/IE by typing in the address bar no success.
btw I am able to ping each machine from one another successfully

So it doesn’t seem like network issue

Agreed! Seems like some reason either openha b not available on that netowrk. Meaning a possible bad in stall or firewall problem?

there was an issue with wifiled
Try: Clear the Cache

on the localhost, PaperUI comes up ok?

do you use firewalld?

Clearing cache helped to get rid of the error but still no success installing wifiled. I saw another post where it is mentioned the wifiled is corrupted. Is it fixed now ? Doesn’t seem like.

Yes dashboard works fine on localhost no issues. I have cleaned up and did a re-install on Danny’s suggestion but still no success. Is it known issue with CentOS ?

No I don’t have a firewall on internal LAN. I can ping, terminal, tty…. on to CentOS server from any other computer on LAN. Also verified that port 8080 on server is open for listening. Any other suggestions before I give-up on OpenHAb/CentOS install ? Is any other Linux distribution like ubuntu or Debian or fedora more compatible with OpenHab ?

Thanks for your help.

Yes, it is. If you clear the cache, OH2 will download a fresh copy of the binding.
What do you mean by no success installing wifiled? what is the problem?

I don’t think so… (but I haven’t checked github to be sure :stuck_out_tongue:)

If 8080 works on localhost, it should work from a remote host also…

@ykgoel I have successfully installed openhab on Ubuntu. It was not as easy as I remembered, but I did get it to work. The main fight was java versions. I would have to see if I still have that vm. I only installed for an experiment I didn’t want to do on my pi.

In fact have you checked your java version? I know I had strange things happen on Ubuntu until I got the java squared away.

Last suggestion, unless there is some strong reason not to, I highly suggest using a pi and openhabian! The process is worth the $35 investment in the hardware to save the time.

wifiled binding: I cleared cache and tmp folders. I am still getting spinning cursor and error in Log file Failed installing 'openhab-binding-wifiled, ': Error: Resource mvn:org.openhab.binding/org.openhab.binding.wifiled/2.3.0 does not contain a manifest

No progress on port 8080 from remote. Will try few things tomorrow otherwise will abandon CentOS install

It is not question of using pi and openhabian as I have done that successfully for smaller automations. The full CentOS installation is for another automation project where a CentOS server already is in place running some other processes. It is a powerful machine and make sense to utilize it for OpenHab and MQTT (if works)

Java I have already downgraded to Zulu on the CentOS server. I don’t see any entries in log files related to Java so think we are good. Moreover openhab2 service is up and running on server without any issues.

@Dim Do I need to point to Test or Snapshot repository to get wifiled fix. Currently I am pointing to Stable ?

that’s fine
the issue with the wifiled binding was fixed on the stable 2.3.0 repo

So that you can take corrective action. Giving you following details to fix the issue in stable.

Pointing to Stable and Test repositories didn’t work. Only Snapshot worked.
The following steps I followed one by one for each

  1. Stopped Openhab service
  2. Cleared /var/lib/openhab2/cache and /var/lib/openhab2/tmp folders
  3. Edit /etc/yum.repos.d/openhab.repo to enable Stable,Test and Snapshot one by one
  4. Downloaded the addons one by one using yum install openhab2-addons
  5. Started the openhab service
  6. Using Dashboard http://localhost:8080 addons menu install the wifiled binding (Spining cursor and error in log file when pointing to stable and test respositories. Worked for snapshot)

I still need to figure out why the dashboard is not working from other computers on same LAN. Will tryout few things over the weekend and post back

thanks for your help.

1 Like

No success. Tried completely disabling the firewalld on CentOS server but no success enabling dashboard from remote computers.
It is more of a hassle than problem because Openhab 2 service is running fine and I am able to do everything by remote connecting to the server. Its only that I can not access dashboard using browsers running on remote computers on the same LAN

Did you ever resolve this? I suspect it’s something to do with Java. I upgraded my Java version to get round the issue of connecting to Marketplace and now Localhost and myopenhab.org work but not LAN access and I can’t work out why. Mind’s a Windows install.