Development of openHAB 3.0.0 and 2.5.x

No, file a GitHub issue in core and make it as specific as possible (one for each request). If someone else has to design the specifics it’s very unlikely it will ever be picked up, simple because a lack off time, unless a developer has the same request. So for your suggestions also propose how that would look like in actual configuration. This would greatly increase the change that it will be implemented or at least have a better discussion.

I have no indication anybody involved in core development is even considering to remove text file configuration.

1 Like

If you upgraded to 2.5.1 snapshot there was a packaging bug that caused the same symposium. I understand that too has been fixed.

End of support for 1.x bindings. Of this I was afraid when I read about 3.x

The reason why I started using Openhab was because of the Nikobus 1.x binding. If this doesn’t work anymore in 3.x then I will never use it and stay on 2.x. Pitty.
And as this binding is a very niche one, I am afraid nobody will migrate it to 2.x 3.x . Doubt I am knowledge enough to do it myself. Will take a look though.

@tom_il Actually, the Nikobus binding has already been migrated to OH 2.5. So, not so niche after all.

3 Likes

I do not use this binding, but isn’t there already a 2.x binding?

Wow, Perfect. I looked around and in 2.2 which I am running its not there. Do I need 2.5 then ?

Oh, wow! That IS old. If you have restdocs installed, uninstall it and reinstall after upgrading. That will make life a little easier.

Yes, you will need 2.5.

Thx very much Guys Up till recently I was still running 2.1. No reason for me to update as it worked perfectly. After updating the repository I could update to 2.5. Now running the latest Nikobus binding. :slight_smile: :slight_smile: :slight_smile:

1 Like

If you were running a version that old, you should check to see how many of your other bindings now have a 2.x version. There has been a lot of development that has occurred in the past 2 1/2 years.

4 Likes

True, I had just one binding running until very recently, and then could add a nice second 2.x one.

I have no indication anybody involved in core development is even considering to remove text file configuration.

That is great news. I was asking because some of the discussions for the new UI gave that impression.

That will not happen as I need serial to run over 30 DIY devices running a custom protocol on serial. See the thread below. BTW I don’t believe other home automation packages have serial port support, Openhab is the only one as it has been around the longest.

This post was flagged by the community and is temporarily hidden.

Is the 2.5.1 stable version out for updating with openhabian.config right now?
If I do a “sudo apt-get upgrade -s” on a openhabian installation the 2.5.1 version isn’t found…

sudo apt-get upgrade -s
Paketlisten werden gelesen… Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen… Fertig
Paketaktualisierung (Upgrade) wird berechnet… Fertig
Das folgende Paket wurde automatisch installiert und wird nicht mehr benötigt:
triggerhappy
Verwenden Sie »sudo apt autoremove«, um es zu entfernen.
Die folgenden Pakete sind zurückgehalten worden:
nodejs
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 1 nicht aktualisiert.

No the release has not been announced They hope to do that in January last I heard.

It should be released now, see:

1 Like

Sorry, I was traveling all day and am on a business trip this week. I missed the announcement.

Hi, tried to update to version 2.5.1 with openhabian-config tool.
Unfourtnately the version isn’t found by openhabian-config.
If I use function “03 | openHAB Stable Install or upgrade to the latest stable release of openHAB 2”
only Version 2.5.0 is found.

How can I update to 2.5.1 with openhabian-config?

Thanks a lot

Via OpenHabian I also am not able to upgrade, it always says I’m on the latest version, no upgrade is required.