Dimmer State with KNX-Binding

Hi everybody,

I am working with a KNX-binding, visualized on Basic UI and iOS. Everything works fine so far, but I am not able to get dimmer state working.

My item looks like this:
Dimmer H2_Licht_Eltern_Decke "Eltern Decke [%d %%]" (H2_Eltern) { knx="0/1/210+<0/1/212, 0/1/211, 0/1/213+<0/1/214" }

Thus the label-text will appear as “Eltern Decke” and I don’t get the current dimming state visualized, although I can see it as a number in the log files as well as in myopenhab.

Any idea what could be wrong?

Just installed Classic UI and it works! But still no effect in Basic UI and on iOS App. Is this a bug or is it correct?

Try the following:
use the label=“Eltern Decke [%d %%]” also in your sitemap file
Use a Switch in the sitemap instead of the Dimmer (The item definition remains a Dimmer)

not sure if this will help
Your item config looks good. The KNX syntax is correct for the listeningGAs…

Hi Dim,

thank you for your reply. Unfortunately neither double usage of the label nor using a switch instead of the slider helps.

maybe it is related to an issue…
try to check: https://github.com/eclipse/smarthome/issues (mainly) and/or https://github.com/openhab/openhab-distro/issues
I am not sure what could be wrong

But are you sure the percentage value should show up in Basic UI and/or iOS App?

Hmmm… not sure
I tested on my BasicUI and I have the same issue:

Dimmer	WDim01_Dim		"Staircase LED Dim [%d %%]"	<slider>	(gZWave,GF_P02_Corridor)  {channel="zwave:device:ZW090C:node4:switch_dimmer"}
Frame {
                Text item=WDim01_Dim
                Slider item=WDim01_Dim label="Staircase LED Dim [%d %%]" 
                Switch item=WDim01_Dim label="Staircase LED Dim [%d %%]"

Here is a related topic (without an answer :frowning:) : BasicUI and Slider item => no values visable

This may be by design in the BasicUI… (or a bug?)

Edit: I tried also Setpoint item=WDim01_Dim and it shows the percentage

1 Like

Thanks a lot. I answered to the related topic and at least I’m now sure it’s not a problem with my configuration and thus I can get on with my work.

Strange things happen… :wink:

1 Like