Docker: Installing IpCamera Binding: Missing Dependency

I’ve started tinkering with Openhab on the RancherOS/Docker system and tried to install the IpCamera binding (IpCamera, @matt1). It throws an error:

2020-01-02 19:08:30.056 [WARN ] [org.apache.felix.fileinstall        ] - Error while starting bundle: file:/openhab/addons/org.openhab.binding.ipcamera-2.5.0-SNAPSHOT.jar
org.osgi.framework.BundleException: Could not resolve module: org.openhab.binding.ipcamera [235]
  Unresolved requirement: Require-Capability: osgi.extender; filter:="(&(osgi.extender=osgi.component)(version>=1.4.0)(!(version>=2.0.0)))"

	at org.eclipse.osgi.container.Module.start( [?:?]
	at org.eclipse.osgi.internal.framework.EquinoxBundle.start( [?:?]
	at org.apache.felix.fileinstall.internal.DirectoryWatcher.startBundle( [9:org.apache.felix.fileinstall:3.6.4]
	at org.apache.felix.fileinstall.internal.DirectoryWatcher.startBundles( [9:org.apache.felix.fileinstall:3.6.4]
	at org.apache.felix.fileinstall.internal.DirectoryWatcher.doProcess( [9:org.apache.felix.fileinstall:3.6.4]
	at org.apache.felix.fileinstall.internal.DirectoryWatcher.process( [9:org.apache.felix.fileinstall:3.6.4]
	at [9:org.apache.felix.fileinstall:3.6.4]

What I can’t tell is if this is an issue with something missing in the docker base image, Openhab image or something in the IpCamera binding. I think think it is a dependency that has to be added within Openhab, but I don’t recall adding it when originally setting up IpCamera binding.

Any thoughts?

Update & Solved…

The now current rancher template uses Openhab 2.3.0. The IpCamera (my guess) is based on something newer. I’m running Openhab 2.5.0 with IpCamera without issue.

If you copy the docker-compose file from rancher and modify it to pull image vers 2.5.0 the binding works perfectly.