[eBUS 2.0] New binding - Release Candidate 7b

[ERROR] [nding.ebus.handler.EBusBridgeHandler] - error! after updating to openHAB 2.5 RC1:

==> /var/log/openhab2/openhab.log <==
2019-12-10 10:53:09.655 [ERROR] [nding.ebus.handler.EBusBridgeHandler] - error!
java.lang.NullPointerException: null
at org.openhab.binding.ebus.handler.EBusBridgeHandler$1.run(EBusBridgeHandler.java:203) [bundleFile:?]
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:1.8.0_112]
at java.util.concurrent.FutureTask.runAndReset(FutureTask.java:308) [?:1.8.0_112]
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$301(ScheduledThreadPoolExecutor.java:180) [?:1.8.0_112]
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:294) [?:1.8.0_112]
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) [?:1.8.0_112]
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) [?:1.8.0_112]
at java.lang.Thread.run(Thread.java:745) [?:1.8.0_112]

Did not have this kind of error before RC1, had MS3, MS4, MS5 and MS6 installed


Hallo All,
I’m currently not working on ooenhab to spend my time for other things. But I hope I find time to update the binding after the 2.5 release. The main problem with a high unresolved telegram count is the lack of configuration files for many Vaillant devices.

1 Like

how can we help you?

If you need logs or anything, let me know.

Currently I try to setup the new build setup. I’ve some issues with the dependencies.

will it include new configuration files for many Vaillant devices?

After i try to add “vaillant_template.json” i got this error.

10:27:14.381 [WARN ] [.ebus.cfg.std.EBusConfigurationReader] - Property ‘name’ is not allowed for type ‘template-block’, ignore property !

how can i solve it?

Hi @Trainer,
the error is comming from the following entrys, try to change “template-block” to “template” or change the name: “slot1” to “slot01”:

“name”: “slot1-3”,
“template”: [
“name”: “timer”,
“template”: [

Thank you for your answer.

i tried it, but without luck

here is my change text:

“name”: “slot1-3”,
“template”: [

and if i change template-block to template, i got this error:

11:18:38.292 [ERROR] [sdev.ebus.command.EBusCommandRegistry] - error!
de.csdev.ebus.cfg.EBusConfigurationReaderException: Unable to find a template for id vaillant.slot1!

@John_Doe Do you know how to solve the problem?

try to remove the name property:

“name”: “slot1-3”,
“name”: “timer”,

@John_Doe thank you.
this fix the problem.

after i add Vaillant VRT 392 json file it got this error:

16:53:14.578 [WARN ] [nding.ebus.thing.EBusTypeProviderImpl] - eBUS command clearerrorhistory only contains a setter channel!

do you also know how to use the configurationBundle?
there i got this error message:

16:51:00.337 [ERROR] [org.apache.felix.configadmin ] - [org.openhab.binding.ebus.thing.EBusTypeProvider, org.eclipse.smarthome.core.thing.binding.ThingTypeProvider, org.eclipse.smarthome.core.thing.type.ChannelTypeProvider, org.eclipse.smarthome.core.thing.type.ChannelGroupTypeProvider, org.osgi.service.cm.ManagedService, id=121, bundle=204/mvn:org.openhab.binding/org.openhab.binding.ebus/2.4.0-SNAPSHOT]: Unexpected problem updating configuration org.openhab.ebus
java.lang.NullPointerException: null
at de.csdev.ebus.cfg.std.EBusConfigurationReader.parseValueConfiguration(EBusConfigurationReader.java:306) ~[?:?]
at de.csdev.ebus.cfg.std.EBusConfigurationReader.parseTelegramConfiguration(EBusConfigurationReader.java:273) ~[?:?]
at de.csdev.ebus.cfg.std.EBusConfigurationReader.loadConfigurationCollection(EBusConfigurationReader.java:139) ~[?:?]
at de.csdev.ebus.cfg.std.EBusConfigurationReader.loadConfigurationCollection(EBusConfigurationReader.java:114) ~[?:?]
at de.csdev.ebus.cfg.std.EBusConfigurationReader.loadConfigurationCollectionBundle(EBusConfigurationReader.java:512) ~[?:?]
at de.csdev.ebus.command.EBusCommandRegistry.loadCommandCollectionBundle(EBusCommandRegistry.java:112) ~[?:?]
at org.openhab.binding.ebus.thing.EBusTypeProviderImpl.loadConfigurationBundleByUrl(EBusTypeProviderImpl.java:301) ~[?:?]
at org.openhab.binding.ebus.thing.EBusTypeProviderImpl.updateConfiguration(EBusTypeProviderImpl.java:484) ~[?:?]
at org.openhab.binding.ebus.thing.EBusTypeProviderImpl.updated(EBusTypeProviderImpl.java:501) ~[?:?]
at org.apache.felix.cm.impl.helper.ManagedServiceTracker$1.run(ManagedServiceTracker.java:177) ~[9:org.apache.felix.configadmin:1.9.4]
at java.security.AccessController.doPrivileged(Native Method) ~[?:?]
at org.apache.felix.cm.impl.helper.ManagedServiceTracker.updated(ManagedServiceTracker.java:173) ~[9:org.apache.felix.configadmin:1.9.4]
at org.apache.felix.cm.impl.helper.ManagedServiceTracker.updateService(ManagedServiceTracker.java:152) [9:org.apache.felix.configadmin:1.9.4]
at org.apache.felix.cm.impl.helper.ManagedServiceTracker.provideConfiguration(ManagedServiceTracker.java:85) [9:org.apache.felix.configadmin:1.9.4]
at org.apache.felix.cm.impl.ConfigurationManager$UpdateConfiguration.run(ConfigurationManager.java:1389) [9:org.apache.felix.configadmin:1.9.4]
at org.apache.felix.cm.impl.UpdateThread$1.run(UpdateThread.java:126) [9:org.apache.felix.configadmin:1.9.4]
at org.apache.felix.cm.impl.UpdateThread$1.run(UpdateThread.java:123) [9:org.apache.felix.configadmin:1.9.4]
at java.security.AccessController.doPrivileged(Native Method) ~[?:?]
at org.apache.felix.cm.impl.UpdateThread.run0(UpdateThread.java:122) [9:org.apache.felix.configadmin:1.9.4]
at org.apache.felix.cm.impl.UpdateThread.run(UpdateThread.java:105) [9:org.apache.felix.configadmin:1.9.4]
at java.lang.Thread.run(Thread.java:748) [?:?]

The configurationBundleUrl parameter is for an index file like https://github.com/csowada/ebus-configuration/blob/master/src/main/resources/index-configuration.json to load a complete set of files.

I would suggest to fork the my configuration repository, work together on a solution and maybe send me a pull request to fix issues.

Since yesterday I test a new version in my productive environment. It looks good so far. I’ll prepare a new release today.

1 Like

Hi @csowada,

thanks for spending yet another share of your time for this great binding. It works quite well for me, especially putting and displaying some interesting values on my KNX bus. I am using the addresses 08 for general variables, 76 for SM1 and 51 for MM. Have not figured out the additional addresses 0C, 15, 35, 51 and 75 yet.

If I may ask/suggest some small things:

  • As written previously, in contrast to most other Wolf SM1 variables, the value for the “Return temperature” is not updated automatically. If I force a polling, then I get an error message. Bug or do I overlook something?
2019-12-28 12:14:38.412 [ERROR] [dev.ebus.core.EBusLowLevelController] - emergency break!!!!
  • I would like to change the DHW and heating program via my BM controller. However, this option is only available for your BM2 Thing, which does not work for my BM. Any hint?
  • I get the “DHW force status” via the MM Thing. Any way to trigger it remotely, i.e., to force a warm water heating cylce before taking a bath etc.?. This would be cool.

Thanks again for your effort.


Hello @tkropf,

I’ve added a commadn in the next release to set the heating mode from a BM1. I can’t check if it works, but you can try it. Feedback are always welcome.

Your other issue with the Solar return temperature,

2019-12-28 12:14:38.412 [ERROR] [dev.ebus.core.EBusLowLevelController] - emergency break!!!!

Try “E1 - Return temp” instead. I use this value for my environment.

I will add the command for heating mode. But completely untested!

Sorry, I have no telegram information to force the DHW

Hallo @All,

I’ve decided to release the eBUS binding! So it is not called Alpha, Beta or RC anymore. Due to the release I’ve started a new thread. Please use this thread for all questions to the new release.

Hi @csowada,
thanks for your quick reply, much appreciated

I tried “E1 - Return temp” , same issue. If I force a read on my BM directly, the correct value shows up in your binding. Thus, SM1 address and variable address seem to work. As soon as I force a polling, the error message occurs. Strange.

I discovered your BM heating program command. Unfortunately, it does not work, same error message as above.

Eventually, I will have to dig myself in the eBus protocol, which I avoided until now (seems pretty tedious). I do have an ancient Wold ISM2 PC interface and a “Wolf WRS Soft” software, thus with an old Win95 laptop I can access and change all values (exampes enclosed). Thus I should be able to log the bus traffic. However, the weather today is too nice :wink:

Heizgerät.prn.pdf (167.8 KB) Solarkreis.prn.pdf (147.4 KB)

Hi @dkuschmierz, @Peter1984,

I saw that both of you have also a Vaillant VWL. I own a VWL 102/3 S, but I think regarding eBUS codes, it should be identically to yours.
My current situation is, that I did not find any config (json) files for this type. I have ebusd running and can read a lot of values manually. Now, I want to integrate it into openhab using the great binding from csowada (a great thank you for the binding and the support here in the forum).

Did you create already json files which you could share?

Fyi: “ebusctl info” shows me:

version: ebusd 3.4.v3.3-51-g57eae05
signal: acquired
symbol rate: 116
max symbol rate: 141
min arbitration micros: 763
max arbitration micros: 1038
min symbol latency: 5
max symbol latency: 6
reconnects: 0
masters: 3
messages: 738
conditional: 262
poll: 3
update: 59
address 03: master #11
address 08: slave #11, scanned "MF=Vaillant;ID=EHP00;SW=0419;HW=7201", loaded "vaillant/08.ehp.csv"
address 10: master #2
address 15: slave #2, scanned "MF=Vaillant;ID=UIH00;SW=0374;HW=6901", loaded "vaillant/15.uih.csv"
address 23: slave, scanned "MF=Vaillant;ID=EHP00;SW=0419;HW=7201", loaded "vaillant/23.ehp.cc.csv"
address 25: slave, scanned "MF=Vaillant;ID=EHP00;SW=0419;HW=7201", loaded "vaillant/25.ehp.hwc.csv"
address 31: master #8, ebusd
address 36: slave #8, ebusd
address 50: slave, scanned "MF=Vaillant;ID=EHP00;SW=0419;HW=7201", loaded "vaillant/50.ehp.mc.csv"
address e0: slave, scanned "MF=Vaillant;ID=OMU00;SW=0118;HW=5202", loaded "vaillant/e0.omu.csv"

Any help appreciated!

Please can you help me to configure vr71?