Endpoint problem? Remote controllers doesn't trigger Fibaro FGD212 Dimmer 2

EDIT feb15: I changed the topic text since I discovered that the problem was not only with Popp wall remotes, but also with a new Fibaro Key Fob remote. I put a detailed update here.

  • Platform information:
    • Hardware: AMD Turion™ II Neo N54L Dual-Core Processor, 16GB RAM SSD hard drive
    • OS: Ubuntu 18.04 LTS
    • Java Runtime Environment: Openjdk 1.8.202
    • openHAB version: 2.4.0, repository Stable
    • Aeotec gen5 z-wave usb controller

I had issues with my z-wave binding just stops working, after trying to find any solution online i gave up and since i had a new zwave usb controller I decided to backup my configuration files and start a fresh install of openhab.

Current installation of openhab is 2.4, set up about a week ago, all my old items, rules and such put in place. I used to have a Zwave.me usb controller, but changed to a aeotec gen5 controller when making a fresh install.

All of my zwave devices have been factory reset and included in my new zwave network, that went without any problems.

I have a number of Popp 009303 wall controllers that I use to control my devices. They are configured in Habmin and associated with the different modules that I want to control directly (they work even if the openhab server is down).

But I have a problem after the fresh install: I’m adding an association to one of my Fibaro dimmer2, save it, but when I press the Popp button nothing happens. Nothing shows up in my log file (zwave is on debug).

I guess the problem has something to do with endpoints:
In my old setup i could associate the Fibaro dimmer modules to my Popp wall controllers, I do remember that they were presented as just “Node XX” in Habmin, no endpoints presented. Now in the new installation, i get “Node XX:endpoint 1” and “Node XX:endpoint 2”. I have tried both of the endpoints but none of them works.
When I look at the zwave database at Chris Jackson’s website, I can see that Fibaro Dimmer2has endpoints 0, 1 and 2. For the problem with my Dimmer2:s perhaps the solution is to be able to send to endpoint 0 some how?

I’ve tried reading up on the theory behind endpoints but i’m still a novice in this matter. any help would be greatly appreciated!

@chris or anyone else, any thoughts on my problem here?

If there is really nothing in the logfile, then the problem is likely associations, or device configuration. I would recommend two things -:

  1. Try to use the latest binding (2.5 milestone 1 at least).
  2. Stop the binding, delete the XML file for this device (in the userdata/zwave folder) and restart the binding (ensuring that debug logging is enabled). Wake up the device a bunch of times so that it is initialised. Attach the log here.

Ok, after some extensive googling i’ve done what you asked;

I uninstalled the zwave binding (in PaperUI).

I found a new zwave binding jar file, org.openhab.binding.zwave-2.5.0-SNAPSHOT.jar (from Jenkins website)

I stopped Openhab, put the jar file in /usr/share/openhab2/addons

I deleted the xml file for node 38, that is the popp wall controller i’m trying to get to control a fibaro dimmer2.

I started openhab and opened habmin. I removed all associations from node 32 except lifeline, saved it and triggered a NIF on the wallcontroller so the config would get to it.

Next I filled in the four available controlgroups (A to D) with: A: Node 8(endpoint 1), B: Node 2, C: Node 7 and D:Node 3.

I triggered a new NIF from the wall controller, and this is the log file from that event:

zwavelog-v2.5-node38-NIF.txt (79.9 KB)

After that I tried the four different buttons on the wall controller, and it works fine with node 2, 3 and 7, but node 8 does not respond.

When I turn on or off any of the three working nodes, i get info in the log file, like this for node 3:

2019-02-13 17:49:22.129 [DEBUG] [WaveSerialHandler$ZWaveReceiveThread] - Receive Message = 01 09 00 04 00 03 03 25 03 00 D4 
2019-02-13 17:49:22.133 [DEBUG] [nal.protocol.ZWaveTransactionManager] - processReceiveMessage input 0<>128 : Message: class=ApplicationCommandHandler[4], type=Request[0], dest=3, callback=0, payload=00 03 03 25 03 00 
2019-02-13 17:49:22.134 [DEBUG] [nal.protocol.ZWaveTransactionManager] - Received msg (0): Message: class=ApplicationCommandHandler[4], type=Request[0], dest=3, callback=0, payload=00 03 03 25 03 00 
2019-02-13 17:49:22.136 [DEBUG] [nal.protocol.ZWaveTransactionManager] - lastTransaction null
2019-02-13 17:49:22.137 [DEBUG] [nal.protocol.ZWaveTransactionManager] - NODE 3: Application Command Request (ALIVE:DONE)
2019-02-13 17:49:22.137 [DEBUG] [ng.zwave.internal.protocol.ZWaveNode] - NODE 3: resetResendCount initComplete=true isDead=false
2019-02-13 17:49:22.137 [DEBUG] [ng.zwave.internal.protocol.ZWaveNode] - NODE 3: Incoming command class COMMAND_CLASS_SWITCH_BINARY, endpoint 0
2019-02-13 17:49:22.137 [DEBUG] [ng.zwave.internal.protocol.ZWaveNode] - NODE 3: SECURITY NOT required on COMMAND_CLASS_SWITCH_BINARY
2019-02-13 17:49:22.138 [DEBUG] [tocol.commandclass.ZWaveCommandClass] - NODE 3: Received COMMAND_CLASS_SWITCH_BINARY V1 SWITCH_BINARY_REPORT
2019-02-13 17:49:22.138 [DEBUG] [dclass.ZWaveBinarySwitchCommandClass] - NODE 3: Switch Binary report, value = 0
2019-02-13 17:49:22.138 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 3: Got an event from Z-Wave network: ZWaveCommandClassValueEvent
2019-02-13 17:49:22.139 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 3: Got a value event from Z-Wave network, endpoint = 0, command class = COMMAND_CLASS_SWITCH_BINARY, value = 0
2019-02-13 17:49:22.139 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 3: Updating channel state zwave:device:9a59f25e:node3:switch_binary to OFF [OnOffType]
2019-02-13 17:49:22.139 [DEBUG] [nal.protocol.ZWaveTransactionManager] - NODE 3: Commands processed 1.
2019-02-13 17:49:22.140 [DEBUG] [nal.protocol.ZWaveTransactionManager] - NODE 3: Checking command org.openhab.binding.zwave.internal.protocol.ZWaveCommandClassPayload@12859b78.
2019-02-13 17:49:22.140 [DEBUG] [nal.protocol.ZWaveTransactionManager] - Transaction completed - outstandingTransactions 0
2019-02-13 17:49:22.141 [DEBUG] [nal.protocol.ZWaveTransactionManager] - Transaction completed - outstandingTransactions 0
2019-02-13 17:49:22.141 [DEBUG] [nal.protocol.ZWaveTransactionManager] - ZWaveReceiveThread queue empty
2019-02-13 17:49:22.141 [DEBUG] [nal.protocol.ZWaveTransactionManager] - Transaction SendNextMessage 0 out at start. Holdoff false.

But for node 8(endpoint 1) there is no response in the logs. My guess to why it works like that is that when iv’e associated the wall controller with the other nodes and press a button, that signal goes straight to the receiving node, and it’s only the receiving node that reports to the controller and log?

All my wall controllers are the same type (they were the only ones that fit with my switch covers) so I have no other kind of remote to test with. But I have tried all my wall controllers, and it seems they can control any node that had no endpoint showing in habmin, but endpoints don’t seem to work.

In my previous installation I had the Snapshot release, and with that there were no endpoints presented for Fibaro Dimmers 2 in habmin. But associating with my Fibaro Double Switch worked partly, there was two endpoints in habmin and if I chose endpoint 1 or 2 still triggered the same relay in Fibaro.

I have a layman’s idea about this that has evolved while writing this text, perhaps you can tell me what you think of it:
As mentioned in my topic i had a look in your zwave database. And in there both the Fibaro dimmer and the fibaro double switch has three endpoints, 0, 1 and 2. What if my problem comes from endpoints being interpreted or calculated wrong? As i mentioned before fibaro dimmer 2 with the wall controller worked in my old installation, and there was no endpoint showing for those nodes in habmin, with makes me think no endpoint = endpoint 0? Perhaps if the list of nodes showed Node XX(endpoint 0) and (endpoint 1) in stead of 1 and 2? That could solve both my problems if my idea is right? Before my renstall the wall controllers sent to node 0 and the dimmer responded, but now it tries to send to endpoint 1 and that doesn’t trigger the dimmer? The problem could be the same with my Double switch where one of the two channels never worked, even though I tried associating them with endpoint 1 and 2 which were available in habmin. And the fact that both endpoint 1 and 2 controls the same relay may indicate something like this?

Phew, that became a lot of text, i really hope you can help me, i’ve solved it temporarily by using scenes and made rules to turn the dimmers on and off, but I would like it to work without the server as well.

Please can you provide a log from the startup as I suggested. I want to see how the device is configured.

But that would be wrong I think? Endpoint 0 is the root endpoint - it has certain functionality, while endpoints 1 and 2 contain specific functionality for that endpoint.

All of the association configurations are using the old command class that doesn’t support endpoints - this is probably the issue, but I don’t know why. I’d need to see the initialisation log to understand what the device reports.

We need to see what is happening during the initialisation of the device. This is when the associations are configured.

@chris I didn’t understand that you wanted the log from the startup.

The file is about 5MB and that is too big for this site. Can you get it here?

New info: Today I purchased a Fibaro Key Fob remote control. Previously I had only the Popp brand of remote and I wanted to rule out if the problem is in the remote or elsewhere.

I included the Key fob in my z-wave network and set some associations. And my problems are just the same:

If I associate the Fibaro Key fob (or the Popp wall controller) with any one of my many Fibaro Dimmer2, I get no response from the Dimmer2 when trying to turn on or off with the remote. If I use Openhab it works just fine. I can control other Z-wave actuators from both my Popp controllers and from my new Fibaro Key Fob.
I’m surprised that the Fibaro Key Fob doesn’t play nicely with the Fibaro dimmer2:s, since they are the same brand. That makes me even more sure that the problem lies in how the associations I set are sent from Openhab to the remotes. Unfortunately I have no idea what the problem can be, since I’m still a newbie at the deeper secrets of Zwave and openhab.

As I wrote in a separate post I also have a problem with a Fibaro FGS-222 Double Switch, associating with the two different endpoints doesn’t work either, only endpoint 1 is responding, but it responds even when sending commands to endpoint 2.

I did a series of tests today, with the new Fibaro Key fob remote, and saved the logs for each test.

The tests (and results) were:

Sending ON  from Fibaro keyfob to Fibaro FGD-212 dimmer2, endpoint 1:
Result: Light does not turn on, nothing at all in log.

Sending on from Fibaro keyfob to Fibaro FGD-212 dimmer2, endpoint 2:
Result: Light does not turn on, nothing at all in log.

Sending ON from openhab app to Fibaro FGD-212 dimmer2, endpoint 1 in openhab code (...node8:switch_binary1):
Result: turns on, information in log.

Sending ON from openhab app to Fibaro FGD-212 dimmer2, endpoint 2 in openhab code (...node8:switch_binary2):
Result: Light turns does not turn on, information in log.

Sending ON from Fibaro keyfob to Fibaro FGS-222 double relay switch, Node 27, endpoint 1 (association set in Habmin):
Result: Relay 1 is turning on, relay 2 remains off, information in log.

Sending ON from Fibaro keyfob to Fibaro FGS-222 double relay switch, Node 27, endpoint 2 (association set in Habmin):
Result: Relay 1 is turning on, relay 2 remains off, information in log.

Trying a different model of actuator, just to see if that works with the new remote:
Sending ON from Fibaro keyfob to Telldus on/off-switch, configured with association group in habmin; Node 2,(no endpoints presented for that kind of device) : 
Result: Telldus switch turns on, information in log.

All the logs were too big to fit in this reply, so they are in this file:
zwave search for pattern sending to endpoints.txt (95.0 KB)

My Fibaro Keyfob was set up like this, using Habmin:
Association groups:
1: Controller (node 1)
2: Node 8:endpoint 1 (Fibaro Dimmer2)
4: Node 8:endpoint 2 (Fibaro Dimmer2)
6: Node 27:endpoint 1 (Fibaro Double Switch)
8: Node 27:endpoint 2 (Fibaro Double Switch)
10: Node 2:no endpoint visible in habmin (Telldus Wall Plug Switch)

Log from when clicking Save in Habmin after selecting nodes for association groups and from when initiating a NIF from the key fob is in this file:
Configure associations Keyfob .txt (76.5 KB)

The only thing I’ve found so far while trying to learn reading zwave logs is that when sending ON to the fibaro double switch from the keyfob is that even though i’ve configured the association in Habmin to endpoint 1, this is what i find in the log:

2019-02-15 21:01:27.807 [DEBUG] [ng.zwave.internal.protocol.ZWaveNode] - NODE 27: Incoming command class COMMAND_CLASS_SWITCH_BINARY, endpoint 0 

Even when sending to endpoint 2 the result in the log is the same:

2019-02-15 21:03:05.235 [DEBUG] [ng.zwave.internal.protocol.ZWaveNode] - NODE 27: Incoming command class COMMAND_CLASS_SWITCH_BINARY, endpoint 0

That must be the reason for why both the buttons on the remote turns Relay 1 on, and none of the buttons do anything to Relay 2? But why?

After associating the Dimmer2 to my Keyfob and pressing buttons trying to control the dimmer2 there is nothing in the logs at all, no response. I can see a green LED lighting up on the Keyfob every time I press a button, and according to the manual that means: “Receiving command confirmed by the controller and associated devices” so that must mean the data must reach the Dimmer2 and be confirmed, but it is not triggering the dimmer to turn on.
If the communication from the Keyfob would have been wrong in any way the LED would have been red instead.
In my previous installation of Openhab (I used the Snapshot daily repository) I could control my Fibaro Dimmer2:s with my remotes. But i’m almost 100% sure that when i configured the associations in Habmin, the nodes of Fibaro Dimmers was presented as just “Node XX”, without endpoints. And now, after a fresh install, i have “Node XX:endpoint 1” and “Node XX:endpoint 2” on all my Fibaro dimmers. Could that be a clue to my problem? And can anyone tell me why there is two endpoints to a Fibaro Dimmer? I understand why there are 2 endpoints to a Double Switch, there are 2 relays in there, but a Fibaro Switch only has 1 dimmer inside?

Is there anyone out there who has a Openhab 2.4 installation, with Zwave binding 2.4, or 2.5 snapshot, and any z-wave remote and Fibaro FGD-212 Dimmer2, or Fibaro FGS-222 Double Switch and could tell me if their setup works or not?

Please can you provide the XML file for the device (from the userdata folder).

Just one point to note -:

There won’t be anything in the logs - if I understand correctly, you have configured the keyfob to send the association to the dimmer - the controller will not see these commands, so will not log anything.

Hi Cris!

Yes, i know there is no.direct result in the log from pressing a button, the only results that do come up is from the receiving unit, right?

I’m not sure which of the devices XML files you want, so here are the xml files for the Fibaro Keyfob, the Fibaro Dimmer2 and Fibaro Double Relay:

network_f82b7b41__node_61.xml (24.8 KB)

Fibaro Dimmer2:
network_f82b7b41__node_8.xml (45.3 KB)

Fibaro Double Relay:
network_f82b7b41__node_27.xml (18.1 KB)

Just of of curiosity (since don’t know how it works yet), there is a number in all my item channels, like this one for example: channel=“zwave:zwave:device:9a59f25e:node61:scene_number”.
When i found the XML files for you i saw a different number in those file names, “f82b7b41”, I thought the number would be the same?

Do you have any theories so far? I’d love to hear any thoughts about the problem! :slight_smile: And thank you very much for putting in the effort for me, You have no idea how much I appreciate that, @chris!

Also, @chris, when i go to the Association Groups in Habmin, set nodes for lifeline and other associations, save, and leaves that page and returns to / reloads that page, it often looks like this:

The Lifeline/controller association appears to have disappeared, and other association only shows up as X-es in a grey box. Do you have any idea why this happens? I’m using a mac with the latest version of Safari browser.

I have found kind of a solution, after much thinking about what the difference between my old and new installation was I discovered that there is a setting for my new zwave-controller (aeotec zstick gen5) for security; Always, with lock devices and off. And it was turned on by default it seems, so all my inclusions with my Fibaro dimmers became secure.

So today I first changed the settings in paperUI to only use security to “Entry Control Devices”, and excluded one of my dimmer2s and included it again. After that it works to set an association in my Popp wall controller and my Fibaro Keyfob to NodeXX:endpoint1 and i can control the light.

So the problem seems to be related to security. I’d rather not exclude and include all my dimmer2:s, is there perhaps any other way to get around that, @chris? Is this error/behaviour something that can be changed in a future binding file? Or is there any other way to disable security on a device that is already included in the zwave network?

The problem with my Fibaro Double Switch is still there, when I associate endpoint 1 or endpoint 2 they both trigger relay 1. And that device is not Zwave+ so it has no security.